gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / jrnl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <address@hidden>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages jrnl)
23 #:use-module (guix packages)
24 #:use-module (guix licenses)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system python)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages python)
29 #:use-module (gnu packages python-crypto)
30 #:use-module (gnu packages python-xyz)
31 #:use-module (gnu packages time))
32
33 (define-public jrnl
34 (package
35 (name "jrnl")
36 (version "1.9.7")
37 (source
38 (origin
39 (method git-fetch)
40 (uri (git-reference
41 (url "https://github.com/maebert/jrnl")
42 (commit version)))
43 (file-name (git-file-name name version))
44 (sha256
45 (base32 "1bjjyfc3fnsy0h299s3jj42wnigj43xdyp5ppi1cvkqbwl369935"))))
46 (build-system python-build-system)
47 (native-inputs
48 `(("behave" ,behave)))
49 (inputs
50 `(("python" ,python)
51 ("python-keyring" ,python-keyring)
52 ("python-pycrypto" ,python-pycrypto)
53 ("python-pytz" ,python-pytz)
54 ("python-tzlocal" ,python-tzlocal)
55 ("python-six" ,python-six)
56 ("python-dateutil" ,python-dateutil)
57 ("python-parsedatetime" ,python-parsedatetime)))
58 (home-page "https://maebert.github.io/jrnl/")
59 (synopsis "Personal journal application")
60 (description
61 "Jrnl is a command line journal application that stores your journal in a
62 plain text file. Optionally, your journal can be encrypted using 256-bit AES
63 encryption.")
64 (license x11)))