gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / iso-codes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages iso-codes)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system python)
27 #:use-module (gnu packages gettext)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages python))
30
31 (define-public iso-codes
32 (package
33 (name "iso-codes")
34 (version "3.77")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append
38 "https://pkg-isocodes.alioth.debian.org/downloads/iso-codes-"
39 version ".tar.xz"))
40 (sha256
41 (base32
42 "140dgygv22a49xb8x1941xr5ff12cphd9zzwxds98pgrqsj77k91"))))
43 (build-system gnu-build-system)
44 (inputs
45 `(("gettext" ,gettext-minimal)
46 ("perl" ,perl)
47 ("python" ,python-wrapper)))
48 (home-page "https://salsa.debian.org/iso-codes-team/iso-codes")
49 (synopsis "Various ISO standards")
50 (description
51 "This package provides lists of various ISO standards (e.g. country,
52 language, language scripts, and currency names) in one place, rather
53 than repeated in many programs throughout the system.
54
55 Currently there are lists of languages and countries embedded in
56 several different programs, which leads to dozens of lists of
57 200 languages, translated into more than 30 languages... not
58 very efficient.
59
60 With this package, we create a single \"gettext domain\" for every
61 supported ISO standard which contains the translations of
62 that domain. It is easy for a programmer to re-use those
63 translations instead of maintaining their own translation
64 infrastructure. Moreover, the programmer does not need to follow
65 changes in the ISO standard and will not work with outdated
66 information.")
67 (license license:gpl2+))) ; some bits use the lgpl2
68
69 (define-public python-iso639
70 (package
71 (name "python-iso639")
72 (version "0.4.5")
73 (source
74 (origin
75 (method url-fetch)
76 (uri (pypi-uri "iso-639" version))
77 (sha256
78 (base32
79 "0jffmh4m20q8j27xb2fqbnlghjj0cx8pgsbzqisdg65qh2wd976w"))))
80 (build-system python-build-system)
81 (home-page "https://github.com/noumar/iso639")
82 (synopsis "Python library for ISO 639 standard")
83 (description "This package provides a Python library for ISO 639 standard
84 that is concerned with representation of names for languages and language
85 groups.")
86 (license license:agpl3+)))
87
88 (define-public python2-iso639
89 (package-with-python2 python-iso639))
90
91 (define-public python-iso3166
92 (package
93 (name "python-iso3166")
94 (version "0.9")
95 (source
96 (origin
97 (method url-fetch)
98 (uri (pypi-uri "iso3166" version))
99 (sha256
100 (base32
101 "0hm0xm30sprk1jssmn4cqks0x3nx5fp8r5ypvahcysmmayzrsnjl"))))
102 (build-system python-build-system)
103 (home-page "https://github.com/deactivated/python-iso3166")
104 (synopsis "Self-contained ISO 3166-1 country definitions")
105 (description "This package provides the ISO 3166-1 country definitions.")
106 (license license:expat)))
107
108 (define-public python2-iso3166
109 (package-with-python2 python-iso3166))