gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / gnustep.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages gnustep)
23 #:use-module (guix download)
24 #:use-module (guix packages)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix licenses)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages xorg)
30 #:use-module (gnu packages libffcall)
31 #:use-module (gnu packages gnome)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages texinfo)
34 #:use-module (gnu packages autotools)
35 #:use-module (gnu packages glib)
36 #:use-module (gnu packages fontutils)
37 #:use-module (gnu packages image)
38 #:use-module (gnu packages pkg-config)
39 #:use-module (gnu packages xml)
40 #:use-module (ice-9 match))
41
42 (define-public gnustep-make
43 (package
44 (name "gnustep-make")
45 (version "2.7.0")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append "ftp://ftp.gnustep.org/pub/gnustep/core/"
49 name "-" version ".tar.gz"))
50 (sha256
51 (base32
52 "1khiygfkz0zhh9b5nybn40g0xnnjxchk24n49hff1bwanszir84h"))))
53 (build-system gnu-build-system)
54 (arguments
55 '(#:tests? #f)) ; no check target
56 (native-inputs
57 `(("which" ,which)))
58 (home-page "http://gnustep.org")
59 (synopsis "GNUstep make package")
60 (description "The makefile package is a simple, powerful and extensible way
61 to write makefiles for a GNUstep-based project. It allows the user to write a
62 project without having to deal with the complex issues associated with
63 configuration, building, installation, and packaging. It also allows the user
64 to easily create cross-compiled binaries.")
65 (license gpl3+)))
66
67 (define-public windowmaker
68 (package
69 (name "windowmaker")
70 (version "0.95.9")
71 (synopsis "NeXTSTEP-like window manager")
72 (source (origin
73 (method url-fetch)
74 (uri (string-append
75 "https://github.com/window-maker/wmaker/releases/download/"
76 "wmaker-" version "/WindowMaker-" version ".tar.gz"))
77 (sha256
78 (base32
79 "055pqvlkhipyjn7m6bb3fs4zz9rd1ynzl0mmwbhp05ihc3zmh8zj"))))
80 (build-system gnu-build-system)
81 (arguments
82 `(#:modules ((guix build gnu-build-system)
83 (guix build utils)
84 (ice-9 match))
85 #:phases
86 (modify-phases %standard-phases
87 (add-before 'configure 'pre-configure
88 (lambda* (#:key outputs #:allow-other-keys)
89 ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
90 ;; and the 'wmsetbg', so make sure it uses the right ones.
91 ;; We can't use a wrapper here because that would pollute
92 ;; $PATH in the whole session.
93 (let* ((out (assoc-ref outputs "out"))
94 (bin (string-append out "/bin")))
95 (substitute* "src/main.c"
96 (("\"wmaker\\.inst")
97 (string-append "\"" bin "/wmaker.inst")))
98 (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
99 (("\"wmsetbg")
100 (string-append "\"" bin "/wmsetbg")))
101 ;; Add enough cells to the command character array to
102 ;; allow passing our large path to the wmsetbg binary.
103 ;; The path to wmsetbg in Guix requires 67 extra characters.
104 (substitute* "src/defaults.c"
105 (("len = strlen\\(text\\) \\+ 40;")
106 (string-append "len = strlen(text) + 107;")))
107 #t)))
108 (add-after 'install 'install-xsession
109 (lambda* (#:key outputs #:allow-other-keys)
110 (let* ((out (assoc-ref outputs "out"))
111 (xsessions (string-append out "/share/xsessions")))
112 (mkdir-p xsessions)
113 (call-with-output-file
114 (string-append xsessions "/windowmaker.desktop")
115 (lambda (port)
116 (format port "~
117 [Desktop Entry]~@
118 Name=Window Maker~@
119 Comment=~a~@
120 Exec=~a/bin/wmaker~@
121 Type=Application~%"
122 (string-map (match-lambda
123 (#\newline #\space)
124 (chr chr))
125 ,synopsis) out))))
126 #t))
127 (add-after 'install-xsession 'wrap
128 (lambda* (#:key outputs #:allow-other-keys)
129 (let* ((out (assoc-ref outputs "out"))
130 (bin (string-append out "/bin")))
131 ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
132 ;; etc., so make sure everything is in $PATH.
133 (wrap-program (string-append bin "/wmaker.inst")
134 `("PATH" ":" prefix (,bin)))
135 #t))))))
136 (inputs
137 `(("libxmu" ,libxmu)
138 ("libxft" ,libxft)
139 ("libx11" ,libx11)
140 ("libxinerama" ,libxinerama)
141 ("fontconfig" ,fontconfig)
142 ("libjpeg" ,libjpeg-turbo)
143 ("giflib" ,giflib)
144 ("libpng" ,libpng)
145 ("libtiff" ,libtiff)))
146 (native-inputs
147 `(("pkg-config" ,pkg-config)))
148 (home-page "https://windowmaker.org/")
149 (description
150 "Window Maker is an X11 window manager originally designed to provide
151 integration support for the GNUstep Desktop Environment. In every way
152 possible, it reproduces the elegant look and feel of the NeXTSTEP user
153 interface. It is fast, feature rich, easy to configure, and easy to use.")
154
155 ;; Artwork is distributed under the WTFPL.
156 (license gpl2+)))
157
158 (define-public wmbattery
159 (package
160 (name "wmbattery")
161 (version "2.54")
162 (source (origin
163 (method url-fetch)
164 (uri (string-append
165 "mirror://debian/pool/main/w/wmbattery/wmbattery_"
166 version ".orig.tar.gz"))
167 (sha256
168 (base32
169 "1r4n58mwkm69y1pjs7l64hg8r1lpndrzyrfl2rdgd4zi6v0jhyyw"))))
170 (build-system gnu-build-system)
171 (arguments '(#:tests? #f)) ; no "check" target
172 (inputs
173 `(("glib" ,glib)
174 ("libx11" ,libx11)
175 ("libxext" ,libxext)
176 ("libxpm" ,libxpm)
177 ("upower" ,upower)))
178 (native-inputs
179 `(("pkg-config" ,pkg-config)))
180 (home-page "https://www.dockapps.net/wmbattery")
181 (synopsis "Display laptop battery info")
182 (description
183 "Wmbattery displays the status of your laptop's battery in a small icon.
184 This includes if it is plugged in, if the battery is charging, how many minutes
185 of battery life remain, battery life remaining (with both a percentage and a
186 graph), and battery status (high - green, low - yellow, or critical - red).")
187 (license gpl2)))
188
189 (define-public wmnd
190 (package
191 (name "wmnd")
192 (version "0.4.18")
193 (source (origin
194 (method url-fetch)
195 (uri (string-append
196 "http://www.thregr.org/~wavexx/software/wmnd/releases/"
197 name "-" version ".tar.gz"))
198 (sha256
199 (base32
200 "01s37d8cfpncza1mlw13ar4rcwbrc1vgaj3ifhglmlcnzvvayg0n"))))
201 (build-system gnu-build-system)
202 (inputs
203 `(("libx11" ,libx11)
204 ("libxext" ,libxext)
205 ("libxpm" ,libxpm)))
206 (native-inputs
207 `(("pkg-config" ,pkg-config)))
208 (home-page "http://www.thregr.org/~wavexx/software/wmnd/")
209 (synopsis "Network interface monitor")
210 (description
211 "WMND is a dockapp for monitoring network interfaces under WindowMaker and
212 other compatible window managers.")
213 (license gpl2+)))
214
215 (define-public wmcpuload
216 (package
217 (name "wmcpuload")
218 (version "1.1.1")
219 (source (origin
220 (method url-fetch)
221 (uri (string-append
222 "mirror://debian/pool/main/w/wmcpuload/"
223 name "_" version ".orig.tar.gz"))
224 (sha256
225 (base32
226 "1334y0axnxydwv05d172f405iljrfakg4kcyg9kmn46v6ywv424g"))))
227 (build-system gnu-build-system)
228 (inputs
229 `(("libx11" ,libx11)
230 ("libxext" ,libxext)
231 ("libxpm" ,libxpm)))
232 (native-inputs
233 `(("pkg-config" ,pkg-config)))
234 (home-page "https://www.dockapps.net/wmcpuload")
235 (synopsis "Monitor CPU usage")
236 (description
237 "Wmcpuload displays the current CPU usage, expressed as a percentile and a
238 chart, and has an LCD look-alike user interface. The back-light may be turned
239 on and off by clicking the mouse button over the application. If the CPU usage
240 hits a certain threshold, an alarm-mode will alert you by turning back-light
241 on.")
242 (license gpl2+)))
243
244 (define-public wmclock
245 (package
246 (name "wmclock")
247 (version "1.0.16")
248 (source (origin
249 (method url-fetch)
250 (uri (string-append
251 "mirror://debian/pool/main/w/wmclock/"
252 name "_" version ".orig.tar.gz"))
253 (sha256
254 (base32
255 "1lx276ba8r2yydhmwj1g586jdqg695ad89ng36fr3mb067gvb2rz"))))
256 (build-system gnu-build-system)
257 (inputs
258 `(("libx11" ,libx11)
259 ("libxext" ,libxext)
260 ("libxpm" ,libxpm)))
261 ;; wmclock requires autoreconf to generate its configure script.
262 (native-inputs
263 `(("autoconf" ,autoconf)
264 ("automake" ,automake)
265 ("pkg-config" ,pkg-config)))
266 (home-page "https://www.dockapps.net/wmclock")
267 (synopsis "Display the date and time")
268 (description
269 "wmclock is an applet for Window Maker which displays the date and time in
270 a dockable tile. It features multiple language support, 24h or 12h time
271 display, and can run a user-specified program on mouse click.")
272 (license gpl2+)))
273
274 (define-public wmfire
275 (package
276 (name "wmfire")
277 (version "1.2.4")
278 (source (origin
279 (method url-fetch)
280 (uri (string-append "http://www.improbability.net/"
281 name "/" name "-" version ".tar.gz"))
282 (sha256
283 (base32
284 "101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))
285 (patches
286 (search-patches "wmfire-update-for-new-gdk-versions.patch"))))
287 (build-system gnu-build-system)
288 (inputs
289 `(("gtk+" ,gtk+-2)
290 ("libgtop" ,libgtop)))
291 (native-inputs
292 `(("pkg-config" ,pkg-config)))
293 (home-page "http://www.improbability.net/")
294 (synopsis "Display flames to represent resource usage")
295 (description
296 "wmfire is an applet for Window Maker that can monitor the average cpu
297 load, or individual cpu load on SMP computers. Additionally it can monitor the
298 memory, network load, a file or just be set to show a pretty flame. On
299 entering the dock a burning spot replaces the cursor, and after two seconds
300 symbols to represent the current monitor are \"burnt\" onscreen. The flame
301 colour can also be changed.")
302 (license gpl2+)))