gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / dico.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages dico)
23 #:use-module (guix packages)
24 #:use-module ((guix licenses) #:select (gpl3+))
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages readline)
29 #:use-module (gnu packages m4)
30 #:use-module (gnu packages groff)
31 #:use-module (gnu packages guile)
32 #:use-module (gnu packages python)
33 #:use-module (gnu packages pcre)
34 #:use-module (gnu packages gsasl)
35 #:use-module (gnu packages autotools)
36 #:use-module (gnu packages compression)
37 #:use-module (gnu packages wordnet))
38
39 (define-public dico
40 (package
41 (name "dico")
42 (version "2.9")
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "mirror://gnu/dico/dico-"
46 version ".tar.xz"))
47 (sha256
48 (base32
49 "0i9xqhy3h5nlizcmav4mv5ay8ivdgn4l4k0k7fxix3fsc87nijyr"))))
50 (build-system gnu-build-system)
51 (arguments
52 '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
53 "/share/guile/site/2.0"))
54 #:make-flags '("V=1")
55 #:phases (modify-phases %standard-phases
56 (add-before 'check 'silence-guile
57 (lambda _
58 ;; Guile is too talkative, which disturbs the test
59 ;; infrastructure. Gag it.
60 (setenv "GUILE_AUTO_COMPILE" "0")
61 (setenv "GUILE_WARN_DEPRECATED" "no")
62 #t))
63 (replace 'check
64 (lambda _
65 ;; Test '71: append + dooffs + env' fails if $V is not 2.
66 (invoke "make" "check" "V=2"))))))
67 (native-inputs `(("groff" ,groff)))
68 (inputs
69 `(("m4" ,m4) ;used at run time
70 ("pcre" ,pcre)
71 ("python" ,python-2)
72 ("guile" ,guile-2.2)
73 ("gsasl" ,gsasl)
74 ("readline" ,readline)
75 ("zlib" ,zlib)
76 ("wordnet" ,wordnet)
77 ("libltdl" ,libltdl)))
78 (home-page "https://www.gnu.org/software/dico/")
79 (synopsis "Implementation of DICT server (RFC 2229)")
80 (description
81 "GNU Dico implements a flexible dictionary server and client according to
82 RFC 2229 (DICT Server). It is able to access any database available,
83 regardless of format, thanks to its modular structure. New modules may be
84 written in C, Guile or Python. Dico also includes a command-line client,
85 which may be used to query remote dictionary databases.")
86 (license gpl3+)))