gnu: gdk-pixbuf: Make it reproducible.
[jackhill/guix/guix.git] / gnu / packages / benchmark.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages benchmark)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages linux))
26
27 (define-public fio
28 (package
29 (name "fio")
30 (version "2.16")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append
34 "http://brick.kernel.dk/snaps/"
35 "fio-" version ".tar.bz2"))
36 (sha256
37 (base32
38 "1v5n5hq500aidwfzmbm3k5d3mhh6ffwbgzq7nys838azga4xd3bx"))))
39 (build-system gnu-build-system)
40 (arguments
41 '(#:tests? #f ; No tests.
42 #:phases
43 (modify-phases %standard-phases
44 (replace 'configure
45 (lambda* (#:key outputs #:allow-other-keys)
46 ;; The configure script doesn't understand some of the
47 ;; GNU options, so we can't use #:configure-flags.
48 (let ((out (assoc-ref outputs "out")))
49 (zero? (system* "./configure"
50 (string-append "--prefix=" out)))))))))
51 (inputs
52 `(("libaio" ,libaio)
53 ("zlib" ,zlib)))
54 (home-page "https://github.com/axboe/fio")
55 (synopsis "Flexible I/O tester")
56 (description
57 "fio is a tool that will spawn a number of threads or processes doing a
58 particular type of I/O action as specified by the user. The typical use of fio
59 is to write a job file matching the I/O load one wants to simulate.")
60 ;; The software is distributed under the GPL2, but a handful of components
61 ;; are covered by other licenses.
62 (license (list license:gpl2 license:gpl2+ license:bsd-2
63 license:public-domain))))