Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libusb.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
5 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
6 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
8 ;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
9 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages libusb)
28 #:use-module (gnu packages)
29 #:use-module ((guix licenses) #:prefix license:)
30 #:use-module (guix packages)
31 #:use-module (guix utils)
32 #:use-module (guix download)
33 #:use-module (guix git-download)
34 #:use-module (guix build-system ant)
35 #:use-module (guix build-system cmake)
36 #:use-module (guix build-system gnu)
37 #:use-module (guix build-system glib-or-gtk)
38 #:use-module (guix build-system python)
39 #:use-module (gnu packages autotools)
40 #:use-module (gnu packages gnupg)
41 #:use-module (gnu packages gtk)
42 #:use-module (gnu packages java)
43 #:use-module (gnu packages linux)
44 #:use-module (gnu packages mp3)
45 #:use-module (gnu packages pkg-config)
46 #:use-module (gnu packages python)
47 #:use-module (gnu packages python-xyz)
48 #:use-module (gnu packages tls)
49 #:use-module (gnu packages xiph))
50
51 (define-public libusb
52 (package
53 (name "libusb")
54 (version "1.0.22")
55 (source
56 (origin
57 (method url-fetch)
58 (uri (string-append "mirror://sourceforge/libusb/libusb-1.0/"
59 "libusb-" version "/libusb-" version ".tar.bz2"))
60 (sha256
61 (base32
62 "0mw1a5ss4alg37m6bd4k44v35xwrcwp5qm4s686q1nsgkbavkbkm"))))
63 (build-system gnu-build-system)
64
65 ;; XXX: Enabling udev is now recommended, but eudev indirectly depends on
66 ;; libusb.
67 (arguments `(#:configure-flags '("--disable-udev")))
68 ;; (inputs `(("eudev" ,eudev)))
69
70 (home-page "https://libusb.info")
71 (synopsis "User-space USB library")
72 (description
73 "Libusb is a library that gives applications easy access to USB
74 devices on various operating systems.")
75 (license license:lgpl2.1+)))
76
77 (define-public libusb-compat
78 (package
79 (name "libusb-compat")
80 (version "0.1.5")
81 (source
82 (origin
83 (method url-fetch)
84 (uri (string-append "mirror://sourceforge/libusb/"
85 name "-" (version-major+minor version) "/"
86 name "-" version "/"
87 name "-" version ".tar.bz2"))
88 (sha256
89 (base32
90 "0nn5icrfm9lkhzw1xjvaks9bq3w6mjg86ggv3fn7kgi4nfvg8kj0"))))
91 (build-system gnu-build-system)
92 (native-inputs
93 `(("pkg-config" ,pkg-config)))
94 (inputs
95 `(("libusb" ,libusb)))
96 (home-page "https://libusb.info")
97 (synopsis "Compatibility shim for libusb")
98 (description
99 "Libusb-compat provides a shim allowing applications based on older
100 version of libusb to run with newer libusb.")
101 (license license:lgpl2.1+)))
102
103 ;; required by 0xffff, which compiles with libusb-compat, but executes only
104 ;; with libusb-0.1
105 (define-public libusb-0.1
106 (package (inherit libusb)
107 (version "0.1.12")
108 (source
109 (origin
110 (method url-fetch)
111 (uri (string-append "mirror://sourceforge/libusb/libusb-0.1 (LEGACY)/"
112 version "/libusb-" version ".tar.gz"))
113 (sha256
114 (base32
115 "0i4bacxkyr7xyqxbmb00ypkrv4swkgm0mghbzjsnw6blvvczgxip"))
116 (patches (search-patches "libusb-0.1-disable-tests.patch"))))))
117
118 (define-public libusb4java
119 ;; There is no public release so we take the latest version from git.
120 (let ((commit "396d642a57678a0d9663b062c980fe100cc0ea1e")
121 (revision "1"))
122 (package
123 (name "libusb4java")
124 (version (string-append "0-" revision "." (string-take commit 9)))
125 (source (origin
126 (method git-fetch)
127 (uri (git-reference
128 (url "https://github.com/usb4java/libusb4java.git")
129 (commit commit)))
130 (file-name (git-file-name name version))
131 (sha256
132 (base32
133 "0wqgapalhfh9v38ycbl6i2f5lh1wpr6fzwn5dwd0rdacypkd1gml"))))
134 (build-system cmake-build-system)
135 (arguments
136 `(#:tests? #f ; there are no tests
137 #:phases
138 (modify-phases %standard-phases
139 ;; FIXME: libusb 1.0.22 deprecated libusb_set_debug, so the build
140 ;; fails because libusb4java uses a deprecated procedure.
141 (add-after 'unpack 'disable-Werror
142 (lambda _
143 (substitute* "CMakeLists.txt"
144 (("-Werror") ""))
145 #t))
146 (add-before 'configure 'set-JAVA_HOME
147 (lambda* (#:key inputs #:allow-other-keys)
148 (setenv "JAVA_HOME" (assoc-ref inputs "jdk"))
149 #t)))))
150 (inputs
151 `(("libusb" ,libusb)))
152 (native-inputs
153 `(("jdk" ,icedtea "jdk")))
154 (home-page "https://github.com/usb4java/libusb4java/")
155 (synopsis "JNI bindings to libusb")
156 (description
157 "This package provides Java JNI bindings to the libusb library for use
158 with usb4java.")
159 (license license:expat))))
160
161 (define-public java-usb4java
162 (package
163 (name "java-usb4java")
164 (version "1.2.0")
165 (source (origin
166 (method url-fetch)
167 (uri (string-append "https://github.com/usb4java/usb4java/"
168 "archive/usb4java-" version ".tar.gz"))
169 (sha256
170 (base32
171 "0gzpsnzwgsdyra3smq288yvxnwrgvdwxr6g8jbknnsk56kv6wc34"))))
172 (build-system ant-build-system)
173 (arguments
174 `(#:jar-name "usb4java.jar"
175 #:phases
176 (modify-phases %standard-phases
177 ;; Usually, native libusb4java libraries for all supported systems
178 ;; would be included in the jar and extracted at runtime. Since we
179 ;; build everything from source we cannot just bundle pre-built
180 ;; binaries for other systems. Instead, we patch the loader to
181 ;; directly return the appropriate library for this system. The
182 ;; downside is that the jar will only work on the same architecture
183 ;; that it was built on.
184 (add-after 'unpack 'copy-libusb4java
185 (lambda* (#:key inputs #:allow-other-keys)
186 (substitute* "src/main/java/org/usb4java/Loader.java"
187 (("private static String extractLibrary" line)
188 (string-append
189 line "(final String a, final String b) {"
190 "return \""
191 (assoc-ref inputs "libusb4java") "/lib/libusb4java.so"
192 "\"; }\n"
193 "private static String _extractLibrary")))
194 #t))
195 (add-after 'unpack 'disable-broken-tests
196 (lambda _
197 (with-directory-excursion "src/test/java/org/usb4java"
198 ;; These tests should only be run when USB devices are present.
199 (substitute* '("LibUsbGlobalTest.java"
200 "TransferTest.java")
201 (("this.context = new Context\\(\\);")
202 "this.context = null;")
203 (("LibUsb.init") "//"))
204 (substitute* "DeviceListIteratorTest.java"
205 (("this.iterator.remove" line)
206 (string-append "assumeUsbTestsEnabled();" line))))
207 #t)))))
208 (inputs
209 `(("libusb4java" ,libusb4java)
210 ("java-commons-lang3" ,java-commons-lang3)
211 ("java-junit" ,java-junit)
212 ("java-hamcrest-core" ,java-hamcrest-core)))
213 (home-page "http://usb4java.org/")
214 (synopsis "USB library for Java")
215 (description
216 "This package provides a USB library for Java based on libusb and
217 implementing @code{javax.usb} (JSR-80).")
218 (license license:expat)))
219
220 (define-public python-libusb1
221 (package
222 (name "python-libusb1")
223 (version "1.6.4")
224 (source
225 (origin
226 (method url-fetch)
227 (uri (pypi-uri "libusb1" version))
228 (sha256
229 (base32
230 "03b7xrz8vqg8w0za5r503jhcmbd1ls5610jcja1rqz833nf0v4wc"))))
231 (build-system python-build-system)
232 (arguments
233 `(#:modules ((srfi srfi-1)
234 (guix build utils)
235 (guix build python-build-system))
236 #:phases
237 (modify-phases %standard-phases
238 (add-before 'install-license-files 'remove-incorrect-license
239 (lambda* (#:key out #:allow-other-keys)
240 ;; Was relicensed to LGPL 2.1+, but old COPYING file still left
241 ;; in source. Remove it so it does not get installed.
242 (delete-file "COPYING")
243 #t))
244 (add-after 'unpack 'fix-libusb-reference
245 (lambda* (#:key inputs #:allow-other-keys)
246 (substitute* "usb1/libusb1.py"
247 (("libusb_path = ctypes.util.find_library\\(base_name\\)")
248 (string-append
249 "libusb_path = \""
250 (find (negate symbolic-link?)
251 (find-files (assoc-ref inputs "libusb")
252 "^libusb.*\\.so\\..*"))
253 "\"")))
254 #t)))))
255 (inputs `(("libusb" ,libusb)))
256 (home-page "https://github.com/vpelletier/python-libusb1")
257 (synopsis "Pure-python wrapper for libusb-1.0")
258 (description "Libusb is a library that gives applications easy access to
259 USB devices on various operating systems. This package provides a Python
260 wrapper for accessing libusb-1.0.")
261 (license license:lgpl2.1+)))
262
263 (define-public python-pyusb
264 (package
265 (name "python-pyusb")
266 (version "1.0.2")
267 (source
268 (origin
269 (method url-fetch)
270 (uri (pypi-uri "pyusb" version))
271 (sha256
272 (base32
273 "0qkk2jn270jwwl1x26hmdhb14m9kkbrzzwzizdjcl1a29b6756sf"))))
274 (build-system python-build-system)
275 (arguments
276 `(#:tests? #f ; no tests
277 #:modules ((srfi srfi-1)
278 (srfi srfi-26)
279 (guix build utils)
280 (guix build python-build-system))
281 #:phases
282 (modify-phases %standard-phases
283 (add-after 'unpack 'fix-libusb-reference
284 (lambda* (#:key inputs #:allow-other-keys)
285 (substitute* "usb/libloader.py"
286 (("lib = locate_library\\(candidates, find_library\\)")
287 (string-append
288 "lib = \""
289 (find (negate symbolic-link?)
290 (find-files (assoc-ref inputs "libusb")
291 "^libusb-.*\\.so\\..*"))
292 "\"")))
293 #t)))))
294 (inputs
295 `(("libusb" ,libusb)))
296 (home-page "https://pyusb.github.io/pyusb/")
297 (synopsis "Python bindings to the libusb library")
298 (description
299 "PyUSB aims to be an easy to use Python module to access USB devices.")
300 (license license:bsd-3)))
301
302 (define-public python2-pyusb
303 (package-with-python2 python-pyusb))
304
305 (define-public libplist
306 (package
307 (name "libplist")
308 (version "2.0.0")
309 (source (origin
310 (method url-fetch)
311 (uri (string-append "https://www.libimobiledevice.org/downloads/"
312 "libplist-" version ".tar.bz2"))
313 (sha256
314 (base32
315 "00pnh9zf3iwdji2faccns7vagbmbrwbj9a8zp9s53a6rqaa9czis"))))
316 (build-system gnu-build-system)
317 (inputs
318 `(("python" ,python)))
319 (native-inputs
320 `(("pkg-config" ,pkg-config)
321 ("python-cython" ,python-cython)))
322 (home-page "https://www.libimobiledevice.org/")
323 (synopsis "C library to handle Apple Property List files")
324 (description "This package provides a small portable C library to handle
325 Apple Property List files in binary or XML.")
326 (license license:lgpl2.1+)))
327
328 (define-public libusbmuxd
329 (package
330 (name "libusbmuxd")
331 (version "1.0.10")
332 (source (origin
333 (method url-fetch)
334 (uri (string-append "https://www.libimobiledevice.org/downloads/"
335 "libusbmuxd-" version ".tar.bz2"))
336 (sha256
337 (base32
338 "1wn9zq2224786mdr12c5hxad643d29wg4z6b7jn888jx4s8i78hs"))))
339 (build-system gnu-build-system)
340 (native-inputs
341 `(("pkg-config" ,pkg-config)
342 ("libplist" ,libplist)))
343 (home-page "https://www.libimobiledevice.org/")
344 (synopsis "Library to multiplex connections from and to iOS devices")
345 (description "This package provides a client library to multiplex
346 connections from and to iOS devices by connecting to a socket provided by a
347 @code{usbmuxd} daemon.")
348 (license license:lgpl2.1+)))
349
350 (define-public libimobiledevice
351 (package
352 (name "libimobiledevice")
353 (version "1.2.0")
354 (source (origin
355 (method url-fetch)
356 (uri (string-append "https://www.libimobiledevice.org/downloads/"
357 "libimobiledevice-" version ".tar.bz2"))
358 (sha256
359 (base32
360 "0dqhy4qwj30mw8pwckvjmgnj1qqrh6p8c6jknmhvylshhzh0ssvq"))))
361 (build-system gnu-build-system)
362 (arguments
363 `(#:configure-flags
364 (list (string-append "PYTHON_LDFLAGS=-L"
365 (assoc-ref %build-inputs "python")
366 "/lib -lpython"
367 ,(version-major+minor (package-version python))
368 "m"))))
369 (propagated-inputs
370 `(("openssl" ,openssl-1.0)
371 ("libplist" ,libplist)
372 ("libusbmuxd" ,libusbmuxd)))
373 (inputs
374 `(("python" ,python)))
375 (native-inputs
376 `(("pkg-config" ,pkg-config)
377 ("python-cython" ,python-cython)
378 ("libtool" ,libtool)))
379 (home-page "https://www.libimobiledevice.org/")
380 (synopsis "Protocol library and tools to communicate with Apple devices")
381 (description "libimobiledevice is a software library that talks the
382 protocols to support Apple devices. It allows other software to easily access
383 the device's filesystem, retrieve information about the device and it's
384 internals, backup/restore the device, manage installed applications, retrieve
385 addressbook/calendars/notes and bookmarks and (using libgpod) synchronize
386 music and video to the device.")
387 (license license:lgpl2.1+)))
388
389 (define-public ifuse
390 (package
391 (name "ifuse")
392 (version "1.1.3")
393 (source (origin
394 (method url-fetch)
395 (uri (string-append "https://www.libimobiledevice.org/downloads/"
396 "ifuse-" version ".tar.bz2"))
397 (sha256
398 (base32
399 "1p9a4n36jb194cnp6v57cz2bggwbywaz8pbpb95ch83pzdkdx257"))))
400 (inputs
401 `(("fuse" ,fuse)
402 ("libimobiledevice" ,libimobiledevice)))
403 (native-inputs
404 `(("pkg-config" ,pkg-config)))
405 (build-system gnu-build-system)
406 (home-page "https://www.libimobiledevice.org/")
407 (synopsis "Mount iOS devices")
408 (description "This package provides @command{ifuse}, a command to mount
409 iOS devices and access their contents.")
410 (license license:lgpl2.1+)))
411
412 (define-public usbmuxd
413 (package
414 (name "usbmuxd")
415 (version "1.1.0")
416 (source (origin
417 (method url-fetch)
418 (uri (string-append "https://www.libimobiledevice.org/downloads/"
419 "usbmuxd-" version ".tar.bz2"))
420 (sha256
421 (base32
422 "0bdlc7a8plvglqqx39qqampqm6y0hcdws76l9dffwl22zss4i29y"))))
423 (inputs
424 `(("libplist" ,libplist)
425 ("libusb" ,libusb)
426 ("libimobiledevice" ,libimobiledevice)))
427 (native-inputs
428 `(("pkg-config" ,pkg-config)))
429 (build-system gnu-build-system)
430 (home-page "https://www.libimobiledevice.org/")
431 (synopsis "Multiplex connections over USB to an iOS device")
432 (description "This package provides the @code{usbmuxd} daemon
433 which multiplexes connections over USB to an iOS device. To
434 users, it means you can sync your music, contacts, photos, etc.
435 over USB.")
436 (license license:gpl2+)))
437
438 (define-public libmtp
439 (package
440 (name "libmtp")
441 (version "1.1.16")
442 (source (origin
443 (method url-fetch)
444 (uri (string-append "mirror://sourceforge/libmtp/libmtp/" version
445 "/libmtp-" version ".tar.gz"))
446 (sha256
447 (base32
448 "185vh9bds6dcy00ycggg69g4v7m3api40zv8vrcfb3fk3vfzjs2v"))))
449 (build-system gnu-build-system)
450 (native-inputs
451 `(("pkg-config" ,pkg-config)))
452 (propagated-inputs
453 ;; libmtp.pc refers to all these.
454 `(("libgcrypt" ,libgcrypt)
455 ("libusb" ,libusb)))
456 (arguments
457 `(#:configure-flags
458 (list (string-append "--with-udev="
459 (assoc-ref %outputs "out")
460 "/lib/udev"))))
461 (home-page "http://libmtp.sourceforge.net/")
462 (synopsis "Library implementing the Media Transfer Protocol")
463 (description "Libmtp implements an MTP (Media Transfer Protocol)
464 initiator, which means that it initiates MTP sessions with devices. The
465 devices responding are known as MTP responders. Libmtp runs on devices
466 with a USB host controller interface. It implements MTP Basic, which was
467 proposed for standardization.")
468 ;; COPYING contains lgpl2.1, while files headers give
469 ;; "GNU Lesser General Public License as published by the Free Software
470 ;; Foundation; either version 2 of the License, or (at your option) any
471 ;; later version."
472 (license license:lgpl2.1+)))
473
474 (define-public gmtp
475 (package
476 (name "gmtp")
477 (version "1.3.11")
478 (source (origin
479 (method url-fetch)
480 (uri (string-append "mirror://sourceforge/gmtp/gMTP-" version
481 "/gmtp-" version ".tar.gz"))
482 (sha256
483 (base32
484 "04q6byyq002fhzkc2rkkahwh5b6272xakaj4m3vwm8la8jf0r0ss"))))
485 (build-system glib-or-gtk-build-system)
486 (arguments
487 '(#:configure-flags
488 (let ((libid3tag (assoc-ref %build-inputs "libid3tag")))
489 (list
490 ;; libid3tag provides no .pc file, so pkg-config fails to find them.
491 (string-append "ID3TAG_CFLAGS=-I" libid3tag "/include")
492 (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")))))
493 (inputs
494 `(("gtk+" ,gtk+)
495 ("flac" ,flac)
496 ("libvorbis" ,libvorbis)
497 ("libid3tag" ,libid3tag)
498 ("libmtp" ,libmtp)))
499 (native-inputs
500 `(("pkg-config" ,pkg-config)))
501 (home-page "http://gmtp.sourceforge.net/")
502 (synopsis "Simple graphical MTP client")
503 (description "gMTP is a simple graphical client for the Media Transfer Protocol
504 (MTP), which allows media files to be transferred to and from many portable
505 devices.")
506 (license license:bsd-3)))
507
508 (define-public hidapi
509 (package
510 (name "hidapi")
511 (version "0.8.0-rc1")
512 (source (origin
513 (method url-fetch)
514 (uri (string-append "https://github.com/signal11/hidapi/archive/hidapi-"
515 version ".tar.gz"))
516 (sha256
517 (base32
518 "0qdgyj9rgb7n0nk3ghfswrhzzknxqn4ibn3wj8g4r828pw07451w"))))
519 (build-system gnu-build-system)
520 (inputs
521 `(("libusb" ,libusb)
522 ("udev" ,eudev)))
523 (native-inputs
524 `(("autoconf" ,autoconf)
525 ("automake" ,automake)
526 ("libtool" ,libtool)
527 ("pkg-config" ,pkg-config)))
528 (home-page "http://www.signal11.us/oss/hidapi/")
529 (synopsis "HID API library")
530 (description
531 "HIDAPI is a library which allows an application to interface with USB and Bluetooth
532 HID-Class devices.")
533 ;; HIDAPI can be used under one of three licenses.
534 (license (list license:gpl3
535 license:bsd-3
536 (license:non-copyleft "file://LICENSE-orig.txt")))))
537
538 (define-public python-hidapi
539 (package
540 (name "python-hidapi")
541 (version "0.7.99.post21")
542 (source
543 (origin
544 (method url-fetch)
545 (uri (pypi-uri "hidapi" version))
546 (sha256
547 (base32
548 "15ws59zdrxahf3k7z5rcrwc4jgv1307anif8ixm2cyb9ask1mgp0"))
549 (modules '((guix build utils)))
550 (snippet
551 ;; Remove bundled libraries.
552 '(begin
553 (delete-file-recursively "hidapi")
554 #t))))
555 (build-system python-build-system)
556 (arguments
557 `(#:phases
558 (modify-phases %standard-phases
559 (add-after 'unpack 'patch-configuration
560 (lambda* (#:key inputs #:allow-other-keys)
561 (substitute* "setup.py"
562 (("'/usr/include/libusb-1.0'")
563 (string-append "'" (assoc-ref inputs "libusb")
564 "/include/libusb-1.0'"))
565 (("'/usr/include/hidapi'")
566 (string-append "'" (assoc-ref inputs "hidapi")
567 "/include/hidapi'")))
568 #t))
569 ;; XXX Necessary because python-build-system drops the arguments.
570 (replace 'build
571 (lambda _
572 (invoke "python" "setup.py" "build" "--with-system-hidapi")))
573 (replace 'check
574 (lambda _
575 (invoke "python" "setup.py" "test" "--with-system-hidapi")))
576 (replace 'install
577 (lambda* (#:key outputs #:allow-other-keys)
578 (invoke "python" "setup.py" "install" "--with-system-hidapi"
579 (string-append "--prefix=" (assoc-ref outputs "out"))
580 "--single-version-externally-managed" "--root=/"))))))
581 (inputs
582 `(("hidapi" ,hidapi)
583 ("libusb" ,libusb)
584 ("eudev" ,eudev)))
585 (native-inputs
586 `(("python-cython" ,python-cython)))
587 (home-page "https://github.com/trezor/cython-hidapi")
588 (synopsis "Cython interface to hidapi")
589 (description "This package provides a Cython interface to @code{hidapi}.")
590 ;; The library can be used under either of these licenses.
591 (license (list license:gpl3
592 license:bsd-3
593 (license:non-copyleft
594 "https://github.com/trezor/cython-hidapi/blob/master/LICENSE-orig.txt"
595 "You are free to use cython-hidapi code for any purpose.")))))
596
597 (define-public python2-hidapi
598 (package-with-python2 python-hidapi))