Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / gpodder.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gpodder)
20 #:use-module (guix download)
21 #:use-module (guix packages)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix build-system cmake)
24 #:use-module (guix build-system python)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages qt))
29
30 (define-public libmygpo-qt
31 (package
32 (name "libmygpo-qt")
33 (version "1.1.0")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "http://stefan.derkits.at/files/"
37 "libmygpo-qt/libmygpo-qt." version ".tar.gz"))
38 (sha256
39 (base32
40 "1kg18qrq2rsswgzhl65r3mlyx7kpqg4wwnbp4yiv6svvmadmlxl2"))
41 (patches (search-patches "libmygpo-qt-fix-qt-5.11.patch"
42 "libmygpo-qt-missing-qt5-modules.patch"))))
43 (build-system cmake-build-system)
44 (native-inputs
45 `(("pkg-config" ,pkg-config)))
46 (inputs
47 `(("qt" ,qtbase)))
48 (arguments
49 `(#:configure-flags '("-DMYGPO_BUILD_TESTS=ON")
50 ;; TODO: Enable tests when https://github.com/gpodder/gpodder/issues/446
51 ;; is fixed.
52 #:tests? #f))
53 (home-page "http://wiki.gpodder.org/wiki/Libmygpo-qt")
54 (synopsis "Qt/C++ library wrapping the gpodder web service")
55 (description "@code{libmygpo-qt} is a Qt/C++ library wrapping the
56 @url{https://gpodder.net} APIs. It allows applications to discover, manage
57 and track podcasts.")
58 (license license:lgpl2.1+)))
59
60 (define-public python-podcastparser
61 (package
62 (name "python-podcastparser")
63 (version "0.6.4")
64 (source
65 (origin
66 (method url-fetch)
67 (uri (pypi-uri "podcastparser" version))
68 (sha256
69 (base32
70 "1ksj1gcmbnm5i43xhpqxbs2mqi6xzawwwkwbh9h6lwa1wxxvv247"))))
71 (native-inputs
72 `(("python-nose" ,python-nose)))
73 (build-system python-build-system)
74 (home-page "http://gpodder.org/podcastparser")
75 (synopsis "Simplified and fast RSS parser Python library")
76 (description "@code{podcastparser} is a library for the gPodder project to
77 provide an easy and reliable way of parsing RSS and Atom-based podcast feeds
78 in Python.")
79 (license license:isc)))