Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / dico.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages dico)
21 #:use-module (guix packages)
22 #:use-module ((guix licenses) #:select (gpl3+))
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages readline)
27 #:use-module (gnu packages m4)
28 #:use-module (gnu packages groff)
29 #:use-module (gnu packages guile)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages pcre)
32 #:use-module (gnu packages gsasl)
33 #:use-module (gnu packages autotools)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages wordnet))
36
37 (define-public dico
38 (package
39 (name "dico")
40 (version "2.3")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "mirror://gnu/dico/dico-"
44 version ".tar.xz"))
45 (sha256
46 (base32
47 "13by0zimx90v2j8v7n4k9y3xwmh4q9jdc2f4f8yjs3x7f5bzm2pk"))
48 (snippet
49 ;; Upstream commit 89922fc.
50 '(substitute* "include/dico/markup.h"
51 (("const char \\*dico_markup_type;")
52 "extern const char *dico_markup_type;")))
53 (modules '((guix build utils)))))
54 (build-system gnu-build-system)
55 (arguments
56 '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
57 "/share/guile/site/2.0"))
58 #:make-flags '("V=1")
59 #:phases (modify-phases %standard-phases
60 (add-before 'check 'silence-guile
61 (lambda _
62 ;; Guile is too talkative, which disturbs the test
63 ;; infrastructure. Gag it.
64 (setenv "GUILE_AUTO_COMPILE" "0")
65 (setenv "GUILE_WARN_DEPRECATED" "no")
66 #t)))))
67 (inputs
68 `(("m4" ,m4) ;used at run time
69 ("pcre" ,pcre)
70 ("python" ,python-2)
71 ("guile" ,guile-2.0)
72 ("gsasl" ,gsasl)
73 ("groff" ,groff)
74 ("readline" ,readline)
75 ("zlib" ,zlib)
76 ;; ("wordnet" ,wordnet) ;FIXME: link failure
77 ("libltdl" ,libltdl)))
78 (home-page "http://www.gnu.org/software/dico/")
79 (synopsis "Implementation of DICT server (RFC 2229)")
80 (description
81 "GNU Dico implements a flexible dictionary server and client according to
82 RFC 2229 (DICT Server). It is able to access any database available,
83 regardless of format, thanks to its modular structure. New modules may be
84 written in C, Guile or Python. Dico also includes a command-line client,
85 which may be used to query remote dictionary databases.")
86 (license gpl3+)))