gnu: Add python-django-override-storage.
[jackhill/guix/guix.git] / gnu / packages / django.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
5 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
7 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages django)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system python)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages base)
31 #:use-module (gnu packages databases)
32 #:use-module (gnu packages check)
33 #:use-module (gnu packages python)
34 #:use-module (gnu packages python-web)
35 #:use-module (gnu packages time))
36
37 (define-public python-django
38 (package
39 (name "python-django")
40 (version "1.11.11")
41 (source (origin
42 (method url-fetch)
43 (uri (pypi-uri "Django" version))
44 (sha256
45 (base32
46 "1p0fk0dszci9gx76hyhay3n8n0k8r4sznbdcrpd9g2xl15rps1vl"))))
47 (build-system python-build-system)
48 (arguments
49 '(#:modules ((srfi srfi-1)
50 (guix build python-build-system)
51 (guix build utils))
52 #:phases
53 (modify-phases %standard-phases
54 (add-before 'check 'set-tzdir
55 (lambda* (#:key inputs #:allow-other-keys)
56 ;; The test-suite tests timezone-dependent functions, thus tzdata
57 ;; needs to be available.
58 (setenv "TZDIR"
59 (string-append (assoc-ref inputs "tzdata")
60 "/share/zoneinfo"))
61 #t))
62 (replace 'check
63 (lambda* (#:key inputs #:allow-other-keys)
64 (setenv "PYTHONPATH"
65 (string-append ".:" (getenv "PYTHONPATH")))
66 (substitute* "tests/admin_scripts/tests.py"
67 (("python_path = \\[")
68 (string-append "python_path = ['"
69 (find (lambda (entry)
70 (string-prefix?
71 (assoc-ref inputs "python-pytz")
72 entry))
73 (string-split (getenv "PYTHONPATH")
74 #\:))
75 "', ")))
76 (zero? (system* "python" "tests/runtests.py")))))))
77 ;; TODO: Install extras/django_bash_completion.
78 (native-inputs
79 `(("tzdata" ,tzdata-for-tests)
80 ;; bcrypt and argon2-cffi are extra requirements not yet in guix
81 ;;("python-argon2-cffi" ,python-argon2-cffi) ; >= 16.1.0
82 ;;("python-bcrypt" ,python-bcrypt) ; not py-bcrypt!
83 ;; Remaining packages are test requirements taken from
84 ;; tests/requirements/py3.txt
85 ("python-docutils" ,python-docutils)
86 ;; optional for tests: ("python-geoip2" ,python-geoip2)
87 ("python-jinja2" ,python-jinja2) ; >= 2.7
88 ;; optional for tests: ("python-memcached" ,python-memcached)
89 ("python-numpy" ,python-numpy)
90 ("python-pillow" ,python-pillow)
91 ("python-pyyaml" ,python-pyyaml)
92 ;; optional for tests: ("python-selenium" ,python-selenium)
93 ("python-sqlparse" ,python-sqlparse)
94 ("python-tblib" ,python-tblib)))
95 (propagated-inputs
96 `(("python-pytz" ,python-pytz)))
97 (home-page "http://www.djangoproject.com/")
98 (synopsis "High-level Python Web framework")
99 (description
100 "Django is a high-level Python Web framework that encourages rapid
101 development and clean, pragmatic design. It provides many tools for building
102 any Web site. Django focuses on automating as much as possible and adhering
103 to the @dfn{don't repeat yourself} (DRY) principle.")
104 (license license:bsd-3)
105 (properties `((python2-variant . ,(delay python2-django))
106 (cpe-name . "django")))))
107
108 (define-public python2-django
109 (let ((base (package-with-python2 (strip-python2-variant python-django))))
110 (package
111 (inherit base)
112 (native-inputs
113 `(;; Test requirements for Python 2 taken from
114 ;; tests/requirements/py3.txt: enum34 and mock.
115 ("python2-enum34" ,python2-enum34)
116 ("python2-mock" ,python2-mock)
117 ;; When adding memcached mind: for Python 2 memcached <= 1.53 is
118 ;; required.
119 ,@(package-native-inputs base))))))
120
121 (define-public python-django-simple-math-captcha
122 (package
123 (name "python-django-simple-math-captcha")
124 (version "1.0.7")
125 (source (origin
126 (method url-fetch)
127 (uri (pypi-uri "django-simple-math-captcha" version))
128 (sha256
129 (base32
130 "0906hms6y6znjhpd0g4wmzv9vcla4brkdpsm4zha9zdj8g5vq2hd"))))
131 (build-system python-build-system)
132 (arguments
133 ;; FIXME: Upstream uses a 'runtests.py' script that is not
134 ;; present in the pypi tarball.
135 '(#:tests? #f))
136 (propagated-inputs
137 `(("python-django" ,python-django)))
138 (home-page "https://github.com/alsoicode/django-simple-math-captcha")
139 (synopsis "Easy-to-use math field/widget captcha for Django forms")
140 (description
141 "A multi-value-field that presents a human answerable question,
142 with no settings.py configuration necessary, but instead can be configured
143 with arguments to the field constructor.")
144 (license license:asl2.0)))
145
146 (define-public python2-django-simple-math-captcha
147 (package-with-python2 python-django-simple-math-captcha))
148
149 (define-public python-pytest-django
150 (package
151 (name "python-pytest-django")
152 (version "3.1.2")
153 (source (origin
154 (method url-fetch)
155 (uri (pypi-uri "pytest-django" version))
156 (sha256
157 (base32
158 "02932m2sr8x22m4az8syr8g835g4ak77varrnw71n6xakmdcr303"))))
159 (build-system python-build-system)
160 (arguments
161 `(#:tests? #f ; FIXME: How to run tests?
162 #:phases
163 (modify-phases %standard-phases
164 (add-after 'unpack 'patch-setuppy
165 (lambda _
166 (substitute* "setup.py"
167 (("setuptools_scm==1.11.1") "setuptools_scm"))
168 #t)))))
169 (native-inputs
170 `(("python-django" ,python-django)
171 ("python-setuptools-scm" ,python-setuptools-scm)))
172 (propagated-inputs
173 `(("python-pytest" ,python-pytest)))
174 (home-page "http://pytest-django.readthedocs.org/")
175 (synopsis "Django plugin for py.test")
176 (description "Pytest-django is a plugin for py.test that provides a set of
177 useful tools for testing Django applications and projects.")
178 (license license:bsd-3)))
179
180 (define-public python2-pytest-django
181 (package-with-python2 python-pytest-django))
182
183 (define-public python-django-filter
184 (package
185 (name "python-django-filter")
186 (version "1.1.0")
187 (source (origin
188 (method url-fetch)
189 (uri (pypi-uri "django-filter" version))
190 (sha256
191 (base32
192 "0slpfqfhnjrzlrb6vmswyhrzn01p84s16j2x1xib35gg4fxg23pc"))))
193 (build-system python-build-system)
194 (arguments
195 '(#:phases
196 (modify-phases %standard-phases
197 (replace 'check
198 (lambda _
199 (zero? (system* "python" "runtests.py")))))))
200 (native-inputs
201 `(("python-django" ,python-django)
202 ("python-djangorestframework" ,python-djangorestframework)
203 ("python-django-crispy-forms" ,python-django-crispy-forms)
204 ("python-mock" ,python-mock)))
205 (home-page "https://django-filter.readthedocs.io/en/latest/")
206 (synopsis "Reusable Django application to filter querysets dynamically")
207 (description
208 "Django-filter is a generic, reusable application to alleviate writing
209 some of the more mundane bits of view code. Specifically, it allows users to
210 filter down a queryset based on a model’s fields, displaying the form to let
211 them do this.")
212 (license license:bsd-3)))
213
214 (define-public python2-django-filter
215 (package-with-python2 python-django-filter))
216
217 (define-public python-django-allauth
218 (package
219 (name "python-django-allauth")
220 (version "0.30.0")
221 (source
222 (origin
223 (method url-fetch)
224 (uri (pypi-uri "django-allauth" version))
225 (sha256
226 (base32
227 "1fslqc5qqb0b66yscvkyjwfv8cnbfx5nlkpnwimyb3pf1nc1w7r3"))))
228 (build-system python-build-system)
229 (arguments
230 '(#:phases
231 (modify-phases %standard-phases
232 ;; TODO: Tagging the tests requiring the web could be done upstream.
233 (add-before 'check 'skip-test-requiring-network-access
234 (lambda _
235 (substitute* "allauth/socialaccount/providers/openid/tests.py"
236 (("def test_login")
237 "from django.test import tag
238 @tag('requires-web')
239 def test_login"))))
240 (replace 'check
241 (lambda _
242 (setenv "DJANGO_SETTINGS_MODULE" "test_settings")
243 (zero? (system*
244 "django-admin"
245 "test"
246 "allauth"
247 "--verbosity=2"
248 "--exclude-tag=requires-web")))))))
249 (propagated-inputs
250 `(("python-openid" ,python-openid)
251 ("python-requests" ,python-requests)
252 ("python-requests-oauthlib" ,python-requests-oauthlib)))
253 (native-inputs
254 `(("python-mock" ,python-mock)))
255 (inputs
256 `(("python-django" ,python-django)))
257 (home-page "https://github.com/pennersr/django-allauth")
258 (synopsis "Set of Django applications addressing authentication")
259 (description
260 "Integrated set of Django applications addressing authentication,
261 registration, account management as well as 3rd party (social)
262 account authentication.")
263 (license license:expat)))
264
265 (define-public python2-django-allauth
266 (package-with-python2 python-django-allauth))
267
268 (define-public python-django-gravatar2
269 (package
270 (name "python-django-gravatar2")
271 (version "1.4.2")
272 (source
273 (origin
274 (method url-fetch)
275 (uri (pypi-uri "django-gravatar2" version))
276 (sha256
277 (base32
278 "1qsv40xywbqsf4mkrmsswrpzqd7nfljxpfiim9an2z3dykn5rka6"))))
279 (build-system python-build-system)
280 (arguments
281 '(;; TODO: The django project for the tests is missing from the release.
282 #:tests? #f))
283 (inputs
284 `(("python-django" ,python-django)))
285 (home-page "https://github.com/twaddington/django-gravatar")
286 (synopsis "Gravatar support for Django, improved version")
287 (description
288 "Essential Gravatar support for Django. Features helper methods,
289 templatetags and a full test suite.")
290 (license license:expat)))
291
292 (define-public python2-django-gravatar2
293 (package-with-python2 python-django-gravatar2))
294
295 (define-public python-django-assets
296 (package
297 (name "python-django-assets")
298 (version "0.12")
299 (source (origin
300 (method url-fetch)
301 (uri (pypi-uri "django-assets" version))
302 (sha256
303 (base32
304 "0y0007fvkn1rdlj2g0y6k1cnkx53kxab3g8i85i0rd58k335p365"))))
305 (build-system python-build-system)
306 (arguments
307 `(#:phases
308 (modify-phases %standard-phases
309 (add-before 'check 'fix-tests
310 (lambda _
311 (begin
312 ;; https://github.com/miracle2k/django-assets/issues/87
313 (substitute* "tests/__init__.py"
314 (("settings.configure.*")
315 (string-append
316 "settings.configure(\n"
317 "INSTALLED_APPS=['django_assets', "
318 "'django.contrib.staticfiles'],\n"
319 "TEMPLATES=[{'BACKEND': "
320 "'django.template.backends.django.DjangoTemplates'}],\n"
321 ")\n")))
322 ;; These tests fail
323 (substitute* "tests/test_django.py"
324 (("TestLoader") "NoTestLoader"))))))))
325 (native-inputs
326 `(("python-nose" ,python-nose)))
327 (propagated-inputs
328 `(("python-django" ,python-django)
329 ("python-webassets" ,python-webassets)))
330 (home-page "https://github.com/miracle2k/django-assets")
331 (synopsis "Asset management for Django")
332 (description
333 "Asset management for Django, to compress and merge CSS and Javascript
334 files. Integrates the webassets library with Django, adding support for
335 merging, minifying and compiling CSS and Javascript files.")
336 (license license:bsd-2)))
337
338 (define-public python2-django-assets
339 (package-with-python2 python-django-assets))
340
341 (define-public python-django-jsonfield
342 (package
343 (name "python-django-jsonfield")
344 (version "1.0.3")
345 (source (origin
346 (method url-fetch)
347 (uri (pypi-uri "jsonfield" version))
348 (sha256
349 (base32
350 "19x4lak0hg9c20r7mvf27w7i8r6i4sg2g0ypmlmp2665fnk76zvy"))))
351 (build-system python-build-system)
352 (arguments
353 `(#:phases
354 (modify-phases %standard-phases
355 (add-before 'check 'fix-tests
356 (lambda _
357 (substitute* "jsonfield/tests.py"
358 (("django.forms.util") "django.forms.utils")))))))
359 (propagated-inputs
360 `(("python-django" ,python-django)))
361 (home-page "https://github.com/bradjasper/django-jsonfield")
362 (synopsis "Store validated JSON in your model")
363 (description
364 "Django-jsonfield is a reusable Django field that allows you to store
365 validated JSON in your model. It silently takes care of serialization. To
366 use, simply add the field to one of your models.")
367 (license license:expat)))
368
369 (define-public python2-django-jsonfield
370 (package-with-python2 python-django-jsonfield))
371
372 (define-public python-dj-database-url
373 (package
374 (name "python-dj-database-url")
375 (version "0.4.2")
376 (source (origin
377 (method url-fetch)
378 (uri (pypi-uri "dj-database-url" version))
379 (sha256
380 (base32
381 "024zbkc5rli4hia9lz9g8kf1zxhb2gwawj5abf67i7gf8n22v0x6"))))
382 (build-system python-build-system)
383 (home-page "https://github.com/kennethreitz/dj-database-url")
384 (synopsis "Use Database URLs in your Django Application")
385 (description
386 "This simple Django utility allows you to utilize the 12factor inspired
387 DATABASE_URL environment variable to configure your Django application.
388
389 The dj_database_url.config method returns a Django database connection
390 dictionary, populated with all the data specified in your URL. There is also a
391 conn_max_age argument to easily enable Django’s connection pool.")
392 (license license:bsd-2)))
393
394 (define-public python2-dj-database-url
395 (package-with-python2 python-dj-database-url))
396
397 (define-public python-django-bulk-update
398 (package
399 (name "python-django-bulk-update")
400 (version "1.1.10")
401 (source (origin
402 (method url-fetch)
403 (uri (pypi-uri "django-bulk-update" version))
404 (sha256
405 (base32
406 "0mbng9m7swfc0dnidipbzlxfhlfjrv755dlnha5s4m9mgdxb1fhc"))))
407 (build-system python-build-system)
408 (arguments
409 ;; tests don't support django 1.10, but the module seems to work.
410 `(#:tests? #f))
411 (native-inputs
412 `(("six" ,python-six)
413 ("jsonfield" ,python-django-jsonfield)
414 ("python-dj-database-url" ,python-dj-database-url)))
415 (propagated-inputs
416 `(("python-django" ,python-django)))
417 (home-page "https://github.com/aykut/django-bulk-update")
418 (synopsis "Simple bulk update over Django ORM or with helper function")
419 (description
420 "Simple bulk update over Django ORM or with helper function. This
421 project aims to bulk update given objects using one query over Django ORM.")
422 (license license:expat)))
423
424 (define-public python2-django-bulk-update
425 (package-with-python2 python-django-bulk-update))
426
427 (define-public python-django-contact-form
428 (package
429 (name "python-django-contact-form")
430 (version "1.3")
431 (source (origin
432 (method url-fetch)
433 (uri (pypi-uri "django-contact-form" version))
434 (sha256
435 (base32
436 "0az590y56k5ahv4sixrkn54d3a8ig2q2z9pl6s3m4f533mx2gj17"))))
437 (build-system python-build-system)
438 (arguments
439 `(#:phases
440 (modify-phases %standard-phases
441 (replace 'check
442 (lambda _
443 ;; the next version will need "make test"
444 (and (zero? (system* "flake8" "contact_form"))
445 (zero? (system* "coverage" "run" "contact_form/runtests.py"))
446 (zero? (system* "coverage" "report" "-m" "--fail-under" "0"))))))))
447 (native-inputs
448 `(("python-coverage" ,python-coverage)
449 ("python-flake8" ,python-flake8)))
450 (propagated-inputs
451 `(("python-django" ,python-django)))
452 (home-page "https://github.com/ubernostrum/django-contact-form")
453 (synopsis "Contact form for Django")
454 (description
455 "This application provides simple, extensible contact-form functionality
456 for Django sites.")
457 (license license:bsd-3)))
458
459 (define-public python2-django-contact-form
460 (package-with-python2 python-django-contact-form))
461
462 (define-public python-django-contrib-comments
463 (package
464 (name "python-django-contrib-comments")
465 (version "1.8.0")
466 (source (origin
467 (method url-fetch)
468 (uri (pypi-uri "django-contrib-comments" version))
469 (sha256
470 (base32
471 "0bxsgw8jrkhg6r5s0z6ksfi4w8yknaqb1s9acmxd9pm3pnsnp5kx"))))
472 (build-system python-build-system)
473 (propagated-inputs
474 `(("python-django" ,python-django)))
475 (home-page "https://github.com/django/django-contrib-comments")
476 (synopsis "Comments framework")
477 (description
478 "Django used to include a comments framework; since Django 1.6 it's been
479 separated to a separate project. This is that project. This framework can be
480 used to attach comments to any model, so you can use it for comments on blog
481 entries, photos, book chapters, or anything else.")
482 (license license:bsd-3)))
483
484 (define-public python2-django-contrib-comments
485 (package-with-python2 python-django-contrib-comments))
486
487 (define-public python-django-overextends
488 (package
489 (name "python-django-overextends")
490 (version "0.4.3")
491 (source (origin
492 (method url-fetch)
493 (uri (pypi-uri "django-overextends" version))
494 (sha256
495 (base32
496 "0qc2pcf3i56pmfxh2jw7k3pgljd8xzficmkl2541n7bkcbngqfzm"))))
497 (build-system python-build-system)
498 (arguments
499 `(#:phases
500 (modify-phases %standard-phases
501 (replace 'check
502 (lambda _
503 (zero? (system* "./test_project/manage.py" "test")))))))
504 (propagated-inputs
505 `(("python-django" ,python-django)))
506 (native-inputs
507 `(("sphinx-me" ,python-sphinx-me)))
508 (home-page "https://github.com/stephenmcd/django-overextends")
509 (synopsis "Circular template inheritance")
510 (description
511 "A Django reusable app providing the overextends template tag, a drop-in
512 replacement for Django's extends tag, which allows you to use circular template
513 inheritance. The primary use-case for overextends is to simultaneously
514 override and extend templates from other reusable apps, in your own Django
515 project.")
516 (license license:bsd-2)))
517
518 (define-public python2-django-overextends
519 (package-with-python2 python-django-overextends))
520
521 (define-public python-django-redis
522 (package
523 (name "python-django-redis")
524 (version "4.7.0")
525 (source (origin
526 (method url-fetch)
527 (uri (pypi-uri "django-redis" version))
528 (sha256
529 (base32
530 "0yyyxv8n9l9dhs893jsqwg2cxqkkc79g719n9dzzzqgkzialv1c1"))))
531 (build-system python-build-system)
532 (arguments
533 `(#:phases
534 (modify-phases %standard-phases
535 (replace 'check
536 (lambda _
537 (and (zero? (system* "redis-server" "--daemonize" "yes"))
538 (with-directory-excursion "tests"
539 (zero? (system* "python" "runtests.py")))))))))
540 (native-inputs
541 `(("python-fakeredis" ,python-fakeredis)
542 ("python-hiredis" ,python-hiredis)
543 ("python-mock" ,python-mock)
544 ("python-msgpack" ,python-msgpack)
545 ("redis" ,redis)))
546 (propagated-inputs
547 `(("python-django" ,python-django)
548 ("python-redis" ,python-redis)))
549 (home-page "https://github.com/niwibe/django-redis")
550 (synopsis "Full featured redis cache backend for Django")
551 (description
552 "Full featured redis cache backend for Django.")
553 (license license:bsd-3)))
554
555 (define-public python2-django-redis
556 (package-with-python2 python-django-redis))
557
558 (define-public python-django-rq
559 (package
560 (name "python-django-rq")
561 (version "0.9.4")
562 (source (origin
563 (method url-fetch)
564 (uri (pypi-uri "django-rq" version))
565 (sha256
566 (base32
567 "04v8ilfdp10bk31fxgh4cn083gsn5m06342cnpm5d10nd8hc0vky"))))
568 (build-system python-build-system)
569 (arguments
570 `(#:phases
571 (modify-phases %standard-phases
572 (replace 'check
573 (lambda _
574 (and (zero? (system* "redis-server" "--daemonize" "yes"))
575 (zero? (system* "django-admin.py" "test" "django_rq"
576 "--settings=django_rq.test_settings"
577 "--pythonpath="))))))))
578 (native-inputs
579 `(("redis" ,redis)))
580 (propagated-inputs
581 `(("python-django" ,python-django)
582 ("python-rq" ,python-rq)))
583 (home-page "https://github.com/ui/django-rq")
584 (synopsis "Django integration with RQ")
585 (description
586 "Django integration with RQ, a Redis based Python queuing library.
587 Django-RQ is a simple app that allows you to configure your queues in django's
588 settings.py and easily use them in your project.")
589 (license license:expat)))
590
591 (define-public python2-django-rq
592 (package-with-python2 python-django-rq))
593
594 (define-public python-django-sortedm2m
595 (package
596 (name "python-django-sortedm2m")
597 (version "1.3.3")
598 (source (origin
599 (method url-fetch)
600 (uri (pypi-uri "django-sortedm2m" version))
601 (sha256
602 (base32
603 "0axf765i7b3c2s83nlph47asi8s071dhq8l7y382v1pw785s22vi"))))
604 (build-system python-build-system)
605 (arguments
606 ;; no tests.
607 `(#:tests? #f))
608 (propagated-inputs
609 `(("python-django" ,python-django)))
610 (home-page "https://github.com/gregmuellegger/django-sortedm2m")
611 (synopsis "Drop-in replacement for django's own ManyToManyField")
612 (description
613 "Sortedm2m is a drop-in replacement for django's own ManyToManyField.
614 The provided SortedManyToManyField behaves like the original one but remembers
615 the order of added relations.")
616 (license license:bsd-3)))
617
618 (define-public python2-django-sortedm2m
619 (package-with-python2 python-django-sortedm2m))
620
621 (define-public python-django-appconf
622 (package
623 (name "python-django-appconf")
624 (version "1.0.2")
625 (source (origin
626 (method url-fetch)
627 (uri (pypi-uri "django-appconf" version))
628 (sha256
629 (base32
630 "0qdjdx35g66xjsc50v0c5h3kg6njs8df33mbjx6j4k1vd3m9lkba"))))
631 (build-system python-build-system)
632 (propagated-inputs
633 `(("python-django" ,python-django)))
634 (home-page "https://github.com/django-compressor/django-appconf")
635 (synopsis "Handle configuration defaults of packaged Django apps")
636 (description
637 "This app precedes Django's own AppConfig classes that act as \"objects
638 [to] store metadata for an application\" inside Django's app loading mechanism.
639 In other words, they solve a related but different use case than
640 django-appconf and can't easily be used as a replacement. The similarity in
641 name is purely coincidental.")
642 (license license:bsd-3)))
643
644 (define-public python2-django-appconf
645 (package-with-python2 python-django-appconf))
646
647 (define-public python-django-statici18n
648 (package
649 (name "python-django-statici18n")
650 (version "1.3.0")
651 (source (origin
652 (method url-fetch)
653 (uri (pypi-uri "django-statici18n" version))
654 (sha256
655 (base32
656 "0alcf4g1nv69njhq5k3qw4mfl2k6dc18bik5nk0g1mnp3m8zyz7k"))))
657 (build-system python-build-system)
658 (propagated-inputs
659 `(("python-django" ,python-django)
660 ("django-appconf" ,python-django-appconf)))
661 (home-page "https://github.com/zyegfryed/django-statici18n")
662 (synopsis "Generate JavaScript catalog to static files")
663 (description
664 "A Django app that provides helper for generating JavaScript catalog to
665 static files.")
666 (license license:bsd-3)))
667
668 (define-public python2-django-statici18n
669 (package-with-python2 python-django-statici18n))
670
671 (define-public pootle
672 (package
673 (name "pootle")
674 (version "2.8.0rc5")
675 (source
676 (origin
677 (method url-fetch)
678 (uri (pypi-uri "Pootle" version ".tar.bz2"))
679 (sha256
680 (base32
681 "0m6qcpkcy22dk3ad5y2k8851kqg2w6vrkywgy4vabwbacd7r1mvn"))))
682 (build-system python-build-system)
683 (arguments
684 `(; pootle supports only python2.
685 #:python ,python-2
686 ;; tests are not run and fail with "pytest_pootle/data/po/.tmp: No such
687 ;; file or directory". If we create this directory,
688 ;; pytest_pootle/data/po/terminology.po is missing.
689 #:tests? #f
690 #:phases
691 (modify-phases %standard-phases
692 (add-before 'build 'fix-requirements
693 (lambda _
694 (substitute* "Pootle.egg-info/requires.txt"
695 (("1.7.3") "1.8.0")
696 (("2.0.0") "2.1.0"))
697 (substitute* "requirements/tests.txt"
698 (("==3.0.6") ">=3.0.6"))
699 (substitute* "requirements/base.txt"
700 (("1.7.3") "1.8.0")
701 (("2.0.0") "2.1.0")))))))
702 (propagated-inputs
703 `(("django-allauth" ,python2-django-allauth)
704 ("django-assets" ,python2-django-assets)
705 ("django-bulk-update" ,python2-django-bulk-update)
706 ("django-contact-form" ,python2-django-contact-form)
707 ("django-contrib-comments" ,python2-django-contrib-comments)
708 ("django-overextends" ,python2-django-overextends)
709 ("django-redis" ,python2-django-redis)
710 ("django-rq" ,python2-django-rq)
711 ("django-sortedm2m" ,python2-django-sortedm2m)
712 ("django-statici18n" ,python2-django-statici18n)
713 ("babel" ,python2-babel)
714 ("cssmin" ,python2-cssmin)
715 ("diff-match-patch" ,python2-diff-match-patch)
716 ("dirsync" ,python2-dirsync)
717 ("elasticsearch" ,python2-elasticsearch)
718 ("jsonfield" ,python2-django-jsonfield)
719 ("lxml" ,python2-lxml)
720 ("dateutil" ,python2-dateutil)
721 ("levenshtein" ,python2-levenshtein)
722 ("mysqlclient" ,python2-mysqlclient)
723 ("psycopg2" ,python2-psycopg2)
724 ("pytz" ,python2-pytz)
725 ("rq" ,python2-rq)
726 ("scandir" ,python2-scandir)
727 ("stemming" ,python2-stemming)
728 ("translate-toolkit" ,python2-translate-toolkit)))
729 (native-inputs
730 `(("python2-pytest" ,python2-pytest)
731 ("python2-pytest-django" ,python2-pytest-django)
732 ("python2-pytest-catchlog" ,python2-pytest-catchlog)
733 ("python2-pytest-cov" ,python2-pytest-cov)
734 ("python2-factory-boy" ,python2-factory-boy)))
735 (home-page "http://pootle.translatehouse.org/")
736 (synopsis "Community localization server")
737 (description
738 "Pootle is an online translation and localization tool. It works to
739 lower the barrier of entry, providing tools to enable teams to work towards
740 higher quality while welcoming newcomers.")
741 (license license:gpl3+)))
742
743 (define-public python-django-tagging
744 (package
745 (name "python-django-tagging")
746 (version "0.4.6")
747 (source
748 (origin
749 (method url-fetch)
750 (uri (pypi-uri "django-tagging" version))
751 (sha256
752 (base32
753 "0s7b4v45j783yaxs7rni10k24san0ya77nqz4s7zdf3jhfpk42r1"))))
754 (build-system python-build-system)
755 (home-page "https://github.com/Fantomas42/django-tagging")
756 (synopsis "Generic tagging application for Django")
757 (description "This package provides a generic tagging application for
758 Django projects, which allows association of a number of tags with any
759 @code{Model} instance and makes retrieval of tags simple.")
760 (license license:bsd-3)))
761
762 (define-public python2-django-tagging
763 (package-with-python2 python-django-tagging))
764
765 (define-public python-djangorestframework
766 (package
767 (name "python-djangorestframework")
768 (version "3.7.7")
769 (source
770 (origin
771 (method url-fetch)
772 (uri (pypi-uri "djangorestframework" version))
773 (sha256
774 (base32
775 "11qv117gqwswxjljs7wafxg1hyzzlx3qrviwlk9hw41bsbl997lz"))))
776 (build-system python-build-system)
777 (arguments
778 '(;; No included tests
779 #:tests? #f))
780 (propagated-inputs
781 `(("python-django" ,python-django)))
782 (home-page "https://www.django-rest-framework.org")
783 (synopsis "Toolkit for building Web APIs with Django")
784 (description
785 "The Django REST framework is for building Web APIs with Django. It
786 provides features like a web browseable API and authentication policies.")
787 (license license:bsd-2)))
788
789 (define-public python-django-crispy-forms
790 (package
791 (name "python-django-crispy-forms")
792 (version "1.7.2")
793 (source
794 (origin
795 (method url-fetch)
796 (uri (pypi-uri "django-crispy-forms" version))
797 (sha256
798 (base32
799 "0pv7y648i8iz7mf64gkjizpbx5d01ap2s4vqqa30n38if6wvlljr"))))
800 (build-system python-build-system)
801 (arguments
802 '(;; No included tests
803 #:tests? #f))
804 (propagated-inputs
805 `(("python-django" ,python-django)))
806 (home-page
807 "http://github.com/maraujop/django-crispy-forms")
808 (synopsis "Tool to control Django forms without custom templates")
809 (description
810 "@code{django-crispy-forms} lets you easily build, customize and reuse
811 forms using your favorite CSS framework, without writing template code.")
812 (license license:expat)))
813
814 (define-public python-django-override-storage
815 (package
816 (name "python-django-override-storage")
817 (version "0.1.4")
818 (source
819 (origin
820 (method url-fetch)
821 (uri (pypi-uri "django-override-storage" version))
822 (sha256
823 (base32
824 "0sqz1mh0yn8b1bzz2gr2azfiynljigm5gkzavp5n17zd3j2jg57x"))))
825 (build-system python-build-system)
826 (propagated-inputs
827 `(("python-django" ,python-django)))
828 (home-page
829 "https://github.com/danifus/django-override-storage")
830 (synopsis "Django test helpers to manage file storage side effects")
831 (description
832 "This project provides tools to help reduce the side effects of using
833 FileFields during tests.")
834 (license license:expat)))