gnu: Add nyacc-1.00.2.
[jackhill/guix/guix.git] / gnu / packages / mes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2018, 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
3 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages mes)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages bash)
25 #:use-module (gnu packages bootstrap)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages cross-base)
28 #:use-module (gnu packages gcc)
29 #:use-module (gnu packages graphviz)
30 #:use-module (gnu packages guile)
31 #:use-module (gnu packages man)
32 #:use-module (gnu packages package-management)
33 #:use-module (gnu packages perl)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages texinfo)
36 #:use-module (guix build-system gnu)
37 #:use-module (guix download)
38 #:use-module (guix git-download)
39 #:use-module (guix licenses)
40 #:use-module (guix packages)
41 #:use-module (guix utils))
42
43 (define-public nyacc-0.86
44 ;; Nyacc used for bootstrap.
45 (package
46 (name "nyacc")
47 (version "0.86.0")
48 (source (origin
49 (method url-fetch)
50 (uri (string-append "mirror://savannah/nyacc/"
51 name "-" version ".tar.gz"))
52 (patches (search-patches "nyacc-binary-literals.patch"))
53 (sha256
54 (base32
55 "0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
56 (build-system gnu-build-system)
57 (native-inputs
58 `(("guile" ,guile-2.2)))
59 (synopsis "LALR(1) Parser Generator in Guile")
60 (description
61 "NYACC is an LALR(1) parser generator implemented in Guile.
62 The syntax and nomenclature should be considered not stable. It comes with
63 extensive examples, including parsers for the Javascript and C99 languages.")
64 (home-page "https://savannah.nongnu.org/projects/nyacc")
65 (license (list gpl3+ lgpl3+))))
66
67 (define-public nyacc-0.99
68 (package
69 (inherit nyacc-0.86)
70 (version "0.99.0")
71 (source (origin
72 (method url-fetch)
73 (uri (string-append "mirror://savannah/nyacc/nyacc-"
74 version ".tar.gz"))
75 (sha256
76 (base32
77 "0hl5qxx19i4x1r0839sxm19ziqq65g4hy97yik81cc2yb9yvgyv3"))
78 (modules '((guix build utils)))
79 (snippet
80 '(begin
81 (substitute* (find-files "." "^Makefile\\.in$")
82 (("^SITE_SCM_DIR =.*")
83 "SITE_SCM_DIR = \
84 @prefix@/share/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
85 (("^SITE_SCM_GO_DIR =.*")
86 "SITE_SCM_GO_DIR = \
87 @prefix@/lib/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n")
88 (("^INFODIR =.*")
89 "INFODIR = @prefix@/share/info\n")
90 (("^DOCDIR =.*")
91 "DOCDIR = @prefix@/share/doc/$(PACKAGE_TARNAME)\n"))
92 #t))))
93 (native-inputs
94 `(("pkg-config" ,pkg-config)))
95 (inputs
96 `(("guile" ,guile-2.2)))))
97
98 (define-public nyacc
99 (package
100 (inherit nyacc-0.99)
101 (version "1.03.0")
102 (source (origin
103 (method url-fetch)
104 (uri (string-append "mirror://savannah/nyacc/nyacc-"
105 version ".tar.gz"))
106 (sha256
107 (base32
108 "1vdiqpm3p0ndmpmkzcpkpjvgklfsk4wxrhkixdxbczpafdfl635p"))
109 (modules '((guix build utils)))
110 (snippet
111 '(begin
112 (substitute* "configure"
113 (("GUILE_GLOBAL_SITE=\\$prefix.*")
114 "GUILE_GLOBAL_SITE=\
115 $prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n"))
116 #t))))
117 (inputs
118 `(("guile" ,guile-3.0)))))
119
120 (define-public nyacc-1.00.2
121 (package
122 (inherit nyacc)
123 (version "1.00.2")
124 (source (origin
125 (method url-fetch)
126 (uri (string-append "mirror://savannah/nyacc/nyacc-"
127 version ".tar.gz"))
128 (modules '((guix build utils)))
129 (snippet
130 '(begin
131 (substitute* (find-files "." "^Makefile\\.in$")
132 (("^SITE_SCM_DIR =.*")
133 "SITE_SCM_DIR = \
134 @prefix@/share/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
135 (("^SITE_SCM_GO_DIR =.*")
136 "SITE_SCM_GO_DIR = \
137 @prefix@/lib/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n")
138 (("^INFODIR =.*")
139 "INFODIR = @prefix@/share/info\n")
140 (("^DOCDIR =.*")
141 "DOCDIR = @prefix@/share/doc/$(PACKAGE_TARNAME)\n"))
142 #t))
143 (sha256
144 (base32
145 "065ksalfllbdrzl12dz9d9dcxrv97wqxblslngsc6kajvnvlyvpk"))))
146 (inputs
147 `(("guile" ,guile-2.2)))))
148
149 (define-public mes-0.19
150 ;; Mes used for bootstrap.
151 (package
152 (name "mes")
153 (version "0.19")
154 (source (origin
155 (method url-fetch)
156 (uri (string-append "mirror://gnu/mes/"
157 "mes-" version ".tar.gz"))
158 (sha256
159 (base32
160 "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
161 (build-system gnu-build-system)
162 (supported-systems '("i686-linux" "x86_64-linux"))
163 (propagated-inputs
164 `(("mescc-tools" ,mescc-tools-0.5.2)
165 ("nyacc" ,nyacc-0.86)))
166 (native-inputs
167 `(("guile" ,guile-2.2)
168 ,@(let ((target-system (or (%current-target-system)
169 (%current-system))))
170 (cond
171 ((string-prefix? "x86_64-linux" target-system)
172 ;; Use cross-compiler rather than #:system "i686-linux" to get
173 ;; MesCC 64 bit .go files installed ready for use with Guile.
174 `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
175 ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
176 (else
177 '())))
178 ("graphviz" ,graphviz)
179 ("help2man" ,help2man)
180 ("perl" ,perl) ; build-aux/gitlog-to-changelog
181 ("texinfo" ,texinfo)))
182 (arguments
183 `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
184 (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
185 (description
186 "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
187 bootstrap to Guix and aims to help create full source bootstrapping for
188 GNU/Linux distributions. It consists of a mutual self-hosting Scheme
189 interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
190 Guile.")
191 (home-page "https://www.gnu.org/software/mes/")
192 (license gpl3+)))
193
194 (define-public mes
195 (package
196 (inherit mes-0.19)
197 (version "0.22")
198 (source (origin
199 (method url-fetch)
200 (uri (string-append "mirror://gnu/mes/"
201 "mes-" version ".tar.gz"))
202 (sha256
203 (base32
204 "0p1jsrrmcbc0zrvbvnjbb6iyxr0in71km293q8qj6gnar6bw09av"))))
205 (propagated-inputs
206 `(("mescc-tools" ,mescc-tools)
207 ("nyacc" ,nyacc-0.99)))
208 (native-search-paths
209 (list (search-path-specification
210 (variable "C_INCLUDE_PATH")
211 (files '("include")))
212 (search-path-specification
213 (variable "LIBRARY_PATH")
214 (files '("lib")))
215 (search-path-specification
216 (variable "MES_PREFIX")
217 (separator #f)
218 (files '("")))))))
219
220 (define-public mes-rb5
221 ;; This is the Reproducible-Builds summit 5's Mes, also built on Debian
222 ;; GNU/Linux and NixOS to produce the same, bit-for-bit identical result.
223 (package
224 (inherit mes)
225 (name "mes-rb5")
226 (inputs '())
227 (propagated-inputs '())
228 (native-inputs
229 `(("bash" ,bash)
230 ("coreutils" ,coreutils)
231 ("grep" ,grep)
232 ("guile" ,guile-2.2)
233 ("gzip" ,gzip)
234 ("libc" ,glibc)
235 ("locales" ,glibc-utf8-locales)
236 ("make" ,gnu-make)
237 ("mes" ,mes)
238 ("mescc-tools" ,mescc-tools)
239 ("nyacc" ,nyacc-0.99)
240 ("sed" ,sed)
241 ("tar" ,tar)))
242 (supported-systems '("i686-linux"))
243 (arguments
244 `(#:implicit-inputs? #f
245 #:strip-binaries? #f ; binutil's strip b0rkes MesCC/M1/hex2 binaries
246 #:modules ((guix build gnu-build-system)
247 (guix build utils)
248 (ice-9 popen)
249 (ice-9 rdelim))
250 #:phases
251 (modify-phases %standard-phases
252 (add-before 'configure 'setenv
253 (lambda _
254 (setenv "AR" "mesar")
255 (setenv "CC" "mescc")
256 (setenv "GUILD" "true")
257 (setenv "SCHEME" "mes")
258 (setenv "LC_ALL" "en_US.UTF-8")
259 #t))
260 (replace 'configure
261 (lambda _
262 (let ((out (assoc-ref %outputs "out")))
263 (invoke "sh" "configure.sh"
264 (string-append "--prefix=" out)
265 "--host=i686-unkown-linux-gnu"
266 "--with-courage"))))
267 (replace 'build
268 (lambda _
269 (invoke "sh" "bootstrap.sh")))
270 (replace 'check
271 (lambda _
272 (copy-file "bin/mes-mescc" "bin/mes-mescc-0.21")
273 (system* "sed" "-i" "s/0\\.22/0\\.21/" "bin/mes-mescc-0.21")
274 (let ((sha256sum
275 (read-delimited
276 " "
277 (open-pipe* OPEN_READ "sha256sum" "bin/mes-mescc-0.21"))))
278 (unless
279 (equal?
280 sha256sum
281 "9e0bcb1633c58e7bc415f6ea27cee7951d6b0658e13cdc147e992b31a14625fb")
282 (throw 'error "mes checksum failure"))
283 #t)))
284 (replace 'install
285 (lambda _
286 (invoke "sh" "install.sh"))))))))
287
288 (define-public mescc-tools-0.5.2
289 ;; Mescc-tools used for bootstrap.
290 (let ((commit "bb062b0da7bf2724ca40f9002b121579898d4ef7")
291 (revision "0")
292 (version "0.5.2"))
293 (package
294 (name "mescc-tools")
295 (version (git-version version revision commit))
296 (source (origin
297 (method git-fetch)
298 (uri (git-reference
299 (url "https://git.savannah.nongnu.org/r/mescc-tools.git")
300 (commit commit)))
301 (file-name (git-file-name name version))
302 (sha256
303 (base32
304 "1nc6rnax66vmhqsjg0kgx23pihdcxmww6v325ywf59vsq1jqjvff"))))
305 (build-system gnu-build-system)
306 (supported-systems '("i686-linux" "x86_64-linux"))
307 (arguments
308 `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
309 #:test-target "test"
310 #:phases (modify-phases %standard-phases
311 (delete 'configure))))
312 (synopsis "Tools for the full source bootstrapping process")
313 (description
314 "Mescc-tools is a collection of tools for use in a full source
315 bootstrapping process. It consists of the M1 macro assembler, the hex2
316 linker, the blood-elf symbol table generator, the kaem shell, exec_enable and
317 get_machine.")
318 (home-page "https://savannah.nongnu.org/projects/mescc-tools")
319 (license gpl3+))))
320
321 (define-public mescc-tools
322 (package
323 (inherit mescc-tools-0.5.2)
324 (name "mescc-tools")
325 (version "0.7.0")
326 (source
327 (origin
328 (method url-fetch)
329 (uri (string-append
330 "http://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
331 name "-Release_" version
332 ".tar.gz"))
333 (file-name (string-append name "-" version ".tar.gz"))
334 (sha256
335 (base32
336 "1p1ijia4rm3002f5sypidl9v5gq0mlch9b0n61rpxkdsaaxjqax3"))))
337 (arguments
338 (substitute-keyword-arguments (package-arguments mescc-tools-0.5.2)
339 ((#:make-flags _)
340 `(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
341 "CC=gcc"))
342 ((#:phases phases)
343 `(modify-phases ,phases
344 (add-after 'unpack 'patch-prefix
345 (lambda _
346 (substitute* "sha256.sh"
347 (("/usr/bin/sha256sum") (which "sha256sum")))
348 #t))))))))
349
350 (define-public m2-planet
351 (let ((commit "b87ddb0051b168ea45f8d49a610dcd069263336a")
352 (revision "2"))
353 (package
354 (name "m2-planet")
355 (version (string-append "1.4.0-" revision "." (string-take commit 7)))
356 (source (origin
357 (method git-fetch)
358 (uri (git-reference
359 (url "https://github.com/oriansj/m2-planet")
360 (commit commit)))
361 (file-name (git-file-name name version))
362 (sha256
363 (base32
364 "0yyc0fcbbxi9jqa1n76x0rwspdrwmc8g09jlmsw9c35nflrhmz8q"))))
365 (native-inputs
366 `(("mescc-tools" ,mescc-tools)))
367 (build-system gnu-build-system)
368 (arguments
369 `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
370 #:tests? #f
371 #:phases (modify-phases %standard-phases
372 (delete 'bootstrap)
373 (delete 'configure))))
374 (synopsis "The PLAtform NEutral Transpiler")
375 (description
376 "M2-Planet, the PLAtform NEutral Transpiler, when combined with
377 mescc-tools, compiles a subset of the C language into working binaries with
378 introspective steps in between. It is self-hosting and for bootstrapping it
379 also has an implementation in the M1 macro assembly language. M2-Planet is
380 built as Phase-5 of the full source bootstrapping process and is capable of
381 building GNU Mes.")
382 (home-page "https://github.com/oriansj/m2-planet")
383 (license gpl3+))))