gnu-build-system: Add 'patch-usr-bin-file' to %standard-phases.
[jackhill/guix/guix.git] / gnu / packages / pcre.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages pcre)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (gnu packages compression)
23 #:use-module (gnu packages readline)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public pcre
29 (package
30 (name "pcre")
31 (version "8.32")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://sourceforge/pcre/pcre/"
35 version "/pcre-" version ".tar.bz2"))
36 (sha256
37 (base32
38 "0m8gvrf1q0iwll4csirvvj98xygw4cy7r14i5l53ivsqs2dzn4x9"))))
39 (build-system gnu-build-system)
40 (inputs `(("bzip2" ,bzip2)
41 ("readline" ,readline)
42 ("zlib" ,zlib)))
43 (arguments
44 `(#:configure-flags '("--enable-utf"
45 "--enable-pcregrep-libz"
46 "--enable-pcregrep-libbz2"
47 "--enable-pcretest-libreadline")))
48 (synopsis "PCRE, Perl Compatible Regular Expressions")
49 (description
50 "The PCRE library is a set of functions that implement regular expression
51 pattern matching using the same syntax and semantics as Perl 5. PCRE has its
52 own native API, as well as a set of wrapper functions that correspond to the
53 POSIX regular expression API.")
54 (license license:bsd-3)
55 (home-page "http://www.pcre.org/")))