gnu-build-system: Add 'patch-usr-bin-file' to %standard-phases.
[jackhill/guix/guix.git] / gnu / packages / lisp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lisp)
20 #:use-module (gnu packages)
21 #:use-module ((guix licenses)
22 #:renamer (symbol-prefix-proc 'license:))
23 #:use-module (guix packages)
24 #:use-module (gnu packages readline)
25 #:use-module (gnu packages texinfo)
26 #:use-module (gnu packages texlive)
27 #:use-module (gnu packages m4)
28 #:use-module (guix download)
29 #:use-module (guix utils)
30 #:use-module (guix build-system gnu))
31
32 (define-public gcl
33 (package
34 (name "gcl")
35 (version "2.6.10")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "mirror://gnu/" name "/" name "-" version ".tar.gz"))
40 (sha256
41 (base32 "1vsicv81ml7d92c87bckgkpvcshi6hzdnj44k0j6zs5mj8pzp8br"))))
42 (build-system gnu-build-system)
43 (arguments
44 `(#:parallel-build? #f ; The build system seems not to be thread safe.
45 #:tests? #f ; There does not seem to be make check or anything similar.
46 #:configure-flags '("--enable-ansi") ; required for use by the maxima package
47 #:phases (alist-cons-before
48 'configure 'pre-conf
49 (lambda _
50 ;; Patch bug when building readline support. This bug was
51 ;; also observed by Debian
52 ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741819
53 (substitute* "o/gcl_readline.d"
54 (("rl_attempted_completion_function = \\(CPPFunction \\*\\)rl_completion;")
55 "rl_attempted_completion_function = rl_completion;"))
56 (substitute*
57 (append
58 '("pcl/impl/kcl/makefile.akcl"
59 "add-defs"
60 "unixport/makefile.dos"
61 "add-defs.bat"
62 "gcl-tk/makefile.prev"
63 "add-defs1")
64 (find-files "h" "\\.defs"))
65 (("SHELL=/bin/(ba)?sh")
66 (string-append "SHELL=" (which "bash")))))
67 %standard-phases)))
68 (native-inputs
69 `(("m4" ,m4)
70 ("readline" ,readline)
71 ("texinfo" ,texinfo)
72 ("texlive" ,texlive)))
73 (home-page "http://www.gnu.org/software/gcl")
74 (synopsis "A Common Lisp implementation")
75 (description "GCL is an implementation of the Common Lisp language. It
76 features the ability to compile to native object code and to load native
77 object code modules directly into its lisp core. It also features a
78 stratified garbage collection strategy, a source-level debugger and a built-in
79 interface to the Tk widget system.")
80 (license license:lgpl2.0+)))
81