gnu-build-system: Add 'patch-usr-bin-file' to %standard-phases.
[jackhill/guix/guix.git] / gnu / packages / lightning.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lightning)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses))
24
25 (define-public lightning
26 (package
27 (name "lightning")
28 (version "2.0.5")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "mirror://gnu/lightning/lightning-"
32 version ".tar.gz"))
33 (sha256
34 (base32
35 "0jm9a8ddxc1v9hyzyv4ybg37fjac2yjqv1hkd262wxzqms36mdk5"))))
36 (build-system gnu-build-system)
37 (synopsis "Library for generating assembly code at runtime")
38 (description
39 "GNU Lightning is a library that generates assembly language code at
40 run-time. Thus, it is useful in creating Just-In-Time compilers. It
41 abstracts over the target CPU by exposing a standardized RISC instruction set
42 to the clients.")
43 (home-page "http://www.gnu.org/software/lightning/")
44 (license gpl3+)))