gnu: Add lvm2.
[jackhill/guix/guix.git] / gnu / packages / lvm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lvm)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages linux)
27 #:use-module (gnu packages pkg-config))
28
29 (define-public lvm2
30 (package
31 (name "lvm2")
32 (version "2.02.98")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "ftp://sources.redhat.com/pub/lvm2/LVM2."
36 version ".tgz"))
37 (sha256
38 (base32
39 "0r6q6z8ip6q5qgkzng0saljassp4912k6i21ra10vq7pzrc0l0vi"))))
40 (build-system gnu-build-system)
41 (inputs
42 `(("pkg-config" ,pkg-config)
43 ("procps" ,procps)))
44 (arguments
45 `(#:tests? #f ; require to be root
46 #:configure-flags
47 `(,(string-append "--with-confdir=" (assoc-ref %outputs "out") "/etc"))
48 #:phases
49 (alist-replace
50 'configure
51 (lambda* (#:key #:allow-other-keys #:rest args)
52 (let ((configure (assoc-ref %standard-phases 'configure)))
53 (substitute* "make.tmpl.in"
54 (("/bin/sh") (which "sh"))
55 (("CC \\?=") "CC =")) ; force CC argument to be set from configure
56 (apply configure args)))
57 %standard-phases)))
58 (synopsis "logical volume management")
59 (description
60 "LVM2 refers to the userspace toolset that provides logical volume
61 management facilities on linux. It is reasonably backwards-compatible with
62 the original LVM toolset.")
63 (license license:gpl2)
64 (home-page "http://www.sourceware.org/lvm2/")))