gnu: wine: Update to 3.0.3.
[jackhill/guix/guix.git] / gnu / packages / cdrom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
5 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
6 ;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
8 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
9 ;;; Copyright © 2017 John Darrington <jmd@gnu.org>
10 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
11 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
12 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
13 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
14 ;;;
15 ;;; This file is part of GNU Guix.
16 ;;;
17 ;;; GNU Guix is free software; you can redistribute it and/or modify it
18 ;;; under the terms of the GNU General Public License as published by
19 ;;; the Free Software Foundation; either version 3 of the License, or (at
20 ;;; your option) any later version.
21 ;;;
22 ;;; GNU Guix is distributed in the hope that it will be useful, but
23 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
24 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
25 ;;; GNU General Public License for more details.
26 ;;;
27 ;;; You should have received a copy of the GNU General Public License
28 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
29
30 (define-module (gnu packages cdrom)
31 #:use-module (guix download)
32 #:use-module (guix packages)
33 #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl2+ gpl3+ cddl1.0))
34 #:use-module (guix build-system cmake)
35 #:use-module (guix build-system gnu)
36 #:use-module (guix build-system glib-or-gtk)
37 #:use-module (guix gexp)
38 #:use-module (gnu packages)
39 #:use-module (gnu packages acl)
40 #:use-module (gnu packages audio)
41 #:use-module (gnu packages bison)
42 #:use-module (gnu packages compression)
43 #:use-module (gnu packages flex)
44 #:use-module (gnu packages fontutils)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages docbook)
47 #:use-module (gnu packages xml)
48 #:use-module (gnu packages gtk)
49 #:use-module (gnu packages glib)
50 #:use-module (gnu packages m4)
51 #:use-module (gnu packages man)
52 #:use-module (gnu packages mp3)
53 #:use-module (gnu packages music)
54 #:use-module (gnu packages ncurses)
55 #:use-module (gnu packages elf)
56 #:use-module (gnu packages wxwidgets)
57 #:use-module (gnu packages linux)
58 #:use-module (gnu packages pkg-config)
59 #:use-module (gnu packages readline)
60 #:use-module (gnu packages base)
61 #:use-module (gnu packages perl)
62 #:use-module (gnu packages perl-web)
63 #:use-module (gnu packages python)
64 #:use-module (gnu packages image)
65 #:use-module (gnu packages photo)
66 #:use-module (gnu packages video)
67 #:use-module (gnu packages wget)
68 #:use-module (gnu packages xiph))
69
70 (define-public libcddb
71 (package
72 (name "libcddb")
73 (version "1.3.2")
74 (source (origin
75 (method url-fetch)
76 (uri (string-append "mirror://sourceforge/libcddb/libcddb/" version
77 "/libcddb-" version ".tar.bz2"))
78 (sha256
79 (base32
80 "0fr21a7vprdyy1bq6s99m0x420c9jm5fipsd63pqv8qyfkhhxkim"))))
81 (build-system gnu-build-system)
82 (arguments '(#:tests? #f)) ; tests rely on access to external servers
83 (home-page "http://libcddb.sourceforge.net/")
84 (synopsis "C library to access data on a CDDB server")
85 (description
86 "Libcddb is a C library to access data on a CDDB server (freedb.org). It
87 allows you to:
88
89 1. search the database for possible CD matches;
90
91 2. retrieve detailed information about a specific CD;
92
93 3. submit new CD entries to the database.
94
95 Libcddb supports both the custom CDDB protocol and tunnelling the query and
96 read operations over plain HTTP. It is also possible to use an HTTP proxy
97 server. If you want to speed things up, you can make use of the built-in
98 caching facility provided by the library.")
99 (license lgpl2.1+)))
100
101 (define-public libcdio
102 (package
103 (name "libcdio")
104 (version "2.0.0")
105 (source (origin
106 (method url-fetch)
107 (uri (string-append "mirror://gnu/libcdio/libcdio-"
108 version ".tar.bz2"))
109 (sha256
110 (base32
111 "0jr8ppdm80c533nzmrpz3iffnpc6nhvsria1di9f4jg1l19a03fd"))))
112 (build-system gnu-build-system)
113 (inputs
114 `(("ncurses" ,ncurses)
115 ("libcddb" ,libcddb)))
116 (native-inputs
117 `(("help2man" ,help2man)
118 ("pkg-config" ,pkg-config)))
119 (home-page "https://www.gnu.org/software/libcdio/")
120 (synopsis "CD Input and Control library")
121 (description
122 "The GNU Compact Disc Input and Control Library (libcdio) is a library
123 for CD-ROM and CD image file access. It allows the developer to add CD
124 access to an application without having to worry about the OS- and
125 device-dependent properties of CD-ROM or the specific details of CD image
126 formats. It includes pycdio, a Python interface to libcdio, and
127 libcdio-paranoia, a library providing jitter-free and error-free audio
128 extraction from CDs.")
129 (license gpl3+)))
130
131 (define-public libcdio-paranoia
132 (package
133 (name "libcdio-paranoia")
134 (version "10.2+0.94+2")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append "mirror://gnu/libcdio/libcdio-paranoia-"
138 version ".tar.gz"))
139 (sha256
140 (base32
141 "0h8rr1ir05r29rgawa1ccw335668k4s3zq4yg9095svyx7n843yn"))))
142 (build-system gnu-build-system)
143 (native-inputs `(("pkg-config" ,pkg-config)))
144 (propagated-inputs `(("libcdio" ,libcdio)))
145 (home-page "https://www.gnu.org/software/libcdio/")
146 (synopsis "Jitter- and error-tolerant CD audio extraction")
147 (description
148 "libcdio-paranoia is an implementation of CD paranoia libraries based on
149 libcdio.")
150 (license gpl3+)))
151
152 (define-public xorriso
153 (package
154 (name "xorriso")
155 (version "1.4.8")
156 (source (origin
157 (method url-fetch)
158 (uri (string-append "mirror://gnu/xorriso/xorriso-"
159 version ".tar.gz"))
160 (sha256
161 (base32
162 "10c44yr3dpmwxa7rf23mwfsy1bahny3jpcg9ig0xjv090jg0d0pc"))))
163 (build-system gnu-build-system)
164 (inputs
165 `(("acl" ,acl)
166 ("readline" ,readline)
167 ("zlib" ,zlib)))
168 (home-page "https://www.gnu.org/software/xorriso/")
169 (synopsis "Create, manipulate, burn ISO-9660 file systems")
170 (description
171 "GNU Xorriso is a tool for copying files to and from ISO 9660 Rock
172 Ridge, a.k.a. Compact Disc File System, file systems and it allows
173 session-wise manipulation of them. It features a formatter and burner for
174 CD, DVD and BD. It can operate on existing ISO images or it can create new
175 ones. xorriso can then be used to copy files directly into or out of ISO
176 files.")
177 (license gpl3+)))
178
179 (define-public cdparanoia
180 (package
181 (name "cdparanoia")
182 (version "10.2")
183 (source (origin
184 (method url-fetch)
185 (uri (string-append "http://downloads.xiph.org/releases/"
186 "cdparanoia/cdparanoia-III-"
187 version ".src.tgz"))
188 (sha256
189 (base32
190 "1pv4zrajm46za0f6lv162iqffih57a8ly4pc69f7y0gfyigb8p80"))
191 (patches (search-patches "cdparanoia-fpic.patch"))
192 (modules '((guix build utils)))
193 (snippet
194 '(begin
195 ;; Make libraries respect LDFLAGS.
196 (substitute* '("paranoia/Makefile.in" "interface/Makefile.in")
197 (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname"))
198 #t))))
199 (build-system gnu-build-system)
200 (arguments
201 `(#:tests? #f ; there is no check target
202 #:configure-flags ; Add $libdir to the RUNPATH of all the executables.
203 (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
204 (home-page "http://www.xiph.org/paranoia/")
205 (synopsis "Audio CD reading utility")
206 (description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
207 drives. The data can be saved to a file or directed to standard output
208 in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
209 proprietary CDROM drive makes are supported; cdparanoia can determine if the
210 target drive is CDDA capable. In addition to simple reading, cdparanoia adds
211 extra-robust data verification, synchronization, error handling and scratch
212 reconstruction capability.")
213 (license gpl2))) ; libraries under lgpl2.1
214
215 (define-public cdrtools
216 (package
217 (name "cdrtools")
218 (version "3.01")
219 (source (origin
220 (method url-fetch)
221 (uri (string-append
222 "mirror://sourceforge/cdrtools/cdrtools-" version ".tar.bz2"))
223 (sha256
224 (base32
225 "03w6ypsmwwy4d7vh6zgwpc60v541vc5ywp8bdb758hbc4yv2wa7d"))
226 (patches (search-patches "cdrtools-3.01-mkisofs-isoinfo.patch"))))
227 (build-system gnu-build-system)
228 ;; XXX cdrtools bundles a modified, relicensed early version of cdparanoia.
229 (inputs
230 `(("linux-headers" ,linux-libre-headers)))
231 (arguments
232 `(#:phases
233 (modify-phases %standard-phases
234 (delete 'configure)
235 (add-before 'build 'set-linux-headers
236 (lambda _
237 (substitute* "autoconf/configure"
238 (("/usr/src/linux")
239 (assoc-ref %build-inputs "linux-headers")))
240 #t))
241 (add-before 'build 'substitute-dirs
242 (lambda _
243 (substitute* (append (find-files "DEFAULTS" "^Defaults\\.")
244 (find-files "DEFAULTS_ENG" "^Defaults\\.")
245 (find-files "TEMPLATES" "^Defaults\\."))
246 (("/opt/schily") (assoc-ref %outputs "out")))
247 #t))
248 (replace 'build
249 (lambda _
250 (zero?
251 (system* "make" "CONFIG_SHELL=sh" "CCOM=gcc" "RM=rm"))))
252 (replace 'install
253 (lambda _
254 (zero?
255 (system* "make"
256 "RM=rm" "LN=ln" "SYMLINK=ln -s"
257 (string-append "INS_BASE=" (assoc-ref %outputs "out"))
258 (string-append "INS_RBASE=" (assoc-ref %outputs "out"))
259 "install" )))))
260 #:tests? #f)) ; no tests
261 (synopsis "Command line utilities to manipulate and burn CD/DVD/BD images")
262 (description "cdrtools is a collection of command line utilities to create
263 CD's, DVD's or Blue Ray discs. The most important components are
264 @command{cdrecord}, a burning program, @command{cdda2wav}, a CD audio ripper
265 which uses libparanoia, and @command{mkisofs}, which can create various disc
266 images.")
267 (home-page "http://cdrtools.sourceforge.net/private/cdrecord.html")
268
269 ;; mkisofs is GPL, the other programs are CDDL.
270 (license (list cddl1.0 gpl2))))
271
272 (define-public dvd+rw-tools
273 (package
274 (name "dvd+rw-tools")
275 (version "7.1")
276 (source (origin
277 (method url-fetch)
278 (uri (string-append
279 "http://fy.chalmers.se/~appro/linux/DVD+RW/tools/dvd+rw-tools-"
280 version ".tar.gz"))
281 (sha256
282 (base32
283 "1jkjvvnjcyxpql97xjjx0kwvy70kxpiznr2zpjy2hhci5s10zmpq"))
284 (patches (search-patches "dvd+rw-tools-add-include.patch"))))
285 (build-system gnu-build-system)
286 (inputs
287 `(("cdrtools" ,cdrtools)))
288 (native-inputs
289 `(("m4" ,m4)))
290 (arguments
291 `(#:tests? #f ; No tests.
292 #:phases
293 (modify-phases %standard-phases
294 (replace 'configure
295 (lambda _ (setenv "prefix" (assoc-ref %outputs "out")) #t))
296 (add-before 'build 'embed-mkisofs
297 (lambda* (#:key inputs #:allow-other-keys)
298 ;; We use sed --in-place because substitute* cannot handle the
299 ;; character encoding used by growisofs.c.
300 (zero? (system* "sed" "-i" "-e"
301 (string-append
302 "s,\"mkisofs\","
303 "\"" (which "mkisofs") "\",")
304 "growisofs.c")))))))
305 (home-page "http://fy.chalmers.se/~appro/linux/DVD+RW/")
306 (synopsis "DVD and Blu-ray Disc burning tools")
307 (description "dvd+rw-tools, mostly known for its command
308 @command{growisofs}, is a collection of DVD and Blu-ray Disc burning tools.
309 It requires another program, such as @command{mkisofs}, @command{genisoimage},
310 or @command{xorrisofs} to create ISO 9660 images.")
311 (license gpl2)))
312
313 (define-public dvdisaster
314 (package
315 (name "dvdisaster")
316 (version "0.79.5")
317 (source (origin
318 (method url-fetch)
319 (uri (string-append "http://dvdisaster.net/downloads/dvdisaster-"
320 version ".tar.bz2"))
321 (sha256
322 (base32
323 "0f8gjnia2fxcbmhl8b3qkr5b7idl8m855dw7xw2fnmbqwvcm6k4w"))))
324 (build-system gnu-build-system)
325 (inputs
326 `(("gtk+" ,gtk+-2)))
327 (native-inputs
328 `(("gettext" ,gettext-minimal)
329 ("pkg-config" ,pkg-config)
330 ("which" ,which)))
331 (arguments
332 `(;; Parallel builds appear to be unsafe, see
333 ;; <http://hydra.gnu.org/build/49331/nixlog/1/raw>.
334 #:parallel-build? #f
335 #:tests? #f)) ; no check target
336 (home-page "http://dvdisaster.net/en/index.html")
337 (synopsis "Error correcting codes for optical media images")
338 (description "Optical media (CD,DVD,BD) keep their data only for a
339 finite time (typically for many years). After that time, data loss develops
340 slowly with read errors growing from the outer media region towards the
341 inside.
342
343 Dvdisaster stores data on CD/DVD/BD (supported media) in a way that it is
344 fully recoverable even after some read errors have developed. This enables
345 you to rescue the complete data to a new medium.
346
347 Data loss is prevented by using error correcting codes. Error correction
348 data is either added to the medium or kept in separate error correction
349 files. Dvdisaster works at the image level so that the recovery does not
350 depend on the file system of the medium. The maximum error correction
351 capacity is user-selectable.")
352 (license gpl2+)))
353
354 (define-public dvdstyler
355 (package
356 (name "dvdstyler")
357 (version "3.0.4")
358 (source
359 (origin
360 (method url-fetch)
361 (uri (string-append "mirror://sourceforge/dvdstyler/dvdstyler/"
362 version "/DVDStyler-" version ".tar.bz2"))
363 (sha256
364 (base32
365 "0lwc0hn94m9r8fi07sjqz3fr618l6lnw3zsakxw7nlgnxbjsk7pi"))))
366 (build-system gnu-build-system)
367 (arguments
368 `(#:configure-flags
369 (list (string-append "XMLTO="
370 (assoc-ref %build-inputs "xmlto")
371 "/bin/xmlto --searchpath "
372 (assoc-ref %build-inputs "docbook-xsl")
373 "/xml/xsl/docbook-xsl-" ,(package-version docbook-xsl)
374 "/htmlhelp:"
375 (assoc-ref %build-inputs "docbook-xml")
376 "/xml/dtd/docbook"))
377 #:phases
378 (modify-phases %standard-phases
379 (add-after 'install 'wrap-program
380 (lambda* (#:key inputs outputs #:allow-other-keys)
381 (wrap-program (string-append (assoc-ref outputs "out") "/bin/dvdstyler")
382 `("PATH" ":" prefix
383 (,(string-join
384 (map (lambda (in) (string-append (assoc-ref inputs in) "/bin"))
385 '("cdrtools" "dvdauthor" "dvd+rw-tools" "ffmpeg"))
386 ":"))))
387 #t)))
388 #:tests? #f)) ; No tests.
389 (inputs ; TODO package bundled wxvillalib
390 `(("wxwidgets" ,wxwidgets-3.1)
391 ("wssvg" ,wxsvg)
392 ("dbus" ,dbus)
393 ("cdrtools" ,cdrtools)
394 ("dvd+rw-tools" ,dvd+rw-tools)
395 ("dvdauthor" ,dvdauthor)
396 ("eudev" ,eudev)
397 ("fontconfig" ,fontconfig)
398 ("libexif" ,libexif)
399 ("libjpeg" ,libjpeg)
400 ("ffmpeg" ,ffmpeg-3.4)))
401 (native-inputs
402 `(("pkg-config" ,pkg-config)
403 ("flex" ,flex)
404 ("python" ,python-2)
405 ("xmlto" ,xmlto)
406 ("gettext" ,gnu-gettext)
407 ("docbook-xml" ,docbook-xml)
408 ("docbook-xsl" ,docbook-xsl)
409 ("zip" ,zip)))
410 (synopsis "DVD authoring application")
411 (description "DVDStyler is a DVD authoring application which allows users
412 to burn video files in many formats to DVD discs, complete with individually
413 designed menus. It can be used to create professional-looking DVD's with
414 custom buttons, backgrounds and animations, from within a user-friendly
415 graphical interface.")
416 (home-page "https://www.dvdstyler.org")
417 (license gpl2)))
418
419 (define-public libcue
420 (package
421 (name "libcue")
422 (version "2.2.1")
423 (source (origin
424 (method url-fetch)
425 (uri (string-append
426 "https://github.com/lipnitsk/libcue/archive/v"
427 version ".tar.gz"))
428 (file-name (string-append name "-" version ".tar.gz"))
429 (sha256
430 (base32
431 "000j5xqp7cc7njwlixr9byahz9kn8pcfdgm76afwv4p8nbmw6yzj"))))
432 (build-system cmake-build-system)
433 (arguments
434 `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
435 (native-inputs
436 `(("bison" ,bison)
437 ("flex" ,flex)))
438 (home-page "https://github.com/lipnitsk/libcue")
439 (synopsis "C library to parse cue sheets")
440 (description "Libcue is a C library to parse so-called @dfn{cue sheets}
441 which contain meta-data for CD/DVD tracks. It provides an API to manipulate
442 the data.")
443 (license gpl2+)))
444
445 (define-public cd-discid
446 (package
447 (name "cd-discid")
448 (version "1.4")
449 (home-page "http://linukz.org/cd-discid.shtml")
450 (source (origin
451 (method url-fetch)
452 (uri (string-append "http://linukz.org/download/cd-discid-"
453 version ".tar.gz"))
454 (sha256
455 (base32
456 "0qrcvn7227qaayjcd5rm7z0k5q89qfy5qkdgwr5pd7ih0va8rmpz"))
457 (modules '((guix build utils)))
458 (snippet
459 '(begin
460 (substitute* "Makefile"
461 (("/usr/bin/install")
462 "install"))
463 #t))))
464 (build-system gnu-build-system)
465 (arguments
466 '(#:tests? #f
467 #:phases (modify-phases %standard-phases (delete 'configure))
468 #:make-flags (list "CC=gcc"
469 (string-append "PREFIX="
470 (assoc-ref %outputs "out")))))
471 (synopsis "Get CDDB discid information from an audio CD")
472 (description
473 "cd-discid is a command-line tool to retrieve CDDB discid information
474 from an audio CD.")
475 (license gpl2+)))
476
477 (define-public abcde
478 (package
479 (name "abcde")
480 (version "2.9.2")
481 (home-page "https://abcde.einval.com/")
482 (source (origin
483 (method url-fetch)
484 (uri (string-append home-page "/download/abcde-"
485 version ".tar.gz"))
486 (sha256
487 (base32
488 "13c5yvp87ckqgha160ym5rdr1a4divgvyqbjh0yb6ffclip6qd9l"))
489 (modules '((guix build utils)))
490 (snippet
491 `(begin
492 (substitute* "Makefile"
493 ;; Fix abcde 2.9.2 still thinking it's 2.9.1.
494 ;; XXX This will be fixed in the next release.
495 (("(abcde_version = abcde-)(2.9.1)" _ good bad)
496 (string-append good ,version))
497 (("/usr/bin/install")
498 "install")
499 (("^etcdir = .*$")
500 (string-append "etcdir = $(prefix)/etc\n")))
501 #t))))
502 (build-system gnu-build-system)
503 (arguments
504 '(#:phases
505 (modify-phases %standard-phases
506 (replace 'configure
507 (lambda* (#:key outputs inputs #:allow-other-keys)
508 (substitute* "Makefile"
509 (("^prefix = .*$")
510 (string-append "prefix = "
511 (assoc-ref outputs "out")
512 "\n"))
513 (("^sysconfdir = .*$")
514 (string-append "sysconfdir = "
515 (assoc-ref outputs "out")
516 "/etc/\n")))
517 #t))
518 (add-after 'install 'wrap
519 (lambda* (#:key inputs outputs #:allow-other-keys)
520 (let ((wget (assoc-ref inputs "wget"))
521 (vorbis (assoc-ref inputs "vorbis-tools"))
522 (parano (assoc-ref inputs "cdparanoia"))
523 (which (assoc-ref inputs "which"))
524 (discid (assoc-ref inputs "cd-discid"))
525 (perl-discid (assoc-ref inputs "perl-musicbrainz-discid"))
526 (perl-ws (assoc-ref inputs "perl-webservice-musicbrainz"))
527 (perl-mojo (assoc-ref inputs "perl-mojolicious"))
528 (flac (assoc-ref inputs "flac"))
529 (out (assoc-ref outputs "out")))
530 (define (wrap file)
531 (wrap-program file
532 `("PATH" ":" prefix
533 (,(string-append out "/bin:"
534 wget "/bin:"
535 flac "/bin:"
536 which "/bin:"
537 vorbis "/bin:"
538 discid "/bin:"
539 parano "/bin")))
540 `("PERL5LIB" ":" prefix
541 (,(string-append perl-discid
542 "/lib/perl5/site_perl:"
543 perl-ws
544 "/lib/perl5/site_perl:"
545 perl-mojo
546 "/lib/perl5/site_perl")))))
547
548 (for-each wrap
549 (find-files (string-append out "/bin")
550 ".*"))))))
551 #:tests? #f)) ; no test target
552
553 (inputs `(("wget" ,wget)
554 ("which" ,which)
555 ("cdparanoia" ,cdparanoia)
556 ("cd-discid" ,cd-discid)
557 ("vorbis-tools" ,vorbis-tools)
558 ("flac" ,flac)
559
560 ("perl-musicbrainz-discid" ,perl-musicbrainz-discid)
561 ("perl-webservice-musicbrainz" ,perl-webservice-musicbrainz)
562 ("perl-mojolicious" ,perl-mojolicious) ;indirect dependency
563
564 ;; A couple of Python and Perl scripts are included.
565 ("python" ,python)
566 ("perl" ,perl)))
567
568 (synopsis "Command-line audio CD ripper")
569 (description
570 "abcde is a front-end command-line utility (actually, a shell script)
571 that grabs tracks off a CD, encodes them to Ogg/Vorbis, MP3, FLAC, Ogg/Speex
572 and/or MPP/MP+ (Musepack) format, and tags them, all in one go.")
573 (license gpl2+)))
574
575 (define-public geteltorito
576 (package
577 (name "geteltorito")
578 (version "0.6")
579 (home-page
580 "https://userpages.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/")
581 (source (origin
582 (method url-fetch)
583 (uri (string-append home-page name "-" version ".tar.gz"))
584 (sha256
585 (base32
586 "1gkbm9ahj2mgqrkrfpibzclsriqgsbsvjh19fr815vpd9f6snkxv"))))
587 (build-system gnu-build-system)
588 (arguments
589 `(#:tests? #f ; No tests.
590 #:phases
591 (modify-phases %standard-phases
592 (delete 'configure)
593 (delete 'build)
594 (replace 'install
595 (lambda* (#:key outputs #:allow-other-keys)
596 (let ((out (assoc-ref outputs "out")))
597 (install-file "geteltorito"
598 (string-append out "/bin"))))))))
599 (inputs `(("perl" ,perl)))
600 (synopsis "Extract the boot image from a CD-ROM")
601 (description
602 "@command{geteltorito} can extract the initial/default boot
603 image from CDs (and ISOs) that follow the El Torito specification
604 for bootable CD-ROMs.
605
606 Image data is written to standard output by default and all other
607 information is written to standard error.")
608 (license gpl2+)))
609
610 (define-public asunder
611 (package
612 (name "asunder")
613 (version "2.8")
614 (source (origin
615 (method url-fetch)
616 (uri
617 (string-append "http://www.littlesvr.ca/asunder/releases/asunder-"
618 version
619 ".tar.bz2"))
620 (sha256
621 (base32
622 "1nq9kd4rd4k2kibf57gdbm0zw2gxa234vvvdhxkm8g5bhx5h3iyq"))))
623 (build-system glib-or-gtk-build-system)
624 (arguments
625 '(#:out-of-source? #f
626 #:phases (modify-phases %standard-phases
627 (add-after 'install 'wrap
628 (lambda* (#:key inputs outputs #:allow-other-keys)
629 (let ((program (string-append (assoc-ref outputs "out")
630 "/bin/asunder")))
631 (define (bin-directory input-name)
632 (string-append (assoc-ref inputs input-name) "/bin"))
633 (wrap-program program
634 `("PATH" ":" prefix
635 ,(map bin-directory (list "cdparanoia"
636 "lame"
637 "vorbis-tools"
638 "flac"
639 "opus-tools"
640 "wavpack"))))))))))
641 (native-inputs `(("intltool" ,intltool)
642 ("pkg-config" ,pkg-config)))
643 ;; TODO: Add the necessary packages for Musepack encoding.
644 (inputs `(("gtk+-2" ,gtk+-2)
645 ("glib" ,glib)
646 ("libcddb" ,libcddb)
647 ("cdparanoia" ,cdparanoia)
648 ("lame" ,lame)
649 ("vorbis-tools" ,vorbis-tools)
650 ("flac" ,flac)
651 ("opus-tools" ,opus-tools)
652 ("wavpack" ,wavpack)))
653 (home-page "http://www.littlesvr.ca/asunder/")
654 (synopsis "Graphical audio CD ripper and encoder")
655 (description
656 "Asunder is a graphical audio CD ripper and encoder. It can save audio
657 tracks as WAV, MP3, Ogg Vorbis, FLAC, Opus, Wavpack, and Musepack. It can use
658 CDDB to name and tag each track automatically, and it allows for each track to
659 be by a different artist. Asunder can encode to multiple formats in one
660 session, and it can create M3U playlists.")
661 (license gpl2)))
662
663 (define-public ripit
664 (package
665 (name "ripit")
666 (version "3.9.0")
667 (source (origin
668 (method url-fetch)
669 (uri (string-append "http://www.suwald.com/ripit/ripit-"
670 version ".tar.gz"))
671 (sha256
672 (base32
673 "0ap71x477jy9c4jiqazb3y45hxdxm3jbq24x05g3vjyqzigi4x1b"))))
674 (build-system gnu-build-system)
675 (arguments
676 `(#:tests? #f ; No test suite.
677 #:phases
678 (modify-phases %standard-phases
679 (delete 'configure)
680 (add-after 'unpack 'patch-usr-bin-install
681 (lambda* (#:key inputs outputs #:allow-other-keys)
682 (substitute* "Makefile"
683 (("/usr/bin/install") (string-append
684 (assoc-ref inputs "coreutils")
685 "/bin/install"))
686 (("\\$\\(DESTDIR\\)/usr/local") (assoc-ref outputs "out"))
687 (("../../etc") "etc")))))))
688 (native-inputs
689 `(("coreutils" ,coreutils)))
690 (inputs
691 `(("perl" ,perl)))
692 (propagated-inputs
693 `(("cdparanoia" ,cdparanoia)
694 ("flac" ,flac)
695 ("vorbis-tools" ,vorbis-tools)
696 ("wavpack" ,wavpack)
697 ("perl-cddb-get" ,perl-cddb-get)))
698 (home-page "http://www.suwald.com/ripit/about.php")
699 (synopsis "Command-line program to extract audio CDs")
700 (description "RipIT is used to extract audio from CDs.")
701 (license gpl2)))
702
703 (define-public ccd2cue
704 (package
705 (name "ccd2cue")
706 (version "0.5")
707 (source
708 (origin
709 (method url-fetch)
710 (uri (string-append
711 "mirror://gnu/ccd2cue/ccd2cue-" version
712 ".tar.gz"))
713 (sha256
714 (base32
715 "1icrkg25hwx4gsn3dski2172ia4ywjh8m1sa17zmjclnrgdwy9c7"))))
716 (build-system gnu-build-system)
717 (synopsis "CCD to CUE sheet conversion")
718 (description
719 "GNU ccd2cue is a preprocessor for CD burning software that allows
720 the conversion of the proprietary CCD format to the CUE format, which
721 is well-supported by free software. These files are commonly
722 distributed with CD images and are used to describe how tracks are
723 laid out on the image.")
724 (home-page "https://www.gnu.org/software/ccd2cue/")
725 (license gpl3+)))
726
727 (define-public libburn
728 (package
729 (name "libburn")
730 (version "1.4.8")
731 (source (origin
732 (method url-fetch)
733 (uri (string-append "http://files.libburnia-project.org/releases/"
734 "libburn-" version ".tar.gz"))
735 (sha256
736 (base32
737 "19lxnzn8bz70glrrrn2hs43gf5g7gfbcka9rcbckhv1pb7is509y"))))
738 (build-system gnu-build-system)
739 (native-inputs
740 `(("pkg-config" ,pkg-config)))
741 (home-page "https://dev.lovelyhq.com/libburnia/libburn")
742 (synopsis "Library for reading and writing optical discs")
743 (description
744 "Libburn is a library for reading and writing optical discs.
745 Supported media are: CD-R, CD-RW, DVD-RAM, DVD+RW, DVD+R, DVD+R/DL,
746 DVD-RW, DVD-R, DVD-R/DL, BD-R, and BD-RE.")
747 (license gpl2)))
748
749 (define-public libisofs
750 (package
751 (name "libisofs")
752 (version "1.4.8")
753 (source (origin
754 (method url-fetch)
755 (uri (string-append "http://files.libburnia-project.org/releases/"
756 "libisofs-" version ".tar.gz"))
757 (sha256
758 (base32
759 "0scvqb72qq24wcg814p1iw1dknldl21hr1hxsc1wy9vc6vgyk7fw"))))
760 (build-system gnu-build-system)
761 (inputs
762 `(("zlib" ,zlib)
763 ("acl" ,acl)))
764 (native-inputs
765 `(("pkg-config" ,pkg-config)))
766 (home-page "https://dev.lovelyhq.com/libburnia/libisofs")
767 (synopsis "Library to create ISO 9660 images")
768 (description
769 "Libisofs creates ISO 9660 (also known as ECMA-119) file system images
770 which can either be written to POSIX file objects or handed over to
771 libburn for being written directly to optical media.
772 It can read metadata of ISO 9660 filesystems, manipulate them, and use them
773 to produce new complete file system images or add-on images to be appended
774 to the read file system image.
775 Supported extensions to ISO 9660 are Rock Ridge, Joliet, AAIP, zisofs.")
776 (license gpl2+)))
777
778 (define-public cdrkit-libre
779 (package
780 (name "cdrkit-libre")
781 (version "1.1.11")
782 (source (origin
783 (method url-fetch)
784 ;; cdrkit.org is dead.
785 ;;
786 ;; ‘cdrkit-libre’ removes a couple of problematic files,
787 ;; see <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32165#14>.
788 (uri (string-append
789 "https://repo.parabola.nu/other/cdrkit-libre/cdrkit-libre-"
790 version ".tar.gz"))
791 (sha256
792 (base32
793 "0g2zyzb56czh429qy87lvaddzjnlcq8c616ddxsmsshz3clhyzrh"))))
794 (build-system cmake-build-system)
795 (inputs
796 `(("bzip2" ,bzip2)
797 ("libcap" ,libcap)
798 ("perl" ,perl)
799 ("zlib" ,zlib)))
800 (arguments
801 `(#:tests? #f ;no tests
802 #:phases
803 (modify-phases %standard-phases
804 (add-after 'install 'old-cdrecord
805 (lambda* (#:key outputs #:allow-other-keys)
806 (with-directory-excursion (string-append (assoc-ref outputs "out")
807 "/bin")
808 (symlink "genisoimage" "mkisofs")
809 (symlink "wodim" "cdrecord"))
810 #t)))))
811 (home-page "https://repo.parabola.nu/other/cdrkit-libre/")
812 (synopsis "Command-line CD/DVD recorder")
813 (description "Cdrkit is a suite of programs for recording CDs and DVDs,
814 blanking CD-RW media, creating ISO-9660 file system images, extracting audio
815 CD data, and more. It's mostly compatible with @code{cdrtools}.")
816 (license gpl2+)))