gnu: Add emacs-slime.
[jackhill/guix/guix.git] / gnu / packages / zile.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages zile)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix packages)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages bdw-gc)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages man)
28 #:use-module (gnu packages ncurses)
29 #:use-module (gnu packages bash)
30 #:use-module (gnu packages pkg-config))
31
32 (define-public zile
33 (package
34 (name "zile")
35 (version "2.4.11")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/zile/zile-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "1k593y1xzvlj52q0gyhcx2lllws4sg84b8r9pcginjb1vjypplhz"))))
43 (build-system gnu-build-system)
44 (arguments
45 '(#:phases (alist-cons-before
46 'configure 'patch-/bin/sh
47 (lambda* (#:key inputs #:allow-other-keys)
48 (let ((bash (assoc-ref inputs "bash")))
49 ;; Refer to the actual shell.
50 (substitute* '("lib/spawni.c" "src/funcs.c")
51 (("/bin/sh")
52 (string-append bash "/bin/sh")))))
53 %standard-phases)))
54 (inputs
55 `(("boehm-gc" ,libgc)
56 ("ncurses" ,ncurses)
57 ("bash" ,bash)))
58 (native-inputs
59 `(("perl" ,perl)
60 ("help2man" ,help2man)
61 ("pkg-config" ,pkg-config)))
62 (home-page "http://www.gnu.org/software/zile/")
63 (synopsis "Lightweight Emacs clone")
64 (description
65 "GNU Zile is a lightweight Emacs clone. It usage is similar to the
66 default Emacs configuration, but it carries a much lighter feature set.")
67 (license gpl3+)))