gnu: Add emacs-slime.
[jackhill/guix/guix.git] / gnu / packages / yubico.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages yubico)
20 #:use-module (gnu packages)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages man)
27 #:use-module (gnu packages curl))
28
29 (define-public libyubikey
30 (package
31 (name "libyubikey")
32 (version "1.12")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append
36 "https://developers.yubico.com/yubico-c/Releases/"
37 name "-" version ".tar.gz"))
38 (sha256
39 (base32
40 "1f0plzmr1gwry4rfgq9q70v6qwqny009hac289ad5m6sj7vqflxr"))))
41 (build-system gnu-build-system)
42 (synopsis "Development kit for the YubiKey authentication device")
43 (description
44 "This package contains a C library and command-line tools that make up
45 the low-level development kit for the Yubico YubiKey authentication device.")
46 (home-page "https://developers.yubico.com/yubico-c/")
47 (license bsd-2)))
48
49 (define-public ykclient
50 (package
51 (name "ykclient")
52 (version "2.13")
53 (source (origin
54 (method url-fetch)
55 (uri (string-append
56 "https://developers.yubico.com/yubico-c-client/Releases/"
57 name "-" version ".tar.gz"))
58 (sha256
59 (base32
60 "1lw1j61rfjngs8vvv9m348zl4166zg24bq0dy72r44wiz79yic4j"))))
61 (build-system gnu-build-system)
62
63 ;; There's just one test, and it requires network access to access
64 ;; yubico.com, so skip it.
65 (arguments '(#:tests? #f))
66
67 (native-inputs `(("pkg-config" ,pkg-config)
68 ("help2man" ,help2man)))
69 (inputs `(("curl" ,curl)))
70 (synopsis "C library to validate one-time-password YubiKeys")
71 (description
72 "YubiKey C Client Library (libykclient) is a C library used to validate a
73 one-time-password (OTP) YubiKey against Yubico’s servers. See the Yubico
74 website for more information about Yubico and the YubiKey.")
75 (home-page "https://developers.yubico.com/yubico-c-client/")
76 (license bsd-2)))