gnu: Add emacs-slime.
[jackhill/guix/guix.git] / gnu / packages / scribus.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages scribus)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix utils)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix build-system cmake)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages cups)
28 #:use-module (gnu packages fontutils)
29 #:use-module (gnu packages ghostscript)
30 #:use-module (gnu packages gtk)
31 #:use-module (gnu packages image)
32 #:use-module (gnu packages linux)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages python)
35 #:use-module (gnu packages qt)
36 #:use-module (gnu packages imagemagick)
37 #:use-module (gnu packages xml))
38
39 (define-public scribus
40 (package
41 (name "scribus")
42 (version "1.5.0")
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "mirror://sourceforge/scribus/scribus-devel/"
46 version "/scribus-" version ".tar.xz"))
47 (sha256
48 (base32
49 "0s4f9q2nyqrrv4wc1ddf2admkmf9m33wmwp73ba5b4vi29nydnx3"))
50 (patches (list (search-patch "scribus-qobject.patch")))))
51 (build-system cmake-build-system)
52 (arguments `(#:tests? #f)) ; no test target
53 (inputs
54 `(("cairo" ,cairo)
55 ("cups" ,cups)
56 ("graphicsmagick" ,graphicsmagick)
57 ("lcms" ,lcms)
58 ("libjpeg" ,libjpeg)
59 ("libtiff" ,libtiff)
60 ("libxml2" ,libxml2)
61 ("python" ,python-2)
62 ("freetype" ,freetype)
63 ("qt" ,qt)
64 ("zlib" ,zlib)))
65 (native-inputs
66 `(("util-linux" ,util-linux)
67 ("pkg-config" ,pkg-config)))
68 (home-page "http://scribus.net")
69 (synopsis "Desktop publishing and page layout program")
70 (description
71 "Scribus is a @dfn{desktop publishing} (DTP) application and can be used
72 for many tasks; from brochure design to newspapers, magazines, newsletters and
73 posters to technical documentation. Scribus supports professional DTP
74 features, such as CMYK color and a color management system to soft proof
75 images for high quality color printing, flexible PDF creation options,
76 Encapsulated PostScript import/export and creation of four color separations,
77 import of EPS/PS and SVG as native vector graphics, Unicode text including
78 right to left scripts such as Arabic and Hebrew via freetype.")
79 (license license:gpl2+)))