gnu: Add emacs-slime.
[jackhill/guix/guix.git] / gnu / packages / lynx.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lynx)
20 #:use-module ((guix licenses) #:select (gpl2))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages pkg-config)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages ncurses)
27 #:use-module (gnu packages libidn)
28 #:use-module (gnu packages gnupg)
29 #:use-module (gnu packages tls)
30 #:use-module (gnu packages zip)
31 #:use-module (gnu packages compression))
32
33 (define-public lynx
34 (package
35 (name "lynx")
36 (version "2.8.8rel.2")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append
40 "http://invisible-mirror.net/archives/lynx/tarballs"
41 "/lynx" version ".tar.bz2"))
42 (sha256
43 (base32 "1rxysl08acqll5b87368f04kckl8sggy1qhnq59gsxyny1ffg039"))))
44 (build-system gnu-build-system)
45 (native-inputs `(("pkg-config" ,pkg-config)
46 ("perl" ,perl)))
47 (inputs `(("ncurses" ,ncurses)
48 ("libidn" ,libidn)
49 ("gnutls" ,gnutls)
50 ("libgcrypt" ,libgcrypt)
51 ("unzip" ,unzip)
52 ("zlib" ,zlib)
53 ("gzip" ,gzip)
54 ("bzip2" ,bzip2)))
55 (arguments
56 `(#:configure-flags '("--with-pkg-config"
57 "--with-screen=ncurses"
58 "--with-zlib"
59 "--with-bzlib"
60 "--with-gnutls"
61 ;; "--with-socks5" ; XXX TODO
62 "--enable-widec"
63 "--enable-ascii-ctypes"
64 "--enable-local-docs"
65 "--enable-htmlized-cfg"
66 "--enable-gzip-help"
67 "--enable-nls"
68 "--enable-ipv6")
69 #:tests? #f ; no check target
70 #:phases (alist-replace
71 'install
72 (lambda* (#:key (make-flags '()) #:allow-other-keys)
73 (zero? (apply system* "make" "install-full" make-flags)))
74 %standard-phases)))
75 (synopsis "Text Web Browser")
76 (description
77 "Lynx is a fully-featured World Wide Web (WWW) client for users running
78 cursor-addressable, character-cell display devices. It will display Hypertext
79 Markup Language (HTML) documents containing links to files on the local
80 system, as well as files on remote systems running http, gopher, ftp, wais,
81 nntp, finger, or cso/ph/qi servers. Lynx can be used to access information on
82 the WWW, or to build information systems intended primarily for local
83 access.")
84 (home-page "http://lynx.isc.org/")
85 (license gpl2)))
86
87 ;;; lynx.scm ends here