gnu: Add emacs-slime.
[jackhill/guix/guix.git] / gnu / packages / libunistring.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libunistring)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public libunistring
27 (package
28 (name "libunistring")
29 (version "0.9.6")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append
33 "mirror://gnu/libunistring/libunistring-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "0ixxmgpgh2v8ifm6hbwsjxl023myk3dfnj7wnvmqjivza31fw9cn"))))
38 (propagated-inputs '()) ; FIXME: add libiconv when !glibc
39 (build-system gnu-build-system)
40 (arguments
41 ;; Work around parallel build issue whereby C files may be compiled before
42 ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
43 ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
44 '(#:parallel-build? #f))
45 (synopsis "C library for manipulating Unicode strings")
46 (description
47 "GNU libunistring is a library providing functions to manipulate
48 Unicode strings and for manipulating C strings according to the Unicode
49 standard.")
50 (home-page "http://www.gnu.org/software/libunistring/")
51 (license lgpl3+)))