gnu: Add emacs-slime.
[jackhill/guix/guix.git] / gnu / packages / fribidi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages fribidi)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses))
24
25 (define-public fribidi
26 (package
27 (name "fribidi")
28 (version "0.19.6")
29 (source
30 (origin
31 (method url-fetch)
32 (uri
33 (string-append "http://fribidi.org/download/" name "-" version
34 ".tar.bz2"))
35 (sha256
36 (base32 "0zg1hpaml34ny74fif97j7ngrshlkl3wk3nja3gmlzl17i1bga6b"))))
37
38 (build-system gnu-build-system)
39 (synopsis "Implementation of the Unicode bidirectional algorithm")
40 (description
41 "GNU FriBidi is an implementation of the Unicode Bidirectional
42 Algorithm. This algorithm is used to properly display text in left-to-right
43 or right-to-left ordering as necessary.")
44 (home-page "http://fribidi.org/")
45 (license lgpl2.1+)))