gnu: Add r-xnomial.
[jackhill/guix/guix.git] / gnu / packages / patches / glib-tests-prlimit.patch
1 prlimit(2) returns ENOSYS on Linux 2.6.32-5-xen-amd64 as found on
2 hydra.gnu.org, and strace(1) doesn't recognize it.
3
4 --- glib-2.34.3/glib/tests/thread.c 2012-11-20 15:27:12.000000000 +0100
5 +++ glib-2.34.3/glib/tests/thread.c 2013-03-27 14:48:31.000000000 +0100
6 @@ -130,7 +130,7 @@ test_thread3 (void)
7 static void
8 test_thread4 (void)
9 {
10 -#ifdef HAVE_PRLIMIT
11 +#if 0
12 struct rlimit ol, nl;
13 GThread *thread;
14 GError *error;