gnu: synapse: Update to 1.20.1.
[jackhill/guix/guix.git] / gnu / packages / matrix.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
3 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages matrix)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (gnu packages check)
24 #:use-module (gnu packages databases)
25 #:use-module (gnu packages monitoring)
26 #:use-module (gnu packages python-crypto)
27 #:use-module (gnu packages python-web)
28 #:use-module (gnu packages python-xyz)
29 #:use-module (gnu packages xml)
30 #:use-module (guix build-system python)
31 #:use-module (guix download)
32 #:use-module (guix packages))
33
34 (define-public python-matrix-synapse-ldap3
35 (package
36 (name "python-matrix-synapse-ldap3")
37 (version "0.1.4")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (pypi-uri "matrix-synapse-ldap3" version))
42 (sha256
43 (base32
44 "01bms89sl16nyh9f141idsz4mnhxvjrc3gj721wxh1fhikps0djx"))))
45 (build-system python-build-system)
46 (arguments
47 ;; tests require synapse, creating a circular dependency.
48 '(#:tests? #f))
49 (propagated-inputs
50 `(("python-twisted" ,python-twisted)
51 ("python-ldap3" ,python-ldap3)
52 ("python-service-identity" ,python-service-identity)))
53 (home-page "https://github.com/matrix-org/matrix-synapse-ldap3")
54 (synopsis "LDAP3 auth provider for Synapse")
55 (description
56 "This package allows Synapse to use LDAP as a password provider.
57 This lets users log in to Synapse with their username and password from
58 an LDAP server.")
59 (license license:asl2.0)))
60
61 (define-public synapse
62 (package
63 (name "synapse")
64 (version "1.20.1")
65 (source (origin
66 (method url-fetch)
67 (uri (pypi-uri "matrix-synapse" version))
68 (sha256
69 (base32
70 "1sf36vwvy2f9jy6dldq6gqfmh60384i5j64s7yc131b4dp0n7lcw"))))
71 (build-system python-build-system)
72 ;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
73 (propagated-inputs
74 `(("python-simplejson" ,python-simplejson) ; not attested but required
75 ;; requirements (synapse/python_dependencies.py)
76 ("python-jsonschema" ,python-jsonschema)
77 ("python-frozendict" ,python-frozendict)
78 ("python-unpaddedbase64" ,python-unpaddedbase64)
79 ("python-canonicaljson" ,python-canonicaljson)
80 ("python-signedjson" ,python-signedjson)
81 ("python-pynacl" ,python-pynacl)
82 ("python-idna" ,python-idna)
83 ("python-service-identity" ,python-service-identity)
84 ("python-twisted" ,python-twisted)
85 ("python-treq" ,python-treq)
86 ("python-pyopenssl" ,python-pyopenssl)
87 ("python-pyyaml" ,python-pyyaml)
88 ("python-pyasn1" ,python-pyasn1)
89 ("python-pyasn1-modules" ,python-pyasn1-modules)
90 ("python-daemonize" ,python-daemonize)
91 ("python-bcrypt" ,python-bcrypt)
92 ("python-pillow" ,python-pillow)
93 ("python-sortedcontainers" ,python-sortedcontainers)
94 ("python-pymacaroons" ,python-pymacaroons)
95 ("python-msgpack" ,python-msgpack)
96 ("python-phonenumbers" ,python-phonenumbers)
97 ("python-six" ,python-six)
98 ("python-prometheus-client" ,python-prometheus-client)
99 ("python-attrs" ,python-attrs)
100 ("python-netaddr" ,python-netaddr)
101 ("python-jinja2" ,python-jinja2)
102 ("python-bleach" ,python-bleach)
103 ("python-typing-extensions" ,python-typing-extensions)
104 ;; conditional requirements (synapse/python_dependencies.py)
105 ;;("python-hiredis" ,python-hiredis)
106 ("python-matrix-synapse-ldap3" ,python-matrix-synapse-ldap3)
107 ("python-psycopg2" ,python-psycopg2)
108 ("python-jinja2" ,python-jinja2)
109 ("python-txacme" ,python-txacme)
110 ("python-pysaml2" ,python-pysaml2)
111 ("python-lxml" ,python-lxml)
112 ;; sentry-sdk, jaeger-client, and opentracing could be included, but
113 ;; all are monitoring aids and not essential.
114 ("python-pyjwt" ,python-pyjwt)))
115 (native-inputs
116 `(("python-mock" ,python-mock)
117 ("python-parameterized" ,python-parameterized)))
118 (home-page "https://github.com/matrix-org/synapse")
119 (synopsis "Matrix reference homeserver")
120 (description "Synapse is a reference \"homeserver\" implementation of
121 Matrix from the core development team at matrix.org, written in
122 Python/Twisted. It is intended to showcase the concept of Matrix and let
123 folks see the spec in the context of a codebase and let you run your own
124 homeserver and generally help bootstrap the ecosystem.")
125 (license license:asl2.0)))