gnu: ola: Update to 0.10.4.
[jackhill/guix/guix.git] / gnu / packages / lighting.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lighting)
20 #:use-module (guix build-system gnu)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages bison)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages gnunet)
29 #:use-module (gnu packages flex)
30 #:use-module (gnu packages libftdi)
31 #:use-module (gnu packages libusb)
32 #:use-module (gnu packages linux)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages protobuf))
35
36 (define-public ola
37 (package
38 (name "ola")
39 (version "0.10.4")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append
43 "https://github.com/OpenLightingProject/ola/releases/download/"
44 version "/ola-" version ".tar.gz"))
45 (patches (search-patches "ola-readdir-r.patch"))
46 (sha256
47 (base32
48 "01zpm0vpin784jyjhbdad097a4i0cjdfrqqfbsvx47d6nbssq2my"))))
49 (build-system gnu-build-system)
50 (native-inputs
51 `(("bison" ,bison)
52 ("cppunit" ,cppunit)
53 ("flex" ,flex)
54 ("pkg-config" ,pkg-config)))
55 (inputs
56 `(("libftdi" ,libftdi)
57 ("libmicrohttpd" ,libmicrohttpd)
58 ("libusb" ,libusb)
59 ("libuuid" ,util-linux)
60 ("zlib" ,zlib)))
61 (propagated-inputs
62 `(("protobuf" ,protobuf))) ;; for pkg-config --libs libola
63 (arguments
64 `(;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
65 ;; build to fail on low memory systems. We disable that with the
66 ;; following configure flags.
67 #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
68 (synopsis "Framework for controlling entertainment lighting equipment")
69 (description "The Open Lighting Architecture is a framework for lighting
70 control information. It supports a range of protocols and over a dozen USB
71 devices. It can run as a standalone service, which is useful for converting
72 signals between protocols, or alternatively using the OLA API, it can be used
73 as the backend for lighting control software. OLA runs on many different
74 platforms including ARM, which makes it a perfect fit for low cost Ethernet to
75 DMX gateways.")
76 (home-page "https://www.openlighting.org/ola")
77 (license license:lgpl2.1+)))