Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / photo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2015, 2017 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
7 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages photo)
26 #:use-module (guix build-system cmake)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system perl)
29 #:use-module (guix download)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix utils)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages algebra)
35 #:use-module (gnu packages autotools)
36 #:use-module (gnu packages base)
37 #:use-module (gnu packages boost)
38 #:use-module (gnu packages compression)
39 #:use-module (gnu packages curl)
40 #:use-module (gnu packages gettext)
41 #:use-module (gnu packages ghostscript)
42 #:use-module (gnu packages gl)
43 #:use-module (gnu packages gnome)
44 #:use-module (gnu packages glib)
45 #:use-module (gnu packages graphics)
46 #:use-module (gnu packages gtk)
47 #:use-module (gnu packages image)
48 #:use-module (gnu packages imagemagick)
49 #:use-module (gnu packages libcanberra)
50 #:use-module (gnu packages libusb)
51 #:use-module (gnu packages llvm)
52 #:use-module (gnu packages man)
53 #:use-module (gnu packages maths)
54 #:use-module (gnu packages perl)
55 #:use-module (gnu packages pkg-config)
56 #:use-module (gnu packages popt)
57 #:use-module (gnu packages python)
58 #:use-module (gnu packages python-xyz)
59 #:use-module (gnu packages readline)
60 #:use-module (gnu packages sqlite)
61 #:use-module (gnu packages tex)
62 #:use-module (gnu packages web)
63 #:use-module (gnu packages wxwidgets)
64 #:use-module (gnu packages xfig)
65 #:use-module (gnu packages xorg)
66 #:use-module (gnu packages xml)
67 #:use-module ((srfi srfi-1) #:hide (zip))
68 #:use-module (srfi srfi-26))
69
70 (define-public libraw
71 (package
72 (name "libraw")
73 (version "0.19.5")
74 (source (origin
75 (method url-fetch)
76 (uri (string-append "https://www.libraw.org/data/LibRaw-"
77 version ".tar.gz"))
78 (sha256
79 (base32
80 "1x827sh6vl8j3ll2ihkcr234y07f31hi1v7sl08jfw3irkbn58j0"))))
81 (build-system gnu-build-system)
82 (native-inputs
83 `(("pkg-config" ,pkg-config)))
84 (inputs
85 `(("libjpeg" ,libjpeg))) ;for lossy DNGs and old Kodak cameras
86 (propagated-inputs
87 `(("lcms" ,lcms))) ;for color profiles
88 (home-page "https://www.libraw.org")
89 (synopsis "Raw image decoder")
90 (description
91 "LibRaw is a library for reading RAW files obtained from digital photo
92 cameras (CRW/CR2, NEF, RAF, DNG, and others).")
93 ;; LibRaw is distributed under both LGPL2.1 and CDDL 1.0. From the README:
94 ;; "You may use one of these licensing modes and switch between them. If
95 ;; you modify LibRaw source and made your changes public, you should accept
96 ;; both two licensing modes for your changes/additions."
97 (license (list license:lgpl2.1 license:cddl1.0))))
98
99 (define-public libraw-0.18
100 (package (inherit libraw)
101 (name "libraw")
102 (version "0.18.12")
103 (source (origin
104 (method url-fetch)
105 (uri (string-append "https://www.libraw.org/data/LibRaw-"
106 version ".tar.gz"))
107 (sha256
108 (base32
109 "1m2khr2cij8z6lawgbmdksjn14fpnjsy8ad4qahnpqapm1slsxap"))))))
110
111 (define-public libexif
112 (package
113 (name "libexif")
114 (version "0.6.21")
115 (source (origin
116 (method url-fetch)
117 (uri (string-append "mirror://sourceforge/libexif/libexif/"
118 version "/libexif-" version ".tar.bz2"))
119 (patches (search-patches "libexif-CVE-2016-6328.patch"
120 "libexif-CVE-2017-7544.patch"
121 "libexif-CVE-2018-20030.patch"))
122 (sha256
123 (base32
124 "06nlsibr3ylfwp28w8f5466l6drgrnydgxrm4jmxzrmk5svaxk8n"))))
125 (build-system gnu-build-system)
126 (home-page "https://libexif.github.io/")
127 (synopsis "Read and manipulate EXIF data in digital photographs")
128 (description
129 "The libexif C library allows applications to read, edit, and save EXIF
130 data as produced by digital cameras.")
131 (license license:lgpl2.1+)))
132
133 (define-public libgphoto2
134 (package
135 (name "libgphoto2")
136 (version "2.5.24")
137 (source (origin
138 (method url-fetch)
139 (uri (string-append "mirror://sourceforge/gphoto/libgphoto/"
140 version "/libgphoto2-" version ".tar.bz2"))
141 (sha256
142 (base32
143 "0cgvsk06c4kcfj16plc27nm7g16r9ci0y4k83sf3iyphd63mfg7x"))))
144 (build-system gnu-build-system)
145 (native-inputs `(("pkg-config" ,pkg-config)))
146 (inputs
147 `(("libjpeg-turbo" ,libjpeg-turbo)
148 ("libltdl" ,libltdl)
149 ("libusb" ,libusb)
150 ("libxml2" ,libxml2)))
151 (propagated-inputs
152 `(;; The .pc refers to libexif.
153 ("libexif" ,libexif)))
154 (home-page "http://www.gphoto.org/proj/libgphoto2/")
155 (synopsis "Accessing digital cameras")
156 (description
157 "This is the library backend for gphoto2. It contains the code for PTP,
158 MTP, and other vendor specific protocols for controlling and transferring data
159 from digital cameras.")
160
161 ;; 'COPYING' says LGPLv2.1+, but in practices files are under LGPLv2+.
162 (license license:lgpl2.1+)))
163
164 (define-public gphoto2
165 (package
166 (name "gphoto2")
167 (version "2.5.23")
168 (source (origin
169 (method url-fetch)
170 (uri (string-append "mirror://sourceforge/gphoto/gphoto/" version
171 "/gphoto2-" version ".tar.bz2"))
172 (sha256
173 (base32
174 "1laqwhxr0xhbykmp0dhd3j4rr2lhj5y228s31afnqxp700hhk1yz"))))
175 (build-system gnu-build-system)
176 (native-inputs
177 `(("pkg-config" ,pkg-config)))
178 (inputs
179 `(("readline" ,readline)
180 ("libjpeg-turbo" ,libjpeg-turbo)
181 ("popt" ,popt)
182 ("libexif" ,libexif)
183 ("libgphoto2" ,libgphoto2)))
184 (arguments
185 '(#:phases
186 (modify-phases %standard-phases
187 (add-before 'check 'pre-check
188 (lambda* (#:key inputs #:allow-other-keys)
189 (substitute* (find-files "tests/data" "\\.param$")
190 (("/usr/bin/env")
191 (which "env")))
192 #t)))
193
194 ;; FIXME: There is 1 test failure, most likely related to the build
195 ;; environment.
196 #:tests? #f))
197
198 (home-page "http://www.gphoto.org/")
199 (synopsis "Command-line tools to access digital cameras")
200 (description
201 "Gphoto2 is a set of command line utilities for manipulating a large
202 number of different digital cameras. Through libgphoto2, it supports PTP,
203 MTP, and much more.")
204
205 ;; Files are typically under LGPLv2+, but 'COPYING' says GPLv2+.
206 (license license:gpl2+)))
207
208 ;; Note: See <https://metacpan.org/pod/Image::ExifTool> for the latest
209 ;; release. The versions at <https://www.sno.phy.queensu.ca/~phil/exiftool/>
210 ;; are not meant for production use according to the Changes file.
211 (define-public perl-image-exiftool
212 (package
213 (name "perl-image-exiftool")
214 (version "11.85")
215 (source
216 (origin
217 (method url-fetch)
218 (uri (list
219 (string-append "mirror://cpan/authors/id/E/EX/EXIFTOOL/"
220 "Image-ExifTool-" version ".tar.gz")
221 ;; New releases may take a while to hit CPAN.
222 (string-append "https://www.sno.phy.queensu.ca/~phil/exiftool/"
223 "Image-ExifTool-" version ".tar.gz")))
224 (sha256
225 (base32
226 "15zqm0ly2b3paqg0ym44ib2mvh6k18a9q5rvdirwipqa127al2lb"))))
227 (build-system perl-build-system)
228 (arguments
229 '(#:phases
230 (modify-phases %standard-phases
231 (add-after 'install 'post-install
232 (lambda* (#:key outputs #:allow-other-keys)
233 ;; Make sure the 'exiftool' commands finds the library.
234 ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
235 (let* ((out (assoc-ref outputs "out"))
236 (pm (find-files out "^ExifTool\\.pm$"))
237 (lib (dirname (dirname (car pm)))))
238 (wrap-program (string-append out "/bin/exiftool")
239 `("PERL5LIB" prefix (,lib)))
240 #t))))))
241 (home-page "https://metacpan.org/release/Image-ExifTool")
242 (synopsis "Program and Perl library to manipulate EXIF and other metadata")
243 (description "This package provides the @code{exiftool} command and the
244 @code{Image::ExifTool} Perl library to manipulate EXIF tags of digital images
245 and a wide variety of other metadata.")
246 (license license:perl-license)))
247
248 (define-public libpano13
249 (package
250 (name "libpano13")
251 (version "2.9.19")
252 (source (origin
253 (method url-fetch)
254 (uri (string-append "mirror://sourceforge/panotools/libpano13/"
255 "libpano13-" version "/"
256 "libpano13-" version ".tar.gz"))
257 (sha256
258 (base32
259 "1a4m3plmfcrrplqs9zfzhc5apibn10m5sajpizm1sd3q74w5fwq3"))))
260 (build-system cmake-build-system)
261 (inputs
262 `(("libjpeg" ,libjpeg)
263 ("libpng" ,libpng)
264 ("libtiff" ,libtiff)
265 ("zlib" ,zlib)))
266 (home-page "http://panotools.sourceforge.net/")
267 (synopsis "Library for panoramic images")
268 (description
269 "The libpano13 package contains the backend library written by the
270 Panorama Tools project for building panoramic images from a set of
271 overlapping images, as well as some command line tools.")
272 (license license:gpl2+)))
273
274 (define-public enblend-enfuse
275 (package
276 (name "enblend-enfuse")
277 (version "4.2")
278 (source (origin
279 (method url-fetch)
280 (uri (string-append "mirror://sourceforge/enblend/"
281 name "/"
282 name "-" (version-major+minor version) "/"
283 name "-" version ".tar.gz"))
284 (sha256
285 (base32
286 "0j5x011ilalb47ssah50ag0a4phgh1b0wdgxdbbp1gcyjcjf60w7"))))
287 (build-system gnu-build-system)
288 (native-inputs
289 `(("pkg-config" ,pkg-config)
290 ("perl" ,perl)
291 ("perl-timedate" ,perl-timedate)
292 ;; for building the documentation
293 ("gnuplot" ,gnuplot)
294 ("help2man" ,help2man)
295 ("imagemagick" ,imagemagick)
296 ("libxml2" ,libxml2)
297 ("texlive-minimal" ,texlive-tiny)
298 ("tidy" ,tidy)
299 ("transfig" ,transfig)))
300 (inputs
301 `(("boost" ,boost)
302 ("gsl" ,gsl)
303 ("lcms" ,lcms)
304 ("libjpeg" ,libjpeg)
305 ("libpng" ,libpng)
306 ("libtiff" ,libtiff)
307 ("openexr" ,openexr)
308 ("vigra" ,vigra)
309 ("zlib" ,zlib)))
310 (arguments
311 `(#:configure-flags `("--enable-openmp")))
312 (home-page "http://enblend.sourceforge.net/")
313 (synopsis "Tools for combining and blending images")
314 (description
315 "Enblend blends away the seams in a panoramic image mosaic using a
316 multi-resolution spline. Enfuse merges different exposures of the same
317 scene to produce an image that looks much like a tone-mapped image.")
318 (license license:gpl2+)))
319
320 (define-public lensfun
321 (package
322 (name "lensfun")
323 (version "0.3.2")
324 (source (origin
325 (method url-fetch)
326 (uri (string-append
327 "mirror://sourceforge/lensfun/"
328 version "/lensfun-" version ".tar.gz"))
329 (sha256
330 (base32
331 "0cfk8jjhs9nbfjfdy98plrj9ayi59aph0nx6ppslgjhlcvacm2xf"))))
332 (build-system cmake-build-system)
333 (arguments
334 `(,@(if (any (cute string-prefix? <> (or (%current-system)
335 (%current-target-system)))
336 '("x86_64" "i686"))
337 ;; SSE and SSE2 are supported only on Intel processors.
338 '()
339 '(#:configure-flags '("-DBUILD_FOR_SSE=OFF" "-DBUILD_FOR_SSE2=OFF")))
340 #:tests? #f)) ; There are no tests to run.
341 (native-inputs
342 `(("pkg-config" ,pkg-config)))
343 (inputs
344 `(("glib" ,glib)))
345 (home-page "https://sourceforge.net/projects/lensfun/")
346 (synopsis "Library to correct optical lens defects with a lens database")
347 (description "Digital photographs are not ideal. Of course, the better is
348 your camera, the better the results will be, but in any case if you look
349 carefully at shots taken even by the most expensive cameras equipped with the
350 most expensive lenses you will see various artifacts. It is very hard to make
351 ideal cameras, because there are a lot of factors that affect the final image
352 quality, and at some point camera and lens designers have to trade one factor
353 for another to achieve the optimal image quality, within the given design
354 restrictions and budget. But we all want ideal shots, don't we? So that's
355 what's Lensfun is all about: rectifying the defects introduced by your
356 photographic equipment.")
357 ;; The libraries are licensed under the LGPL3, the programs are
358 ;; licensed GPL3, and the database is license CC-BY-SA 3.0. See the
359 ;; README.md file for this clarification.
360 (license (list license:lgpl3 license:gpl3 license:cc-by-sa3.0))))
361
362 (define-public darktable
363 (package
364 (name "darktable")
365 (version "2.6.3")
366 (source
367 (origin
368 (method url-fetch)
369 (uri (string-append
370 "https://github.com/darktable-org/darktable/releases/"
371 "download/release-" version "/darktable-" version ".tar.xz"))
372 (sha256
373 (base32 "1w3q3dhcxa0bs590zbsj61ap8z84wmn04xs5q3gjwisqhjf9j655"))))
374 (build-system cmake-build-system)
375 (arguments
376 `(#:tests? #f ; there are no tests
377 #:configure-flags '("-DBINARY_PACKAGE_BUILD=On")
378 #:phases
379 (modify-phases %standard-phases
380 (add-before 'configure 'set-LDFLAGS-and-CPATH
381 (lambda* (#:key inputs outputs #:allow-other-keys)
382 (setenv "LDFLAGS"
383 (string-append
384 "-Wl,-rpath="
385 (assoc-ref outputs "out") "/lib/darktable"))
386
387 ;; Ensure the OpenEXR headers are found.
388 (setenv "CPATH"
389 (string-append (assoc-ref inputs "ilmbase")
390 "/include/OpenEXR:" (or (getenv "CPATH") "")))
391 #t)))))
392 (inputs
393 `(("libxslt" ,libxslt)
394 ("libxml2" ,libxml2)
395 ("pugixml" ,pugixml)
396 ("gtk+" ,gtk+)
397 ("sqlite" ,sqlite)
398 ("libjpeg" ,libjpeg)
399 ("libpng" ,libpng)
400 ("cairo" ,cairo)
401 ("lcms" ,lcms)
402 ("exiv2" ,exiv2)
403 ("libtiff" ,libtiff)
404 ("curl" ,curl)
405 ("libgphoto2" ,libgphoto2)
406 ("dbus-glib" ,dbus-glib)
407 ("openexr" ,openexr)
408 ("ilmbase" ,ilmbase)
409 ("libsoup" ,libsoup)
410 ("python-jsonschema" ,python-jsonschema)
411 ("intltool" ,intltool)
412 ("perl" ,perl)
413 ("pkg-config" ,pkg-config)
414 ("libwebp" ,libwebp)
415 ("lensfun" ,lensfun)
416 ("librsvg" ,librsvg)
417 ("json-glib" ,json-glib)
418 ("freeimage" ,freeimage)))
419 (home-page "https://www.darktable.org")
420 (synopsis "Virtual lighttable and darkroom for photographers")
421 (description "Darktable is a photography workflow application and RAW
422 developer. It manages your digital negatives in a database, lets you view
423 them through a zoomable lighttable and enables you to develop raw images
424 and enhance them.")
425 ;; See src/is_supported_platform.h for supported platforms.
426 (supported-systems '("i686-linux" "x86_64-linux" "aarch64-linux"))
427 (license license:gpl3+)))
428
429 (define-public hugin
430 (package
431 (name "hugin")
432 (version "2019.0.0")
433 (source (origin
434 (method url-fetch)
435 (uri (string-append "mirror://sourceforge/hugin/hugin/hugin-"
436 (version-major+minor version)
437 "/hugin-" version ".tar.bz2"))
438 (sha256
439 (base32
440 "1l925qslp98gg7yzmgps10h6dq0nb60wbfk345anlxsv0g2ifizr"))))
441 (build-system cmake-build-system)
442 (native-inputs
443 `(("gettext" ,gnu-gettext)
444 ("pkg-config" ,pkg-config)))
445 (inputs
446 `(("boost" ,boost)
447 ("enblend-enfuse" ,enblend-enfuse)
448 ("exiv2" ,exiv2-0.26)
449 ("fftw" ,fftw)
450 ("flann" ,flann)
451 ("freeglut" ,freeglut)
452 ("glew" ,glew)
453 ("lcms" ,lcms)
454 ("libjpeg" ,libjpeg)
455 ("libpano13" ,libpano13)
456 ("libpng" ,libpng)
457 ("libtiff" ,libtiff)
458 ("libxi" ,libxi)
459 ("libxmu" ,libxmu)
460 ("mesa" ,mesa)
461 ("openexr" ,openexr)
462 ("sqlite" ,sqlite)
463 ("vigra" ,vigra)
464 ("wxwidgets" ,wxwidgets)
465 ("zlib" ,zlib)))
466 (arguments
467 `(#:tests? #f ; no check target
468 #:configure-flags
469 (list
470 ;; The header files of ilmbase (propagated by openexr) are not found
471 ;; when included by the header files of openexr, and an explicit
472 ;; flag needs to be set.
473 (string-append "-DCMAKE_CXX_FLAGS=-I"
474 (assoc-ref %build-inputs "ilmbase")
475 "/include/OpenEXR")
476 ;; Disable installation of the Python scripting interface.
477 ;; It would require the additional inputs python and swig.
478 ;; Installation would need to be tweaked, as it tries to install
479 ;; into the python directory.
480 "-DBUILD_HSI=OFF")
481 #:phases
482 (modify-phases %standard-phases
483 (add-before 'configure 'substitute
484 (lambda _
485 (substitute* "src/hugin1/base_wx/StitchingExecutor.cpp"
486 (("wxT\\(\"enblend\"\\)")
487 (string-append "wxT(\"" (which "enblend") "\")"))
488 (("wxT\\(\"enfuse\"\\)")
489 (string-append "wxT(\"" (which "enfuse") "\")")))
490 #t)))))
491 (home-page "http://hugin.sourceforge.net/")
492 (synopsis "Panorama photo stitcher")
493 (description
494 "Hugin is an easy to use panoramic imaging toolchain with a graphical
495 user interface. It can be used to assemble a mosaic of photographs into
496 a complete panorama and stitch any series of overlapping pictures.")
497 (license license:gpl2+)))
498
499 (define-public rawtherapee
500 (package
501 (name "rawtherapee")
502 (version "5.8")
503 (source (origin
504 (method url-fetch)
505 (uri (string-append "http://rawtherapee.com/shared/source/"
506 "rawtherapee-" version ".tar.xz"))
507 (sha256
508 (base32
509 "0lq8qi7g0a28h3rab7bk5bbbd4gvfma42bvlz1dfn8p9mah2h19n"))))
510 (build-system cmake-build-system)
511 (arguments
512 '(#:tests? #f ; no test suite
513 #:build-type "release"
514 #:configure-flags
515 (list (string-append "-DLENSFUNDBDIR="
516 (assoc-ref %build-inputs "lensfun")
517 "/share/lensfun")
518 ;; Don't optimize the build for the host machine. See the file
519 ;; 'ProcessorTargets.cmake' in the source distribution for more
520 ;; information.
521 "-DPROC_TARGET_NUMBER=1"
522 ;; These flags are recommended by upstream for distributed packages.
523 ;; See the file 'RELEASE_NOTES.txt' in the source distribution.
524 "-O3"
525 "-DCACHE_NAME_SUFFIX=\"\"")))
526 (native-inputs
527 `(("pkg-config" ,pkg-config)))
528 (inputs
529 `(("expat" ,expat)
530 ("fftw" ,fftwf)
531 ("glib" ,glib)
532 ("glibmm" ,glibmm)
533 ("gtk+" ,gtk+)
534 ("gtkmm" ,gtkmm)
535 ("lcms" ,lcms)
536 ("lensfun" ,lensfun)
537 ("libcanberra" ,libcanberra)
538 ("libiptcdata" ,libiptcdata)
539 ("libjpeg" ,libjpeg)
540 ("libpng" ,libpng)
541 ("librsvg" ,librsvg)
542 ("libsigc++" ,libsigc++)
543 ("libtiff" ,libtiff)
544 ("zlib" ,zlib)))
545 (home-page "http://rawtherapee.com")
546 (synopsis "Raw image developing and processing")
547 (description "RawTherapee is a raw image processing suite. It comprises a
548 subset of image editing operations specifically aimed at non-destructive raw
549 photo post-production and is primarily focused on improving a photographer's
550 workflow by facilitating the handling of large numbers of images. Most raw
551 formats are supported, including Pentax Pixel Shift, Canon Dual-Pixel, and those
552 from Foveon and X-Trans sensors.")
553 (license license:gpl3+)))