gnu: nano: Upgrade to 2.3.4.
[jackhill/guix/guix.git] / gnu / packages / nano.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages nano)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages gettext)
22 #:use-module (gnu packages ncurses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public nano
28 (package
29 (name "nano")
30 (version "2.3.4")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/nano/nano-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1hcqv5yam4pkqx1sviigikzvd7n1pz6lwp7lzpdzagck9fgi4x0p"))))
39 (build-system gnu-build-system)
40 (inputs
41 `(("gettext" ,gnu-gettext)
42 ("ncurses" ,ncurses)))
43 (home-page "http://www.nano-editor.org/")
44 (synopsis "Small, user-friendly console text editor")
45 (description
46 "GNU Nano is a small and simple text editor. In addition to basic
47 editing, it supports interactive search and replace, go to line and column
48 number, auto-indentation and more.")
49 (license gpl3+))) ; some files are under GPLv2+