Revert "PRELIMINARY: gnu: Add network-manager."
[jackhill/guix/guix.git] / gnu / packages / dictionaries.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages dictionaries)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system trivial)
24 #:use-module (gnu packages base)
25 #:use-module (gnu packages texinfo)
26 #:use-module ((gnu packages compression)
27 #:select (gzip)))
28
29 (define-public vera
30 (package
31 (name "vera")
32 (version "1.22")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/vera/vera-" version
36 ".tar.gz"))
37 (sha256
38 (base32
39 "1anx6ikwlkg7bn3c5a8xxrp33bvhfgxmncvnqbn2fp1hnbhqh5i7"))))
40 (build-system trivial-build-system)
41 (arguments
42 `(#:builder (begin
43 (use-modules (guix build utils))
44
45 (let* ((out (assoc-ref %outputs "out"))
46 (info (string-append out "/share/info"))
47 (html (string-append out "/share/html"))
48 (source (assoc-ref %build-inputs "source"))
49 (tar (assoc-ref %build-inputs "tar"))
50 (gz (assoc-ref %build-inputs "gzip"))
51 (texi (assoc-ref %build-inputs "texinfo")))
52 (setenv "PATH" (string-append gz "/bin"))
53 (system* (string-append tar "/bin/tar") "xvf" source)
54
55 (chdir (string-append "vera-" ,version))
56 (mkdir-p info)
57 (mkdir-p html)
58
59 ;; XXX: Use '--force' because the document is unhappy
60 ;; with Texinfo 5 (yes, documents can be unhappy.)
61 (and (zero?
62 (system* (string-append texi "/bin/makeinfo")
63 "vera.texi" "--force" "-o"
64 (string-append info "/vera.info")))
65 (zero?
66 (system* (string-append texi "/bin/makeinfo")
67 "vera.texi" "--force" "--html" "-o"
68 (string-append html "/vera.html"))))))
69 #:modules ((guix build utils))))
70 (native-inputs `(("texinfo" ,texinfo)
71 ("tar" ,tar)
72 ("gzip" ,gzip)))
73 (home-page "http://savannah.gnu.org/projects/vera/")
74 (synopsis "List of acronyms")
75 (description
76 "V.E.R.A. (Virtual Entity of Relevant Acronyms) is a list of computing
77 acronyms distributed as an info document.")
78 (license fdl1.3+)))