gnu: xorg: Disable not compiling xf86-video-geode.
[jackhill/guix/guix.git] / gnu / packages / patchelf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages patchelf)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public patchelf
26 (package
27 (name "patchelf")
28 (version "0.6")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append
32 "http://nixos.org/releases/patchelf/patchelf-"
33 version
34 "/patchelf-"
35 version
36 ".tar.bz2"))
37 (sha256
38 (base32
39 "00bw29vdsscsili65wcb5ay0gvg1w0ljd00sb5xc6br8bylpyzpw"))))
40 (build-system gnu-build-system)
41 (home-page "http://nixos.org/patchelf.html")
42 (synopsis
43 "A small utility to modify the dynamic linker and RPATH of ELF executables")
44 (description
45 "PatchELF allows the ELF \"interpreter\" and RPATH of an ELF binary to be
46 changed.")
47 (license gpl3+)))