gnu: xorg: Disable not compiling xf86-video-geode.
[jackhill/guix/guix.git] / gnu / packages / libunistring.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libunistring)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public libunistring
26 (package
27 (name "libunistring")
28 (version "0.9.3")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append
32 "mirror://gnu/libunistring/libunistring-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "18q620269xzpw39dwvr9zpilnl2dkw5z5kz3mxaadnpv4k3kw3b1"))))
37 (propagated-inputs '()) ; FIXME: add libiconv when !glibc
38 (build-system gnu-build-system)
39 (synopsis "GNU Libunistring, a Unicode string library")
40 (description
41 "This library provides functions for manipulating Unicode strings and for
42 manipulating C strings according to the Unicode standard.
43
44 GNU libunistring is for you if your application involves non-trivial text
45 processing, such as upper/lower case conversions, line breaking, operations
46 on words, or more advanced analysis of text. Text provided by the user can,
47 in general, contain characters of all kinds of scripts. The text processing
48 functions provided by this library handle all scripts and all languages.
49
50 libunistring is for you if your application already uses the ISO C / POSIX
51 <ctype.h>, <wctype.h> functions and the text it operates on is provided by
52 the user and can be in any language.
53
54 libunistring is also for you if your application uses Unicode strings as
55 internal in-memory representation.")
56 (home-page "http://www.gnu.org/software/libunistring/")
57 (license lgpl3+)))