gnu: xorg: Disable not compiling xf86-video-geode.
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libidn)
20 #:use-module (gnu packages)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public libidn
27 (package
28 (name "libidn")
29 (version "1.26")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/libidn/libidn-" version
33 ".tar.gz"))
34 (sha256 (base32
35 "0g657kv60rh486m7bwyp5k24ljmym4wnb8nmk6d3i3qgr1qlqbqa"))))
36 (build-system gnu-build-system)
37 ;; FIXME: No Java and C# libraries are currently built.
38 (synopsis "GNU Libidn, a library to encode and decode internationalised domain names")
39 (description
40 "GNU Libidn is a fully documented implementation of the Stringprep,
41 Punycode and IDNA specifications. Libidn's purpose is to encode and decode
42 internationalised domain names.
43
44 The library contains a generic Stringprep implementation. Profiles for
45 Nameprep, iSCSI, SASL, XMPP and Kerberos V5 are included. Punycode and
46 ASCII Compatible Encoding (ACE) via IDNA are supported. A mechanism to
47 define Top-Level Domain (TLD) specific validation tables, and to compare
48 strings against those tables, is included.
49 Default tables for some TLDs are also included.")
50 (license lgpl2.1+)
51 (home-page "http://www.gnu.org/software/libidn/")))