gnu: xorg: Disable not compiling xf86-video-geode.
[jackhill/guix/guix.git] / gnu / packages / ed.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages ed)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public ed
27 (package
28 (name "ed")
29 (version "1.6")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/ed/ed-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "0rcay0wci2kiwil2h505b674cblmn4nq8pqw9g9pgqmaqjq6f711"))))
37 (build-system gnu-build-system)
38 (arguments
39 '(#:configure-flags '("CC=gcc")
40 #:phases (alist-cons-before 'patch-source-shebangs 'patch-test-suite
41 (lambda _
42 (substitute* "testsuite/check.sh"
43 (("/bin/sh") (which "sh"))))
44 %standard-phases)))
45 (home-page "http://www.gnu.org/software/ed/")
46 (synopsis
47 "GNU ed, an implementation of the standard Unix editor")
48 (description
49 "GNU ed is a line-oriented text editor. It is used to create,
50 display, modify and otherwise manipulate text files, both
51 interactively and via shell scripts. A restricted version of ed,
52 red, can only edit files in the current directory and cannot
53 execute shell commands. Ed is the \"standard\" text editor in the
54 sense that it is the original editor for Unix, and thus widely
55 available. For most purposes, however, it is superseded by
56 full-screen editors such as GNU Emacs or GNU Moe.")
57 (license gpl3+)))