gnu: bootstrap: Memoize 'bootstrap-origin'.
[jackhill/guix/guix.git] / gnu / packages / rsync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages rsync)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages acl)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages popt)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix build-system cmake)
34 #:use-module (guix build-system gnu))
35
36
37 (define-public rsync
38 (package
39 (name "rsync")
40 (version "3.1.3")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "http://rsync.samba.org/ftp/rsync/src/rsync-"
44 version ".tar.gz"))
45 (sha256
46 (base32
47 "1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
48 (build-system gnu-build-system)
49 (inputs `(("perl" ,perl)
50 ("acl" ,acl)))
51 (synopsis "Remote (and local) file copying tool")
52 (description
53 "Rsync is a fast and versatile file copying tool. It can copy locally,
54 to/from another host over any remote shell, or to/from a remote rsync daemon.
55 Its delta-transfer algorithm reduces the amount of data sent over the network
56 by sending only the differences between the source files and the existing
57 files in the destination.")
58 (license license:gpl3+)
59 (home-page "http://rsync.samba.org/")))
60
61 (define-public librsync
62 (package
63 (name "librsync")
64 (version "2.0.2")
65 (source (origin
66 (method url-fetch)
67 (uri (string-append "https://github.com/librsync/librsync/archive/v"
68 version ".tar.gz"))
69 (sha256
70 (base32
71 "1waa581pcscc1rnvy06cj584k5dx0dc7jj79wsdj7xw4xqh9ayz6"))))
72 (build-system cmake-build-system)
73 (inputs
74 `(("popt" ,popt)))
75 (native-inputs
76 `(("which" ,which)
77 ("perl" ,perl)))
78 (home-page "http://librsync.sourceforge.net/")
79 (synopsis "Implementation of the rsync remote-delta algorithm")
80 (description
81 "Librsync is a free software library that implements the rsync
82 remote-delta algorithm. This algorithm allows efficient remote updates of a
83 file, without requiring the old and new versions to both be present at the
84 sending end. The library uses a \"streaming\" design similar to that of zlib
85 with the aim of allowing it to be embedded into many different applications.")
86 (license license:lgpl2.1+)))
87
88 (define-public librsync-0.9
89 (package
90 (inherit librsync)
91 (version "0.9.7")
92 (source (origin
93 (method url-fetch)
94 (uri (string-append "mirror://sourceforge/librsync/librsync/"
95 version "/librsync-" version ".tar.gz"))
96 (sha256
97 (base32
98 "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
99 (build-system gnu-build-system)
100 (arguments '(#:configure-flags '("--enable-shared")))
101 (inputs '())))