gnu: groff: Add "doc" output.
[jackhill/guix/guix.git] / gnu / packages / groff.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages groff)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages bison)
27 #:use-module (gnu packages ghostscript)
28 #:use-module (gnu packages netpbm)
29 #:use-module (gnu packages perl)
30 #:use-module (gnu packages texinfo))
31
32 (define-public groff
33 (package
34 (name "groff")
35 (version "1.22.3")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/groff/groff-" version
39 ".tar.gz"))
40 (sha256 (base32
41 "1998v2kcs288d3y7kfxpvl369nqi06zbbvjzafyvyl3pr7bajj1s"))))
42 (build-system gnu-build-system)
43 (outputs '("out"
44 "doc")) ;12MiB of PS, PDF, HTML, and examples
45 (inputs `(("ghostscript" ,ghostscript)
46 ("netpbm" ,netpbm)))
47 (native-inputs `(("bison" ,bison)
48 ("perl" ,perl)
49 ("psutils" ,psutils)
50 ("texinfo" ,texinfo)))
51 (arguments '(#:parallel-build? #f)) ; parallel build fails
52 (synopsis "Typesetting from plain text mixed with formatting commands")
53 (description
54 "Groff is a typesetting package that reads plain text and produces
55 formatted output based on formatting commands contained within the text. It
56 is usually the formatter of \"man\" documentation pages.")
57 (license gpl3+)
58 (home-page "http://www.gnu.org/software/groff/")))