gnu: maven-resources-plugin: Don't use unstable tarball.
[jackhill/guix/guix.git] / gnu / packages / kde-multimedia.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages kde-multimedia)
21 #:use-module (guix build-system qt)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix utils)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages audio)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages cdrom)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages gnome)
34 #:use-module (gnu packages gstreamer)
35 #:use-module (gnu packages kde-frameworks)
36 #:use-module (gnu packages libcanberra)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages mp3)
39 #:use-module (gnu packages music)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages pulseaudio)
42 #:use-module (gnu packages qt)
43 #:use-module (gnu packages video)
44 #:use-module (gnu packages xiph)
45 #:use-module (gnu packages xorg))
46
47 (define-public audiocd-kio
48 (package
49 (name "audiocd-kio")
50 (version "20.04.1")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (string-append "mirror://kde/stable/release-service/" version
55 "/src/audiocd-kio-" version ".tar.xz"))
56 (sha256
57 (base32 "0qlnxxbayqhz25jbvzis27jw2zbw1pmacp8rv7v5wa7zfqn3kmyk"))))
58 (build-system qt-build-system)
59 (native-inputs
60 `(("extra-cmake-modules" ,extra-cmake-modules)
61 ("kdoctools" ,kdoctools)))
62 (inputs
63 `(("cdparanoia" ,cdparanoia)
64 ("flac" ,flac)
65 ("kcmutils" ,kcmutils)
66 ("kconfig" ,kconfig)
67 ("ki18n" ,ki18n)
68 ("kio" ,kio)
69 ("libkcddb" ,libkcddb)
70 ("libkcompactdisc", libkcompactdisc)
71 ("libvorbis" ,libvorbis)
72 ("phonon" ,phonon)
73 ("qtbase" ,qtbase)))
74 (home-page "https://kde.org/applications/multimedia/org.kde.kio_audiocd")
75 (synopsis "Transparent audio CD integration for applications using the KDE
76 Platform")
77 (description "KIO AudioCD is a KIO slave that enables KIO-aware
78 applications (such as Dolphin or k3b) to access audio and CD text data on the
79 audio compact disks. It allows transparent drag and drop conversion of audio
80 data into the popular formats and has a configuration System Settings module
81 available in the \"Multimedia\" section.
82
83 This package is part of the KDE multimedia module.")
84 (license ;; GPL for programs, FDL for documentation
85 (list license:gpl2+ license:fdl1.2+))))
86
87 (define-public dragon
88 (package
89 (name "dragon")
90 (version "20.04.1")
91 (source
92 (origin
93 (method url-fetch)
94 (uri (string-append "mirror://kde/stable/release-service/" version
95 "/src/dragon-" version ".tar.xz"))
96 (sha256
97 (base32 "1sssg20a1vpwk816lp5jgwahilaswb9f3hgfqvc73il4g11ky1xj"))))
98 (build-system qt-build-system)
99 (native-inputs
100 `(("extra-cmake-modules" ,extra-cmake-modules)
101 ("kdoctools" ,kdoctools)))
102 (inputs
103 `(("kconfig" ,kconfig)
104 ("kconfigwidgets" ,kconfigwidgets)
105 ("kcoreaddons" ,kcoreaddons)
106 ("kcrash" ,kcrash)
107 ("kdbusaddons" ,kdbusaddons)
108 ("ki18n" ,ki18n)
109 ("kio" ,kio)
110 ("kjobwidgets" ,kjobwidgets)
111 ("knotifications" ,knotifications)
112 ("kparts" ,kparts)
113 ("kwidgetsaddons" ,kwidgetsaddons)
114 ("kwindowsystem" ,kwindowsystem)
115 ("kxmlgui" ,kxmlgui)
116 ("oxygen-icons" ,oxygen-icons) ; default icon set
117 ("phonon" ,phonon)
118 ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
119 ("qtbase" ,qtbase)
120 ("solid" ,solid)))
121 (home-page "https://kde.org/applications/multimedia/org.kde.dragonplayer")
122 (synopsis "Simple video player")
123 (description "Dragon Player is a multimedia player where the focus is on
124 simplicity, instead of features. Dragon Player does one thing, and only one
125 thing, which is playing multimedia files. It's simple interface is designed
126 not to get in your way and instead empower you to simply play multimedia
127 files.
128
129 This package is part of the KDE multimedia module.")
130 (license ;; GPL for programs, FDL for documentation
131 (list license:gpl2+ license:fdl1.2+))))
132
133 (define-public elisa
134 (package
135 (name "elisa")
136 (version "0.4.2")
137 (source
138 (origin
139 (method url-fetch)
140 (uri (string-append "mirror://kde//stable/elisa/0.4.2"
141 "/elisa-" version ".tar.xz"))
142 (sha256
143 (base32 "0v9af6l89pgz1g7naf7gwcnq8znlicyh7z985kxalbdmv359c97w"))))
144 (build-system qt-build-system)
145 (native-inputs
146 `(("extra-cmake-modules" ,extra-cmake-modules)
147 ("pkg-config" ,pkg-config)
148 ("dbus" ,dbus)
149 ("kdoctools" ,kdoctools)
150 ("xorg-server" , xorg-server-for-tests)))
151 (inputs
152 `(("kconfig" ,kconfig)
153 ("baloo" ,baloo)
154 ("kconfigwidgets" ,kconfigwidgets)
155 ("kcoreaddons" ,kcoreaddons)
156 ("kcrash" ,kcrash)
157 ("kcmutils" ,kcmutils)
158 ("kdbusaddons" ,kdbusaddons)
159 ("kdeclarative" ,kdeclarative)
160 ("kfilemetadata" ,kfilemetadata)
161 ("ki18n" ,ki18n)
162 ("kio" ,kio)
163 ("kirigami" ,kirigami)
164 ("kmediaplayer" ,kmediaplayer)
165 ("kparts" ,kparts)
166 ("kpackage" ,kpackage)
167 ("kwidgetsaddons" ,kwidgetsaddons)
168 ("kxmlgui" ,kxmlgui)
169 ("oxygen-icons" ,oxygen-icons) ; default icon set
170 ("phonon" ,phonon)
171 ("qtbase" ,qtbase)
172 ("qtdeclarative" ,qtdeclarative)
173 ("qtgraphicaleffects" ,qtgraphicaleffects) ; not listed as dependency
174 ("qtmultimedia" ,qtmultimedia)
175 ("qtquickcontrols" ,qtquickcontrols)
176 ("qtquickcontrols2" ,qtquickcontrols2)
177 ("qtsvg" ,qtsvg)
178 ("qtx11extras" ,qtx11extras)
179 ;; TODO: upnpqt https://gitlab.com/homeautomationqt/upnp-player-qt
180 ("vlc" ,vlc)))
181 (arguments
182 `(#:phases
183 (modify-phases %standard-phases
184 (add-before 'check 'start-xorg-server
185 (lambda* (#:key inputs #:allow-other-keys)
186 ;; The test suite requires a running X server, setting
187 ;; QT_QPA_PLATFORM=offscreen does not suffice.
188 (system (string-append (assoc-ref inputs "xorg-server")
189 "/bin/Xvfb :1 -screen 0 640x480x24 &"))
190 (setenv "DISPLAY" ":1")
191 #t)))))
192 (home-page "https://kde.org/applications/multimedia/org.kde.elisa")
193 (synopsis "Powerful music player for Plasma 5")
194 (description "Elisa is a simple music player aiming to provide a nice
195 experience for its users. Elisa browses music by album, artist or
196 all tracks. The music is indexed using either a private indexer or an indexer
197 using Baloo. The private one can be configured to scan music on chosen paths.
198 The Baloo one is much faster because Baloo is providing all needed data from
199 its own database. You can build and play your own playlist.")
200 (license license:lgpl3+)))
201
202 (define-public ffmpegthumbs
203 (package
204 (name "ffmpegthumbs")
205 (version "20.04.1")
206 (source
207 (origin
208 (method url-fetch)
209 (uri (string-append "mirror://kde/stable/release-service/" version
210 "/src/ffmpegthumbs-" version ".tar.xz"))
211 (sha256
212 (base32 "17l50z33a1h5zkrrfkb261yi2hms66qj36l1mndq7mvs97y2ggmc"))))
213 (build-system qt-build-system)
214 (native-inputs
215 `(("extra-cmake-modules" ,extra-cmake-modules)
216 ("pkg-config" ,pkg-config)))
217 (inputs
218 `(("ffmpeg" ,ffmpeg)
219 ("kconfig" ,kconfig)
220 ("ki18n" ,ki18n)
221 ("kio" ,kio)
222 ("qtbase" ,qtbase)))
223 (home-page "https://kde.org/applications/multimedia/org.kde.ffmpegthumbs")
224 (synopsis "Video thumbnail generator for KDE using ffmpeg")
225 (description "
226 FFMpegThumbs is a video thumbnail generator for KDE file managers
227 like Dolphin and Konqueror. It enables them to show preview images
228 of video files using FFMpeg.
229
230 This package is part of the KDE multimedia module.")
231 (license license:gpl2+)))
232
233 (define-public juk
234 (package
235 (name "juk")
236 (version "20.04.1")
237 (source
238 (origin
239 (method url-fetch)
240 (uri (string-append "mirror://kde/stable/release-service/" version
241 "/src/juk-" version ".tar.xz"))
242 (sha256
243 (base32 "06vsh7knyhcbcbf632jhldbqpzfkdyils2l8dbcdw5nj5hhgzzmr"))))
244 (build-system qt-build-system)
245 (native-inputs
246 `(("extra-cmake-modules" ,extra-cmake-modules)))
247 (inputs
248 `(("kcoreaddons" ,kcoreaddons)
249 ("kcompletion" ,kcompletion)
250 ("kconfig" ,kconfig)
251 ("kcrash" ,kcrash)
252 ("kdbusaddons" ,kdbusaddons)
253 ("kdoctools" ,kdoctools)
254 ("kglobalaccel" ,kglobalaccel)
255 ("ki18n" ,ki18n)
256 ("kiconthemes" ,kiconthemes)
257 ("kjobwidgets" ,kjobwidgets)
258 ("kio" ,kio)
259 ("knotifications" ,knotifications)
260 ("ktextwidgets" ,ktextwidgets)
261 ("kwallet" ,kwallet)
262 ("kwidgetsaddons" ,kwidgetsaddons)
263 ("kwindowsystem" ,kwindowsystem)
264 ("kxmlgui" ,kxmlgui)
265 ("oxygen-icons" ,oxygen-icons) ; default icon set
266 ("phonon" ,phonon)
267 ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
268 ("qtbase" ,qtbase)
269 ("qtsvg" ,qtsvg)
270 ("taglib" ,taglib)))
271 (home-page "https://kde.org/applications/multimedia/org.kde.juk")
272 (synopsis "Music jukebox / music player")
273 (description "JuK is a powerful music player capable of managing a large
274 music collection.
275
276 Some of JuK's features include:
277 @itemize
278 @item Music collection, playlists, and smart playlists
279 @item Tag editing support, including the ability to edit multiple files at once
280 @item Tag-based music file organization and renaming
281 @item CD burning support using k3b
282 @item Album art using Google Image Search
283 @end itemize
284
285 This package is part of the KDE multimedia module.")
286 (license license:gpl2+)))
287
288 (define-public k3b
289 (package
290 (name "k3b")
291 (version "20.04.2")
292 (source
293 (origin
294 (method url-fetch)
295 (uri (string-append "mirror://kde/stable/release-service/" version
296 "/src/k3b-" version ".tar.xz"))
297 (sha256
298 (base32 "15wm987hz6rfs9ds9l1gbs6gdsardj1ywvk6zmpvj2i2190y4b3q"))))
299 (build-system qt-build-system)
300 (arguments
301 `(#:phases
302 (modify-phases %standard-phases
303 (add-after 'unpack 'set-absolute-library-paths
304 (lambda _
305 ;; Set absolute paths for dlopened libraries. We can’t use k3b’s
306 ;; runpath as they are loaded by the Qt library.
307 (let ((libcdio-paranoia (assoc-ref %build-inputs "libcdio-paranoia"))
308 (libdvdcss (assoc-ref %build-inputs "libdvdcss")))
309 (substitute* "libk3b/tools/k3bcdparanoialib.cpp"
310 (("\"(cdio_cdda|cdio_paranoia)\"" _ library)
311 (string-append "\"" libcdio-paranoia "/lib/" library "\"")))
312 (substitute* "libk3b/tools/k3blibdvdcss.cpp"
313 (("\"(dvdcss)\"" _ library)
314 (string-append "\"" libdvdcss "/lib/" library "\""))))
315 #t))
316 (add-after 'qt-wrap 'wrap-path
317 (lambda _
318 ;; Set paths to backend programs.
319 (wrap-program (string-append (assoc-ref %outputs "out") "/bin/k3b")
320 `("PATH" ":" prefix
321 ,(map (lambda (input)
322 (string-append (assoc-ref %build-inputs input) "/bin"))
323 '("cdrdao" "dvd+rw-tools" "libburn" "sox"))))
324 #t)))))
325 (native-inputs
326 `(("extra-cmake-modules" ,extra-cmake-modules)
327 ("pkg-config" ,pkg-config)
328 ("kdoctools" ,kdoctools)))
329 (inputs
330 `(("cdrdao" ,cdrdao)
331 ("dvd+rw-tools" ,dvd+rw-tools)
332 ("ffmpeg" ,ffmpeg)
333 ("flac" ,flac)
334 ("karchive" ,karchive)
335 ("kcmutils" ,kcmutils)
336 ("kconfig" ,kconfig)
337 ("kcoreaddons" ,kcoreaddons)
338 ("kfilemetadata" ,kfilemetadata)
339 ("ki18n" ,ki18n)
340 ("kiconthemes" ,kiconthemes)
341 ("kio" ,kio)
342 ("kjobwidgets" ,kjobwidgets)
343 ("knewstuff" ,knewstuff)
344 ("knotifications" ,knotifications)
345 ("knotifyconfig" ,knotifyconfig)
346 ("kservice" ,kservice)
347 ("kwidgetsaddons" ,kwidgetsaddons)
348 ("kxmlgui" ,kxmlgui)
349 ("lame" ,lame)
350 ("libburn" ,libburn)
351 ("libcdio-paranoia" ,libcdio-paranoia)
352 ("libdvdcss" ,libdvdcss)
353 ("libdvdread" ,libdvdread)
354 ;; TODO: LibFuzzer
355 ("libiconv" ,libiconv)
356 ("libkcddb" ,libkcddb)
357 ("libmad" ,libmad)
358 ("libmpcdec" ,libmpcdec)
359 ;;("libmusicbrainz" ,libmusicbrainz) ; wants old version 2
360 ("libsamplerate" ,libsamplerate)
361 ("libsndfile" ,libsndfile)
362 ("libvorbis" ,libvorbis)
363 ("oxygen-icons" ,oxygen-icons) ; default icon set
364 ("qtbase" ,qtbase)
365 ("qtwebkit" ,qtwebkit)
366 ("shared-mime-info" ,shared-mime-info)
367 ("solid" ,solid)
368 ("sox" ,sox)
369 ("taglib" ,taglib)
370 ("zlib" ,zlib)))
371 (home-page "https://kde.org/applications/multimedia/org.kde.k3b")
372 (synopsis "Sophisticated CD/DVD burning application")
373 (description "K3b is CD-writing software which intends to be feature-rich
374 and provide an easily usable interface. Features include burning audio CDs
375 from .WAV and .MP3 audio files, configuring external programs and configuring
376 devices.
377
378 The @code{udisks-service} should be enabled for @command{k3b} to discover the
379 available CD drives.")
380 (license ;; GPL for programs, FDL for documentation
381 (list license:gpl2+ license:fdl1.2+))))
382
383 (define-public kaffeine
384 (package
385 (name "kaffeine")
386 (version "2.0.18")
387 (source
388 (origin
389 (method url-fetch)
390 (uri (string-append "mirror://kde/stable/kaffeine"
391 "/kaffeine-" version ".tar.xz"))
392 (sha256
393 (base32 "10dnhr9v2jlki44i3gmjagky66ybixmv6f29z5imk9clgddrlyfr"))))
394 (build-system qt-build-system)
395 (native-inputs
396 `(("extra-cmake-modules" ,extra-cmake-modules)
397 ("pkg-config" ,pkg-config)
398 ("kdoctools" ,kdoctools)))
399 (inputs
400 `(("eudev" ,eudev)
401 ("kcoreaddons" ,kcoreaddons)
402 ("kdbusaddons" ,kdbusaddons)
403 ("ki18n" ,ki18n)
404 ("kio" ,kio)
405 ("kwidgetsaddons" ,kwidgetsaddons)
406 ("kwindowsystem" ,kwindowsystem)
407 ("kxmlgui" ,kxmlgui)
408 ("libxscrnsaver" ,libxscrnsaver)
409 ("oxygen-icons" ,oxygen-icons) ; default icon set
410 ("qtbase" ,qtbase)
411 ("qtx11extras" ,qtx11extras)
412 ("solid" ,solid)
413 ("v4l-utils" ,v4l-utils) ; libdvbv5
414 ("vlc" ,vlc)))
415 (arguments
416 `(#:phases
417 (modify-phases %standard-phases
418 (add-after 'unpack 'fix-code
419 (lambda _
420 (substitute* "src/dvb/dvbdevice_linux.cpp"
421 (("\\s*qPrintable\\(transponder\\.getTransmissionType\\(\\)\\)\\);")
422 "transponder.getTransmissionType());"))
423 #t)))))
424 (home-page "https://kde.org/applications/multimedia/org.kde.kaffeine")
425 (synopsis "Versatile media player for KDE")
426 (description "Kaffeine is a media player for KDE. While it supports
427 multiple Phonon backends, its default backend is Xine, giving Kaffeine a wide
428 variety of supported media types and letting Kaffeine access CDs, DVDs, and
429 network streams easily.
430
431 Kaffeine can keep track of multiple playlists simultaneously, and supports
432 autoloading of subtitle files for use while playing video.")
433 (license ;; GPL for programs, FDL for documentation
434 (list license:gpl2+ license:fdl1.2+))))
435
436 (define-public kamoso
437 (package
438 (name "kamoso")
439 (version "20.04.1")
440 (source
441 (origin
442 (method url-fetch)
443 (uri (string-append "mirror://kde/stable/release-service/" version
444 "/src/kamoso-" version ".tar.xz"))
445 (sha256
446 (base32 "0c47j315kjfikd3b6x18786k3gqymicjjslpm0a58zdxl3wpqfay"))))
447 (build-system qt-build-system)
448 (native-inputs
449 `(("extra-cmake-modules" ,extra-cmake-modules)
450 ("glib:bin" ,glib "bin")
451 ("kdoctools" ,kdoctools)
452 ("pkg-config" ,pkg-config)))
453 (inputs
454 `(("gstreamer" ,gstreamer)
455 ("gst-plugins-base" ,gst-plugins-base)
456 ("kconfig" ,kconfig)
457 ("ki18n" ,ki18n)
458 ("kio" ,kio)
459 ("kirigami" ,kirigami)
460 ("knotifications" ,knotifications)
461 ("kparts" ,kparts)
462 ("oxygen-icons" ,oxygen-icons) ; default icon set
463 ("purpose" ,purpose)
464 ("qtbase" ,qtbase)
465 ("qtdeclarative" ,qtdeclarative)
466 ("qtgraphicaleffects" ,qtgraphicaleffects)
467 ("qtquickcontrols" ,qtquickcontrols)
468 ("qtquickcontrols2" ,qtquickcontrols2) ; not listed as dependency
469 ("qtx11extras" ,qtx11extras)))
470 (arguments
471 `(#:tests? #f ; test program gets built, but is not found
472 #:configure-flags
473 (list (string-append "-DCMAKE_CXX_FLAGS=-I"
474 (assoc-ref %build-inputs "gst-plugins-base")
475 "/include/gstreamer-1.0"))))
476 (home-page "https://kde.org/applications/multimedia/org.kde.kamoso")
477 (synopsis "Take pictures and videos out of your webcam")
478 (description "Kamoso is a simple and friendly program to use your
479 camera. Use it to take pictures and make videos to share.")
480 (license ;; GPL for programs, LGPL for libraries
481 (list license:gpl2+ license:lgpl2.0+))))
482
483 (define-public kmix
484 (package
485 (name "kmix")
486 (version "20.04.1")
487 (source
488 (origin
489 (method url-fetch)
490 (uri (string-append "mirror://kde/stable/release-service/" version
491 "/src/kmix-" version ".tar.xz"))
492 (sha256
493 (base32 "1na52ypp57wqrc6pl1khinx9i6fidv1k97nnxcy8zb4l7d5sh1nd"))))
494 (build-system qt-build-system)
495 (native-inputs
496 `(("extra-cmake-modules" ,extra-cmake-modules)
497 ("pkg-config" ,pkg-config)))
498 (inputs
499 `(("alsa-lib" ,alsa-lib)
500 ("glib" ,glib)
501 ("kconfigwidgets" ,kconfigwidgets)
502 ("kcompletion" ,kcompletion)
503 ("kconfig" ,kconfig)
504 ("kconfigwidgets" ,kconfigwidgets)
505 ("kcrash" ,kcrash)
506 ("kdbusaddons" ,kdbusaddons)
507 ("kdoctools" ,kdoctools)
508 ("kglobalaccel" ,kglobalaccel)
509 ("ki18n" ,ki18n)
510 ("kiconthemes" ,kiconthemes)
511 ("knotifications" ,knotifications)
512 ("kwidgetsaddons" ,kwidgetsaddons)
513 ("kwindowsystem" ,kwindowsystem)
514 ("kxmlgui" ,kxmlgui)
515 ("libcanberra" ,libcanberra)
516 ("oxygen-icons" ,oxygen-icons) ; default icon set
517 ("plasma-framework" ,plasma-framework)
518 ("pulseaudio" ,pulseaudio)
519 ("qtbase" ,qtbase)
520 ("solid" ,solid)))
521 (home-page "https://kde.org/applications/multimedia/org.kde.kmix")
522 (synopsis "Volume control and mixer")
523 (description "KMix is an audio device mixer, used to adjust volume, select
524 recording inputs, and set other hardware options.
525
526 This package is part of the KDE multimedia module.")
527 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
528 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
529
530 (define-public kmplayer
531 (package
532 (name "kmplayer")
533 (version "0.12.0b")
534 (source
535 (origin
536 (method url-fetch)
537 (uri (string-append "mirror://kde/stable/kmplayer/0.12"
538 "/kmplayer-" version ".tar.bz2"))
539 (sha256
540 (base32 "0wzdxym4fc83wvqyhcwid65yv59a2wvp1lq303cn124mpnlwx62y"))
541 (patches (search-patches
542 "kmplayer-aarch64.patch"
543 "kmplayer-upstream_Fix-build-with-Qt-5.9.patch"))))
544 (build-system qt-build-system)
545 (native-inputs
546 `(("extra-cmake-modules" ,extra-cmake-modules)
547 ("pkg-config" ,pkg-config)
548 ("kdoctools" ,kdoctools)))
549 (inputs
550 `(("kconfig" ,kconfig)
551 ("kcoreaddons" ,kcoreaddons)
552 ("kdelibs4support" ,kdelibs4support)
553 ("ki18n" ,ki18n)
554 ("kinit" ,kinit)
555 ("kio" ,kio)
556 ("kparts" ,kparts)
557 ("kmediaplayer" ,kmediaplayer)
558 ("kwidgetsaddons" ,kwidgetsaddons)
559 ("libxcb" ,libxcb) ;; FIXME: why does cmake not find XEVIE and XPRINT?
560 ("oxygen-icons" ,oxygen-icons) ; default icon set
561 ("phonon" ,phonon)
562 ("qtbase" ,qtbase)
563 ("cairo" ,cairo)
564 ("qtsvg" ,qtsvg)
565 ("qtx11extras" ,qtx11extras)
566 ("xcb-util" ,xcb-util)
567 ("xcb-util-cursor" ,xcb-util-cursor)
568 ("xcb-util-errors" ,xcb-util-errors)
569 ("xcb-util-image" ,xcb-util-image)
570 ("xcb-util-keysyms" ,xcb-util-keysyms)
571 ("xcb-util-wm" ,xcb-util-wm)))
572 (arguments
573 `(#:configure-flags
574 (list (string-append
575 "-DCMAKE_CXX_FLAGS=-I"
576 (assoc-ref %build-inputs "qtx11extras") "/include/qt5"))))
577 (home-page "https://kde.org/applications/multimedia/org.kde.kmplayer")
578 (synopsis "Media player using mplayer/phonon as backend")
579 (description "Kmplayer can play all the audio/video supported by
580 mplayer/phonon from a local file or URL and be embedded in Konqueror and
581 KHTML. It also plays DVDs.
582
583 Some features:
584 @itemize
585 @item play DVD/VCD movies (from file or url and from a video device)
586 @item embed inside konqueror (movie is played inside konqueror)
587 @item embed inside khtml (movie playback inside a html page)
588 @item Movie recording using mencoder (part of the mplayer package)
589 @item No video during recording, but you can always open a new window and play it
590 @item Broadcasting, http streaming, using ffserver/ffmpeg
591 @item For TV sources, you need v4lctl (part of the xawtv package)
592 @end itemize")
593 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
594 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
595
596 (define-public kwave
597 (package
598 (name "kwave")
599 (version "20.04.1")
600 (source
601 (origin
602 (method url-fetch)
603 (uri (string-append "mirror://kde/stable/release-service/" version
604 "/src/kwave-" version ".tar.xz"))
605 (sha256
606 (base32 "0ysa873pc2gip95cxr8yv7ifd9qql5zg6h67i9n9q3iqa6v58iyw"))))
607 (build-system qt-build-system)
608 (native-inputs
609 `(("extra-cmake-modules" ,extra-cmake-modules)
610 ("librsvg" ,librsvg)
611 ("pkg-config" ,pkg-config)
612 ("kdoctools" ,kdoctools)))
613 (inputs
614 `(("also-lib" ,alsa-lib)
615 ("audiofile" ,audiofile)
616 ("flac" ,flac)
617 ("id3lib" ,id3lib)
618 ("karchive" ,karchive)
619 ("kcompletion" ,kcompletion)
620 ("kconfig" ,kconfig)
621 ("kconfigwidgets" ,kconfigwidgets)
622 ("kcoreaddons" ,kcoreaddons)
623 ("kcrash" ,kcrash)
624 ("kdbusaddons" ,kdbusaddons)
625 ("ki18n" ,ki18n)
626 ("kiconthemes" ,kiconthemes)
627 ("kio" ,kio)
628 ("kservice" ,kservice)
629 ("ktextwidgets" ,ktextwidgets)
630 ("kwidgetsaddons" ,kwidgetsaddons)
631 ("kxmlgui" ,kxmlgui)
632 ("libmad" ,libmad)
633 ("libsamplerate" ,libsamplerate)
634 ("libvorbis" ,libvorbis)
635 ("opus" ,opus)
636 ("oxygen-icons" ,oxygen-icons) ; default icon set
637 ("pulseaudio" ,pulseaudio)
638 ("qtbase" ,qtbase)
639 ("qtmultimedia" ,qtmultimedia)
640 ("zlib" ,zlib)))
641 (home-page "https://kde.org/applications/multimedia/org.kde.kwave")
642 (synopsis "Sound editor for KDE")
643 (description "Kwave is a sound editor designed for the KDE Desktop
644 Environment.
645
646 With Kwave you can record, play back, import and edit many sorts of audio
647 files including multi-channel files. It includes some plugins to transform
648 audio files in several ways and presents a graphical view with a complete
649 zoom- and scroll capability.
650
651 Its features include:
652 @itemize
653 @item 24 Bit Support
654 @item Undo/Redo
655 @item Use of multicore CPUs (SMP, hyperthreading)
656 @item Simple Drag & Drop
657 @item Realtime Pre-Listen for some effects
658 @item Support for multi-track files
659 @item Playback and recording via native ALSA (or OSS, deprecated)
660 @item Playback via PulseAudio and Phonon
661 @item Load and edit-capability for large files (can use virtual memory)
662 @item Reading and auto-repair of damaged wav-files
663 @item Supports multiple windows
664 @item Extendable Plugin interface
665 @item a nice splashscreen
666 @item some label handling
667 @end itemize")
668 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
669 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+
670 license:cc-by-sa3.0 license:cc-by-sa4.0 ;; icons, samples
671 license:cc0 license:bsd-3)))) ;; utilities files
672
673 (define-public libkcddb
674 (package
675 (name "libkcddb")
676 (version "20.04.1")
677 (source
678 (origin
679 (method url-fetch)
680 (uri (string-append "mirror://kde/stable/release-service/" version
681 "/src/libkcddb-" version ".tar.xz"))
682 (sha256
683 (base32 "1fwryaj8ldmsqhl5qxjda8by9i7xlb97r8p9rqzckw697hkfhs0h"))))
684 (build-system qt-build-system)
685 (native-inputs
686 `(("extra-cmake-modules" ,extra-cmake-modules)
687 ("kdoctools" ,kdoctools)))
688 (inputs
689 `(("kcodecs" ,kcodecs)
690 ("kconfig" ,kconfig)
691 ("ki18n" ,ki18n)
692 ("kio" ,kio)
693 ("kwidgetsaddons" ,kwidgetsaddons)
694 ("libmusicbrainz" ,libmusicbrainz)
695 ("qtbase" ,qtbase)))
696 (arguments
697 `(#:tests? #f)) ; Most tests require network
698 (home-page "https://cgit.kde.org/libkcddb.git")
699 (synopsis "CDDB library for KDE Platform (runtime)")
700 (description "A library for retrieving and sending cddb information.")
701 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
702 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
703
704 (define-public libkcompactdisc
705 (package
706 (name "libkcompactdisc")
707 (version "20.04.1")
708 (source
709 (origin
710 (method url-fetch)
711 (uri (string-append "mirror://kde/stable/release-service/" version
712 "/src/libkcompactdisc-" version ".tar.xz"))
713 (sha256
714 (base32 "0iy4i0hxqsrnndd4iqkww7v1rqry7kvi5paxdw5qjfffwn8kcsbx"))))
715 (build-system qt-build-system)
716 (native-inputs
717 `(("extra-cmake-modules" ,extra-cmake-modules)))
718 (inputs
719 `(("alsa-lib" ,alsa-lib)
720 ("kcoreaddons" ,kcoreaddons)
721 ("ki18n" ,ki18n)
722 ("phonon" ,phonon)
723 ("qtbase" ,qtbase)
724 ("solid" ,solid)))
725 (home-page "https://cgit.kde.org/libkcompactdisc.git/")
726 (synopsis "KDE library for playing & ripping CDs")
727 (description "The KDE Compact Disc library provides an API for
728 applications using the KDE Platform to interface with the CD drives for audio
729 CDs.")
730 (license ;; GPL for programs, LGPL for libraries
731 (list license:gpl2+ license:lgpl2.0+))))