gnu: mescc-tools: Update to 0.5.2-0.bb062b0d.
[jackhill/guix/guix.git] / gnu / packages / mes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017,2018 Jan Nieuwenhuizen <janneke@gnu.org>
3 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages mes)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages cross-base)
25 #:use-module (gnu packages gcc)
26 #:use-module (gnu packages graphviz)
27 #:use-module (gnu packages guile)
28 #:use-module (gnu packages man)
29 #:use-module (gnu packages package-management)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages texinfo)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module (guix licenses)
36 #:use-module (guix packages))
37
38 (define-public nyacc
39 (package
40 (name "nyacc")
41 (version "0.86.0")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "mirror://savannah/nyacc/"
45 name "-" version ".tar.gz"))
46 (patches (search-patches "nyacc-binary-literals.patch"))
47 (sha256
48 (base32
49 "0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
50 (build-system gnu-build-system)
51 (native-inputs
52 `(("guile" ,guile-2.2)))
53 (synopsis "LALR(1) Parser Generator in Guile")
54 (description
55 "NYACC is an LALR(1) parser generator implemented in Guile.
56 The syntax and nomenclature should be considered not stable. It comes with
57 extensive examples, including parsers for the Javascript and C99 languages.")
58 (home-page "https://savannah.nongnu.org/projects/nyacc")
59 (license (list gpl3+ lgpl3+))))
60
61 (define-public mes
62 (let ((triplet "i686-unknown-linux-gnu")
63 (version "0.18")
64 (revision "0")
65 (commit "08f04f559670d9e8f57eb03bb9b13f4d0b81cedf"))
66 (package
67 (name "mes")
68 (version (string-append version "-" revision "." (string-take commit 7)))
69 (source (origin
70 (method url-fetch)
71 (uri (string-append
72 "https://git.savannah.gnu.org/cgit/mes.git/snapshot/"
73 name "-" commit
74 ".tar.gz"))
75 (sha256
76 (base32
77 "1b7wz9k38pfrz707pd4p8s54q903jr167q73ya7qkna89sxj3wna"))))
78 (build-system gnu-build-system)
79 (supported-systems '("i686-linux" "x86_64-linux"))
80 (propagated-inputs
81 `(("mescc-tools" ,mescc-tools)
82 ("nyacc" ,nyacc)))
83 (native-inputs
84 `(("guile" ,guile-2.2)
85 ,@(if (not (string-prefix? "i686-linux" (or (%current-target-system)
86 (%current-system))))
87 ;; Use cross-compiler rather than #:system "i686-linux" to get
88 ;; MesCC 64 bit .go files installed ready for use with Guile.
89 `(("i686-linux-binutils" ,(cross-binutils triplet))
90 ("i686-linux-gcc" ,(cross-gcc triplet)))
91 '())
92 ("graphviz" ,graphviz)
93 ("help2man" ,help2man)
94 ("perl" ,perl) ; build-aux/gitlog-to-changelog
95 ("texinfo" ,texinfo)))
96 (arguments
97 `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
98 (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
99 (description
100 "GNU Mes--Maxwell Equations of Software--brings the Reduced
101 Binary Seed bootstrap to GuixSD and aims to help create full source
102 bootstrapping for GNU/Linux distributions. It consists of a mutual
103 self-hosting Scheme interpreter in C and a Nyacc-based C compiler in
104 Scheme and is compatible with Guile.")
105 (home-page "https://gnu.org/software/mes")
106 (license gpl3+))))
107
108 (define-public mescc-tools
109 (let ((commit "bb062b0da7bf2724ca40f9002b121579898d4ef7")
110 (revision "0")
111 (version "0.5.2"))
112 (package
113 (name "mescc-tools")
114 (version (string-append version "-" revision "." (string-take commit 7)))
115 (source (origin
116 (method url-fetch)
117 (uri (string-append
118 "https://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
119 name "-" commit
120 ".tar.gz"))
121 (sha256
122 (base32
123 "1h6j57wyf91i42b26f8msbv6451cw3nm4nmpl1fckp9c7vi8mwkh"))))
124 (build-system gnu-build-system)
125 (supported-systems '("i686-linux" "x86_64-linux"))
126 (arguments
127 `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
128 #:test-target "test"
129 #:phases (modify-phases %standard-phases
130 (delete 'configure))))
131 (synopsis "Tools for the full source bootstrapping process")
132 (description
133 "Mescc-tools is a collection of tools for use in a full source
134 bootstrapping process. It consists of the M1 macro assembler, the hex2
135 linker, the blood-elf symbol table generator, the kaem shell, exec_enable and
136 get_machine.")
137 (home-page "https://savannah.nongnu.org/projects/mescc-tools")
138 (license gpl3+))))