gnu: libkomparediff2: Update to 19.08.3.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 David Craven <david@craven.ch>
4 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
5 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
6 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
9 ;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
10 ;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages kde)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system qt)
30 #:use-module (guix deprecation)
31 #:use-module (guix download)
32 #:use-module (guix git-download)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix packages)
35 #:use-module (guix utils)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages algebra)
38 #:use-module (gnu packages apr)
39 #:use-module (gnu packages audio)
40 #:use-module (gnu packages boost)
41 #:use-module (gnu packages code)
42 #:use-module (gnu packages compression)
43 #:use-module (gnu packages curl)
44 #:use-module (gnu packages documentation)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages ghostscript)
47 #:use-module (gnu packages gl)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages graphics)
50 #:use-module (gnu packages image)
51 #:use-module (gnu packages kde-frameworks)
52 #:use-module (gnu packages kde-plasma)
53 #:use-module (gnu packages linux)
54 #:use-module (gnu packages llvm)
55 #:use-module (gnu packages maths)
56 #:use-module (gnu packages pdf)
57 #:use-module (gnu packages perl)
58 #:use-module (gnu packages photo)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages pulseaudio)
61 #:use-module (gnu packages python)
62 #:use-module (gnu packages tls)
63 #:use-module (gnu packages qt)
64 #:use-module (gnu packages version-control)
65 #:use-module (gnu packages video)
66 #:use-module (gnu packages xdisorg)
67 #:use-module (gnu packages xml)
68 #:use-module (gnu packages xorg))
69
70 (define-public baloo-widgets
71 (package
72 (name "baloo-widgets")
73 (version "19.08.3")
74 (source
75 (origin
76 (method url-fetch)
77 (uri (string-append "mirror://kde/stable/applications/" version
78 "/src/baloo-widgets-" version ".tar.xz"))
79 (sha256
80 (base32 "0bba8dgxd7rcjji809kwnw78hl1nb5ssh2ir4k4b0wvx395jifgd"))))
81 (build-system qt-build-system)
82 (native-inputs
83 `(("extra-cmake-modules" ,extra-cmake-modules)))
84 (inputs
85 `(("baloo" ,baloo)
86 ("kconfig" ,kconfig)
87 ("ki18n" ,ki18n)
88 ("kio" ,kio)
89 ("qtbase" ,qtbase)))
90 (arguments
91 `(#:phases
92 (modify-phases %standard-phases
93 (add-before 'check 'check-setup
94 (lambda _
95 (setenv "QT_QPA_PLATFORM" "offscreen")
96 #t)))))
97 (home-page "https://community.kde.org/Baloo")
98 (synopsis "Wigets for use with Baloo")
99 (description "Baloo is a framework for searching and managing metadata.
100 This package contains GUI widgets for baloo.")
101 (license license:lgpl2.0+)))
102
103 (define-public grantleetheme
104 (package
105 (name "grantleetheme")
106 (version "19.08.3")
107 (source
108 (origin
109 (method url-fetch)
110 (uri (string-append "mirror://kde/stable/applications/" version
111 "/src/grantleetheme-" version ".tar.xz"))
112 (sha256
113 (base32 "0j77q1yyfmggzgkqgcw2xr0v9xg3h5cdhh8jry8h2llw75ahy6xb"))
114 (patches (search-patches "grantlee-merge-theme-dirs.patch"))))
115 (build-system qt-build-system)
116 (native-inputs
117 `(("extra-cmake-modules" ,extra-cmake-modules)
118 ("libxml2" ,libxml2))) ;; xmllint required for tests
119 (inputs
120 `(("grantlee" ,grantlee)
121 ("ki18n" ,ki18n)
122 ("kiconthemes" ,kiconthemes)
123 ("knewstuff" ,knewstuff)
124 ("qtbase" ,qtbase)))
125 (home-page "https://cgit.kde.org/grantleetheme.git")
126 (synopsis "Library providing Grantlee theme support")
127 (description "This library provides Grantlee theme support.")
128 (license ;; LGPL for libraries, FDL for documentation
129 (list license:lgpl2.0+ license:fdl1.2+))))
130
131 (define-public kdenlive
132 (let ((version "18.08.1"))
133 (package
134 (name "kdenlive")
135 (version version)
136 (source
137 (origin
138 (method git-fetch)
139 (uri (git-reference
140 (url "git://anongit.kde.org/kdenlive.git")
141 (commit (string-append "v" version))))
142 (file-name (string-append name "-" version "-checkout"))
143 (sha256
144 (base32
145 "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
146 (build-system cmake-build-system)
147 (native-inputs
148 `(("extra-cmake-modules" ,extra-cmake-modules)
149 ("qttools" ,qttools)))
150 (propagated-inputs
151 `(("mlt" ,mlt)))
152 (inputs
153 `(("shared-mime-info" ,shared-mime-info)
154 ("frei0r-plugins" ,frei0r-plugins)
155 ("qtbase" ,qtbase)
156 ("qtscript" ,qtscript)
157 ("qtsvg" ,qtsvg)
158 ("kparts" ,kparts)
159 ("knotifications" ,knotifications)
160 ("karchive" ,karchive)
161 ("kdbusaddons" ,kdbusaddons)
162 ("kcrash" ,kcrash)
163 ("kguiaddons" ,kguiaddons)
164 ("knewstuff" ,knewstuff)
165 ("knotifyconfig" ,knotifyconfig)
166 ("kfilemetadata" ,kfilemetadata)
167 ("kdoctools" ,kdoctools)
168 ("kdeclarative" ,kdeclarative)
169 ("qtdeclarative" ,qtdeclarative)
170 ("qtquickcontrols" ,qtquickcontrols)
171 ("kiconthemes" ,kiconthemes)
172 ("qtgraphicaleffects" ,qtgraphicaleffects)
173 ("kplotting" ,kplotting)))
174 (arguments
175 `(#:phases
176 (modify-phases %standard-phases
177 (add-after 'install 'wrap-executable
178 (lambda* (#:key inputs outputs #:allow-other-keys)
179 (let* ((out (assoc-ref outputs "out"))
180 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
181 (qtbase (assoc-ref inputs "qtbase"))
182 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
183 (frei0r (assoc-ref inputs "frei0r-plugins"))
184 (qml "/lib/qt5/qml"))
185 (wrap-program (string-append out "/bin/kdenlive")
186 `("QT_PLUGIN_PATH" ":" prefix
187 ,(map (lambda (label)
188 (string-append (assoc-ref inputs label)
189 "/lib/qt5/plugins/"))
190 '("qtbase" "qtsvg")))
191 `("FREI0R_PATH" ":" =
192 (,(string-append frei0r "/lib/frei0r-1/")))
193 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
194 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
195 `("QML2_IMPORT_PATH" ":" prefix
196 (,(string-append qtquickcontrols qml)
197 ,(string-append qtdeclarative qml)))))
198 #t)))))
199 (home-page "https://kdenlive.org")
200 (synopsis "Non-linear video editor")
201 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
202
203 Non-linear video editing is much more powerful than beginner's (linear)
204 editors, hence it requires a bit more organization before starting. However,
205 it is not reserved to specialists and can be used for small personal
206 projects.")
207 (license license:gpl2+))))
208
209 (define-public kdevelop
210 (package
211 (name "kdevelop")
212 (version "5.5.1")
213 (source
214 (origin
215 (method url-fetch)
216 (uri (string-append "mirror://kde/stable/kdevelop"
217 "/" version "/src/kdevelop-"
218 version ".tar.xz"))
219 (sha256
220 (base32 "18hxwkdbfw0qs3p19jv6d8wwwdzb9m087891i8w2bzkn21fd5pmy"))))
221 (build-system qt-build-system)
222 (native-inputs
223 `(("extra-cmake-modules" ,extra-cmake-modules)
224 ("pkg-config" ,pkg-config)
225 ("shared-mime-info" ,shared-mime-info)
226 ("qttools" ,qttools)))
227 (inputs
228 `(("boost" ,boost)
229 ("clang" ,clang)
230 ("grantlee" ,grantlee)
231 ("karchive" ,karchive)
232 ("kcmutils" ,kcmutils)
233 ("kcrash" ,kcrash)
234 ("kdeclarative" ,kdeclarative)
235 ("kdoctools" ,kdoctools)
236 ("kguiaddons" ,kguiaddons)
237 ("ki18n" ,ki18n)
238 ("kiconthemes" ,kiconthemes)
239 ("kio" ,kio) ;; not checked as requirement
240 ("kitemmodels" ,kitemmodels)
241 ("kitemviews" ,kitemviews)
242 ("kjobwidgets" ,kjobwidgets)
243 ("knotifications" ,knotifications)
244 ("knotifyconfig" ,knotifyconfig)
245 ("kparts" ,kparts)
246 ("kservice" ,kservice)
247 ("ktexteditor" ,ktexteditor)
248 ("kwindowsystem" ,kwindowsystem)
249 ("kxmlgui" ,kxmlgui)
250 ("libkomparediff2" ,libkomparediff2)
251 ("oxygen-icons" ,oxygen-icons)
252 ("qtbase" ,qtbase)
253 ("qtdeclarative" ,qtdeclarative)
254 ("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
255 ("qtquickcontrols2" ,qtquickcontrols2) ;; not checked as requirement
256 ("qtwebkit" ,qtwebkit)
257 ("threadweaver" ,threadweaver)
258
259 ;; recommendes
260 ("astyle" ,astyle)
261 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
262 ("libksysguard" ,libksysguard)
263
264 ;; optional
265 ("apr" ,apr) ; required for subversion support
266 ("apr-util" ,apr-util) ; required for subversion support
267 ("attica" ,attica)
268 ("kconfigwidgets" ,kconfigwidgets)
269 ("knewstuff" ,knewstuff)
270 ("krunner" ,krunner)
271 ;; TODO: OktetaGui, OktetaKastenControllers
272 ("plasma" ,plasma-framework)
273 ;; TODO: purpose
274 ("sonnet" ,sonnet)
275 ("subversion" ,subversion)))
276
277 ;; run-time packages - TODO
278 ;; ClazyStandalone
279 ;; Cppcheck
280 ;; heaptrack
281 ;; heaptrack_gui
282 ;; meson
283 (arguments
284 `(#:tests? #f ;; there are some issues with the test suite
285 #:phases
286 (modify-phases %standard-phases
287 (add-before 'configure 'add-include-path
288 (lambda* (#:key inputs #:allow-other-keys)
289 (substitute* "cmake/modules/FindClang.cmake"
290 (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
291 (string-append line " " (assoc-ref inputs "clang") "/lib")))
292 #t)))))
293 (home-page "https://kdevelop.org")
294 (synopsis "IDE for C, C++, Python, Javascript and PHP")
295 (description "The KDevelop IDE provides semantic syntax highlighting, as
296 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
297 JavaScript, Python and PHP. It also integrates with a debugger, different
298 build systems (CMake, QMake, custom Makefiles) and version control
299 software (Git, Subversion, Mercurial, CVS and Bazaar).")
300 (license license:lgpl2.1+)))
301
302 (define-public kdevelop-pg-qt
303 (package
304 (name "kdevelop-pg-qt")
305 (version "2.2.1")
306 (source
307 (origin
308 (method git-fetch)
309 (uri (git-reference
310 (url "https://github.com/KDE/kdevelop-pg-qt")
311 (commit (string-append "v" version))))
312 (file-name (git-file-name name version))
313 (sha256
314 (base32 "1kfab4p717acbdkcdi41d98vwch7v431gb2qi6s38hmclsf8bf8g"))))
315 (native-inputs
316 `(("extra-cmake-modules" ,extra-cmake-modules)))
317 (inputs
318 `(("qtbase" ,qtbase)))
319 (build-system cmake-build-system)
320 (home-page "https://kde.org")
321 (synopsis "Parser generator library for KDevplatform")
322 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
323 for some KDevelop language plugins (Ruby, PHP, CSS...).")
324 (license license:lgpl2.0+)))
325
326 ;; kdevplatform was merged into kdevelop as of 5.2.x
327 (define-deprecated kdevplatform kdevelop)
328
329 (define-public kdiagram
330 (package
331 (name "kdiagram")
332 (version "2.7.0")
333 (source
334 (origin
335 (method url-fetch)
336 (uri (string-append "mirror://kde/stable/kdiagram/" version
337 "/kdiagram-" version ".tar.xz"))
338 (sha256
339 (base32 "1pgvf2q8b59hw0jg5ajmj5nrn4q8cgnifpvdd0fynk2ml6zym8k3"))
340 (patches (search-patches
341 "kdiagram-Fix-missing-link-libraries.patch"))))
342 (build-system qt-build-system)
343 (native-inputs
344 `(("extra-cmake-modules" ,extra-cmake-modules)
345 ("qttools" ,qttools)))
346 (inputs
347 `(("qtbase" ,qtbase)
348 ("qtsvg" ,qtsvg)))
349 (home-page "https://cgit.kde.org/kdiagram.git/")
350 (synopsis "Libraries for creating business diagrams")
351 (description "This package provides libraries for integrating business
352 diagrams in Qt-based applications.
353
354 @code{KCharts} provides an implementation of the ODF Chart specification. It
355 supports stock charts, box charts, and whisker charts. @code{KGantt} provides
356 a module for implementing ODF Gantt charts, which are bar charts that
357 illustrate project schedules.")
358 (license license:gpl2+)))
359
360 (define-public krita
361 (package
362 (name "krita")
363 (version "4.2.9")
364 (source (origin
365 (method url-fetch)
366 (uri (string-append
367 "mirror://kde/stable/krita/" version
368 "/krita-" version ".tar.gz"))
369 (sha256
370 (base32
371 "1a3djmjhnvlp8dpiz68s0lwg71nv3ypq592jfgsnm5zlxa0vp1cz"))))
372 (build-system cmake-build-system)
373 (arguments
374 `(#:tests? #f
375 #:configure-flags
376 (list "-DBUILD_TESTING=OFF"
377 (string-append "-DCMAKE_CXX_FLAGS=-I"
378 (assoc-ref %build-inputs "openexr")
379 "/include/OpenEXR"))
380 #:phases
381 (modify-phases %standard-phases
382 ;; Ensure that icons are found at runtime.
383 ;; This works around <https://bugs.gnu.org/22138>.
384 (add-after 'install 'wrap-executable
385 (lambda* (#:key inputs outputs #:allow-other-keys)
386 (let ((out (assoc-ref outputs "out"))
387 (qt '("qtbase" "qtsvg")))
388 (wrap-program (string-append out "/bin/krita")
389 `("QT_PLUGIN_PATH" ":" prefix
390 ,(map (lambda (label)
391 (string-append (assoc-ref inputs label)
392 "/lib/qt5/plugins/"))
393 qt)))
394 #t))))))
395 (native-inputs
396 `(("curl" ,curl)
397 ("eigen" ,eigen)
398 ("extra-cmake-modules" ,extra-cmake-modules)
399 ("gettext-minimal" ,gettext-minimal)
400 ("kitemmodels" ,kitemmodels)
401 ("pkg-config" ,pkg-config)
402 ("qwt" ,qwt)
403 ("vc" ,vc)))
404 (inputs
405 `(("boost" ,boost)
406 ("exiv2" ,exiv2)
407 ("fftw" ,fftw)
408 ("gsl" ,gsl)
409 ("ilmbase" ,ilmbase)
410 ("karchive" ,karchive)
411 ("kcompletion" ,kcompletion)
412 ("kconfig" ,kconfig)
413 ("kcoreaddons" ,kcoreaddons)
414 ("kcrash" ,kcrash)
415 ("kguiaddons" ,kguiaddons)
416 ("ki18n" ,ki18n)
417 ("kiconthemes" ,kiconthemes)
418 ("kio" ,kio)
419 ("kitemviews" ,kitemviews)
420 ("kwidgetsaddons" ,kwidgetsaddons)
421 ("kwindowsystem" ,kwindowsystem)
422 ("kxmlgui" ,kxmlgui)
423 ("lcms" ,lcms)
424 ("libjpeg-turbo" ,libjpeg-turbo)
425 ("libpng" ,libpng)
426 ("libraw" ,libraw-0.18)
427 ("libtiff" ,libtiff)
428 ("libx11" ,libx11)
429 ("libxcb" ,libxcb)
430 ("libxi" ,libxi)
431 ("openexr" ,openexr)
432 ("perl" ,perl)
433 ("poppler-qt5" ,poppler-qt5)
434 ("qtbase" ,qtbase)
435 ("qtdeclarative" ,qtdeclarative)
436 ("qtmultimedia" ,qtmultimedia)
437 ("qtsvg" ,qtsvg)
438 ("qtx11extras" ,qtx11extras)
439 ("quazip" ,quazip)
440 ("zlib" ,zlib)))
441 (home-page "https://krita.org")
442 (synopsis "Digital painting application")
443 (description
444 "Krita is a professional painting tool designed for concept artists,
445 illustrators, matte and texture artists, and the VFX industry. Notable
446 features include brush stabilizers, brush engines and wrap-around mode.")
447 (license license:gpl2+)))
448
449 (define-public libkomparediff2
450 (package
451 (name "libkomparediff2")
452 (version "19.08.3")
453 (source
454 (origin
455 (method url-fetch)
456 (uri (string-append "mirror://kde/stable/applications/" version
457 "/src/libkomparediff2-" version ".tar.xz"))
458 (sha256
459 (base32 "0p8j24d0lzylv5crdzak87016ppgph5hiyxkvapda1m8zlb5dfm1"))))
460 (native-inputs
461 `(("extra-cmake-modules" ,extra-cmake-modules)
462 ("pkg-config" ,pkg-config)))
463 (inputs
464 `(("kcodecs" ,kcodecs)
465 ("kconfig" ,kconfig)
466 ("kcoreaddons" ,kcoreaddons)
467 ("ki18n" ,ki18n)
468 ("kio" ,kio)
469 ("kxmlgui" ,kxmlgui)
470 ("qtbase" ,qtbase)))
471 (build-system cmake-build-system)
472 (home-page "https://kde.org")
473 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
474 (description "Libkomparediff2 is a library to work with diffs and patches,
475 used in KDE development tools Kompare and KDevelop.")
476
477 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
478 ;; source archive
479 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
480
481 (define-public qca
482 (package
483 (name "qca")
484 (version "2.2.1")
485 (source
486 (origin
487 (method url-fetch)
488 (uri (string-append "mirror://kde/stable/qca/" version
489 "/qca-" version ".tar.xz"))
490 (sha256
491 (base32
492 "00kv1vsrc8fp556hm8s6yw3240vx3l4067q6vfxrb3gdwgcd45np"))))
493 (build-system cmake-build-system)
494 (native-inputs
495 `(("pkg-config" ,pkg-config)))
496 (inputs
497 `(("openssl" ,openssl)
498 ("qtbase" ,qtbase)))
499 (home-page "https://userbase.kde.org/QCA")
500 (synopsis "Libraries for the Qt Cryptographic Architecture")
501 (description "The Qt Cryptographic Architecture (QCA) provides a
502 straightforward and cross-platform API for a range of cryptographic features,
503 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
504 cards.")
505 (license license:lgpl2.1)))
506
507 (define-public kpmcore
508 (package
509 (name "kpmcore")
510 (version "4.0.1")
511 (source (origin
512 (method url-fetch)
513 (uri (string-append
514 "mirror://kde/stable/kpmcore"
515 "/" version "/src/"
516 name "-" version ".tar.xz"))
517 (sha256
518 (base32
519 "1sslkwcj2cyrn7bpjdjdwikp1q8wrsxpsg2sxxd8hsairgy7ygh3"))
520 (patches (search-patches "kpmcore-fix-tests.patch"
521 "kpmcore-remove-broken-test.patch"))))
522 (build-system cmake-build-system)
523 (native-inputs
524 `(("extra-cmake-modules" ,extra-cmake-modules)
525 ("pkg-config" ,pkg-config)))
526 (inputs
527 `(("kauth" ,kauth)
528 ("kcoreaddons" ,kcoreaddons)
529 ("ki18n" ,ki18n)
530 ("kwidgetsaddons" ,kwidgetsaddons)
531 ("qtbase" ,qtbase)
532 ("qca" ,qca)
533 ("util-linux" ,util-linux "lib")))
534 (home-page "https://community.kde.org/Frameworks")
535 (synopsis "Library for managing partitions")
536 (description "Library for managing partitions.")
537 (license license:gpl3+)))
538
539 (define-public snorenotify
540 (package
541 (name "snorenotify")
542 (version "0.7.0")
543 (source
544 (origin
545 (method url-fetch)
546 (uri (string-append "mirror://kde/stable/snorenotify/"
547 version "/src/snorenotify-" version ".tar.xz"))
548 (sha256
549 (base32
550 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
551 (build-system cmake-build-system)
552 (arguments
553 `(#:tests? #f)) ; both tests fail, require display
554 (inputs
555 `(("qtbase" ,qtbase)))
556 (native-inputs
557 `(("extra-cmake-modules" ,extra-cmake-modules)
558 ("qttools" ,qttools)))
559 (home-page "https://techbase.kde.org/Projects/Snorenotify")
560 (synopsis "Qt notification framework")
561 (description "Snorenotify is a multi platform Qt notification framework.
562 Using a plugin system it is possible to create notifications with many
563 different notification systems.")
564 (license license:lgpl3)))
565
566 (define-public kdeconnect
567 (package
568 (name "kdeconnect")
569 (version "1.3.5")
570 (source
571 (origin
572 (method url-fetch)
573 (uri (string-append "mirror://kde/stable/kdeconnect/"
574 version "/kdeconnect-kde-"
575 version ".tar.xz"))
576 (sha256
577 (base32
578 "02lr3xx5s2mgddac4n3lkgr7ppf1z5m6ajs90rjix0vs8a271kp5"))))
579 (build-system qt-build-system)
580 (arguments
581 `(#:configure-flags '("-DBUILD_TESTING=ON"
582 "-DLIBEXEC_INSTALL_DIR=libexec")
583 #:tests? #f)) ; tests fail hard in our build environment
584 (native-inputs
585 `(("extra-cmake-modules" ,extra-cmake-modules)
586 ("kdoctools" ,kdoctools)
587 ("libxtst" ,libxtst)
588 ("pkg-config" ,pkg-config)
589 ("python" ,python-wrapper)))
590 (inputs
591 `(("kcmutils" ,kcmutils)
592 ("kconfigwidgets" ,kconfigwidgets)
593 ("kdbusaddons" ,kdbusaddons)
594 ("ki18n" ,ki18n)
595 ("kiconthemes" ,kiconthemes)
596 ("kio" ,kio)
597 ("knotifications" ,knotifications)
598 ("kwayland" ,kwayland)
599 ("libfakekey" ,libfakekey)
600 ("qca" ,qca)
601 ("qtbase" ,qtbase)
602 ("qtdeclarative" ,qtdeclarative)
603 ("qtx11extras" ,qtx11extras)))
604 (home-page "https://community.kde.org/KDEConnect")
605 (synopsis "Enable your devices to communicate with each other")
606 (description "KDE Connect is a project that enables all your devices to
607 communicate with each other. Here's a few things KDE Connect can do:
608 @enumerate
609 @item Receive your phone notifications on your desktop computer and reply to messages
610 @item Control music playing on your desktop from your phone
611 @item Use your phone as a remote control for your desktop
612 @item Run predefined commands on your PC from connected devices
613 @item Check your phones battery level from the desktop
614 @item Ring your phone to help finding it
615 @item Share files and links between devices
616 @item Browse your phone from the desktop
617 @item Control the desktop's volume from the phone
618 @end enumerate")
619 (properties `((upstream-name . "kdeconnect-kde")))
620 (license (list license:gpl2 license:gpl3)))) ; dual licensed
621
622 (define-public kqtquickcharts
623 (package
624 (name "kqtquickcharts")
625 (version "19.08.2")
626 (source
627 (origin
628 (method url-fetch)
629 (uri (string-append "mirror://kde/stable/applications/"
630 version "/src/kqtquickcharts-" version ".tar.xz"))
631 (sha256
632 (base32
633 "1yy9fyd8y4g25ljdsbil19qdf4j3mzmzl489sx7rqpm3lfdzjh9k"))))
634 (build-system cmake-build-system)
635 (native-inputs
636 `(("extra-cmake-modules" ,extra-cmake-modules)))
637 (inputs
638 `(("qtbase" ,qtbase)
639 ("qtdeclarative" ,qtdeclarative)))
640 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
641 (synopsis "Interactive charts for Qt Quick")
642 (description
643 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
644 charts.")
645 (license license:lgpl2.1+)))
646
647 (define-public kcachegrind
648 (package
649 (name "kcachegrind")
650 (version "19.04.1")
651 (source (origin
652 (method url-fetch)
653 (uri (string-append "mirror://kde/stable/applications/" version
654 "/src/kcachegrind-" version ".tar.xz"))
655 (sha256
656 (base32
657 "1hhsk64yp6q2xh8j269j4wp9y24ggmii861r6gf02mj1mbn2p1jb"))))
658 (build-system cmake-build-system)
659 (native-inputs
660 `(("extra-cmake-modules" ,extra-cmake-modules)
661 ("perl" ,perl)
662 ("python" ,python)
663 ("qttools" ,qttools)
664 ("kdoctools" ,kdoctools)))
665 (inputs
666 `(("qtbase" ,qtbase)
667 ("karchive" ,karchive)
668 ("ki18n" ,ki18n)
669 ("kio" ,kio)
670 ("kdbusaddons" ,kdbusaddons)))
671 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
672 ;; Python and PHP, respectively. These are optional and we ignore them
673 ;; for now.
674 (home-page "https://kcachegrind.github.io/html/Home.html")
675 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
676 (description
677 "The data files generated by the Callgrind of Valgrind, an application
678 profiler, can be loaded into KCachegrind for browsing the performance results.
679 There is also a command-line tool to get ASCII reports from data files without
680 the need to use KCachegrind.
681
682 The format of Callgrind output is documented. With conversion scripts,
683 KCachegrind is able to visualize output of other profilers like OProfile, a
684 system-wide profiler for Linux using statistical sampling with hardware
685 performance counters. There also exist converters for profiling output of
686 Python, PHP, and Perl.")
687 (license license:gpl2)))
688
689 (define-public libkdegames
690 (package
691 (name "libkdegames")
692 (version "19.08.3")
693 (source
694 (origin
695 (method url-fetch)
696 (uri (string-append "mirror://kde/stable/applications/" version
697 "/src/libkdegames-" version ".tar.xz"))
698 (sha256
699 (base32 "12dvkmjgbi8dp9y55zmx1pw3zr2i374c4vn3mfn9r31bf06dr701"))))
700 (build-system qt-build-system)
701 (native-inputs
702 `(("extra-cmake-modules" ,extra-cmake-modules)))
703 (inputs
704 `(("karchive" ,karchive)
705 ("kbookmarks" ,kbookmarks)
706 ("kcodecs" ,kcodecs)
707 ("kcompletion" ,kcompletion)
708 ("kconfigwidgets" ,kconfigwidgets)
709 ("kcrash" ,kcrash)
710 ("kdbusaddons" ,kdbusaddons)
711 ("kdeclarative" ,kdeclarative)
712 ("kdnssd" ,kdnssd)
713 ("kglobalaccel" ,kglobalaccel)
714 ("kguiaddons" ,kguiaddons)
715 ("ki18n" ,ki18n)
716 ("kiconthemes" ,kiconthemes)
717 ;("kio" ,kio)
718 ("kitemviews" ,kitemviews)
719 ("kjobwidgets" ,kjobwidgets)
720 ("knewstuff" ,knewstuff)
721 ("kservice" ,kservice)
722 ("ktextwidgets" ,ktextwidgets)
723 ("kwidgetsaddons" ,kwidgetsaddons)
724 ("kxmlgui" ,kxmlgui)
725 ("libsndfile" ,libsndfile)
726 ("openal" ,openal)
727 ("qtbase" ,qtbase)
728 ("qtdeclarative" ,qtdeclarative)
729 ("qtsvg" ,qtsvg)))
730 (home-page "https://games.kde.org/")
731 (synopsis "Runtime library for kdegames")
732 (description "Runtime library for kdegames")
733 (license (list license:gpl2+ license:fdl1.2+))))
734
735 (define-public zeroconf-ioslave
736 (package
737 (name "zeroconf-ioslave")
738 (version "19.08.3")
739 (source
740 (origin
741 (method url-fetch)
742 (uri (string-append "mirror://kde/stable/applications/" version
743 "/src/zeroconf-ioslave-" version ".tar.xz"))
744 (sha256
745 (base32 "1vbi4kpyrk530q2dj8ql2i0gxjybdbmkqpl8vkhrihl7r7f0xc5p"))))
746 (build-system qt-build-system)
747 (native-inputs
748 `(("extra-cmake-modules" ,extra-cmake-modules)))
749 (inputs
750 `(("kdbusaddons" ,kdbusaddons)
751 ("kdnssd" ,kdnssd)
752 ("ki18n" ,ki18n)
753 ("kio" ,kio)
754 ("qtbase" ,qtbase)))
755 (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
756 (synopsis "DNS-SD Service Discovery Monitor")
757 (description "Adds an entry to Dolphin's Network page to show local
758 services such as printers which advertise themselves with DNSSD (called Avahi
759 or Bonjour by other projects).")
760 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
761 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))