gnu: emacs-undohist-el: Update to 0.2.1.
[jackhill/guix/guix.git] / gnu / packages / patches / clamav-config-llvm-libs.patch
1 Our llvm does not contain a single top-level library, so consult llvm-config
2 for the libraries that need to be linked against.
3
4 --- clamav-0.100.2/libclamav/c++/configure.ac 2018-09-19 14:29:07.000000000 -0500
5 +++ clamav-0.100.2/libclamav/c++/configure.ac 2018-10-06 21:45:09.377249158 -0500
6 @@ -105,7 +105,7 @@
7
8 if test "x$llvm_linking" = "xdynamic"; then
9 AC_SUBST(LLVMCONFIG_LDFLAGS, [`$llvmconfig --ldflags`])
10 - AC_SUBST(LLVMCONFIG_LIBS, [-lLLVM-$llvmver])
11 + AC_SUBST(LLVMCONFIG_LIBS, [`$llvmconfig --libs $llvmcomp`])
12 AC_SUBST(LLVMCONFIG_LIBFILES, [])
13 else
14 if test $llvmver_test -ge 350; then