gnu: nss, nss-certs: Update to 3.27.2.
[jackhill/guix/guix.git] / gnu / packages / wget.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages wget)
22 #:use-module (guix licenses)
23 #:use-module (gnu packages libidn)
24 #:use-module (gnu packages python)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages web)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages tls)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix build-system gnu))
32
33 (define-public wget
34 (package
35 (name "wget")
36 (version "1.18")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "mirror://gnu/wget/wget-"
41 version ".tar.xz"))
42 (sha256
43 (base32
44 "1hcwx8ww3sxzdskkx3l7q70a7wd6569yrnjkw9pw013cf9smpddm"))))
45 (build-system gnu-build-system)
46 (inputs
47 `(("gnutls" ,gnutls)
48 ("libidn" ,libidn)
49 ("libpsl" ,libpsl)))
50 (native-inputs
51 `(("pkg-config" ,pkg-config)
52 ("perl" ,perl)
53 ("python" ,python) ;for testenv suite
54 ("perl-http-daemon" ,perl-http-daemon)
55 ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
56 (home-page "http://www.gnu.org/software/wget/")
57 (synopsis "Non-interactive command-line utility for downloading files")
58 (description
59 "GNU Wget is a non-interactive tool for fetching files using the HTTP,
60 HTTPS and FTP protocols. It can resume interrupted downloads, use file name
61 wild cards, supports proxies and cookies, and it can convert absolute links
62 in downloaded documents to relative links.")
63 (license gpl3+))) ; some files are under GPLv2+
64
65 (define-public wgetpaste
66 (package
67 (name "wgetpaste")
68 (version "2.28")
69 (source
70 (origin
71 (method url-fetch)
72 (uri (string-append "http://wgetpaste.zlin.dk/wgetpaste-"
73 version ".tar.bz2"))
74 (sha256
75 (base32
76 "1hh9svyypqcvdg5mjxyyfzpdzhylhf7s7xq5dzglnm4injx3i3ak"))))
77 (build-system gnu-build-system)
78 (arguments
79 '(#:phases
80 (modify-phases %standard-phases
81 (delete 'configure)
82 (delete 'build)
83 (replace 'install
84 (lambda* (#:key outputs #:allow-other-keys)
85 (let* ((out (assoc-ref outputs "out"))
86 (bin (string-append out "/bin"))
87 (zsh (string-append out "/share/zsh/site-functions")))
88 (install-file "wgetpaste" bin)
89 (install-file "_wgetpaste" zsh)))))
90 #:tests? #f)) ; no test target
91 (home-page "http://wgetpaste.zlin.dk/")
92 (synopsis "Script that automates pasting to a number of pastebin services")
93 (description
94 "@code{wgetpaste} is an extremely simple command-line interface to various
95 online pastebin services.")
96 (license public-domain)))