gnu: nss, nss-certs: Update to 3.27.2.
[jackhill/guix/guix.git] / gnu / packages / mate.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages mate)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix utils)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages gtk)
30 #:use-module (gnu packages gnome)
31 #:use-module (gnu packages xorg)
32 #:use-module (gnu packages xdisorg)
33 #:use-module (gnu packages base)
34 #:use-module (gnu packages xml)
35 #:use-module (gnu packages python))
36
37 (define-public mate-icon-theme
38 (package
39 (name "mate-icon-theme")
40 (version "1.16.0")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "http://pub.mate-desktop.org/releases/"
44 (version-major+minor version) "/"
45 name "-" version ".tar.xz"))
46 (sha256
47 (base32
48 "1zldw22p1i76iss8car39pmfagpfxxlfk1fdhvr4x5r6gf36gv7d"))))
49 (build-system gnu-build-system)
50 (native-inputs
51 `(("pkg-config" ,pkg-config)
52 ("intltool" ,intltool)
53 ("gtk+" ,gtk+)
54 ("icon-naming-utils" ,icon-naming-utils)))
55 (home-page "http://mate-desktop.org/")
56 (synopsis "The MATE desktop environment icon theme")
57 (description
58 "This package contains the default icon theme used by the MATE desktop.")
59 (license license:lgpl3+)))
60
61 (define-public mate-themes
62 (package
63 (name "mate-themes")
64 (version (package-version gtk+))
65 (source (origin
66 (method url-fetch)
67 (uri (string-append "http://pub.mate-desktop.org/releases/themes/"
68 (version-major+minor (package-version gtk+))
69 "/mate-themes-" (package-version gtk+)
70 ".tar.xz"))
71 (sha256
72 (base32
73 "12p6xvqs8smbk9nivi43089fiw1jbb3g9836arr0sksmmziklnvy"))))
74 (build-system gnu-build-system)
75 (native-inputs
76 `(("pkg-config" ,pkg-config)
77 ("intltool" ,intltool)))
78 (inputs
79 `(("gtk+" ,gtk+)
80 ("gdk-pixbuf" ,gdk-pixbuf)
81 ("gtk-engines" ,gtk-engines)
82 ("murrine" ,murrine)))
83 (home-page "http://mate-desktop.org/")
84 (synopsis
85 "Official themes for the MATE desktop")
86 (description
87 "This package includes the standard themes for the MATE desktop, for
88 example Menta, TraditionalOk, GreenLaguna or BlackMate. This package has
89 themes for both gtk+-2 and gtk+-3.")
90 (license (list license:lgpl2.1+ license:cc-by-sa3.0 license:gpl3+
91 license:gpl2+))))
92
93 (define-public mate-desktop
94 (package
95 (name "mate-desktop")
96 (version "1.16.1")
97 (source (origin
98 (method url-fetch)
99 (uri (string-append "http://pub.mate-desktop.org/releases/"
100 (version-major+minor version) "/"
101 name "-" version ".tar.xz"))
102 (sha256
103 (base32
104 "1pzncfgrzp2mp9407ivk1113hkadpf110blr058h31jkwsk8syjq"))))
105 (build-system gnu-build-system)
106 (arguments
107 `(#:configure-flags '("--with-gtk=3.0"
108 "--enable-mpaste")))
109 (native-inputs
110 `(("pkg-config" ,pkg-config)
111 ("intltool" ,intltool)
112 ("glib:bin" ,glib "bin")
113 ("gobject-introspection" ,gobject-introspection)
114 ("yelp-tools" ,yelp-tools)))
115 ;;("gtk-doc" ,gtk-doc))) ; add back in when gtk-doc builds
116 (inputs
117 `(("gtk+" ,gtk+)
118 ("libxrandr" ,libxrandr)
119 ("python2" ,python-2)
120 ("startup-notification" ,startup-notification)))
121 (propagated-inputs
122 `(("dconf" ,dconf))) ; mate-desktop-2.0.pc
123 (home-page "http://mate-desktop.org/")
124 (synopsis "Library with common API for various MATE modules")
125 (description
126 "This package contains a public API shared by several applications on the
127 desktop and the mate-about program.")
128 (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.1+))))
129
130 (define-public libmateweather
131 (package
132 (name "libmateweather")
133 (version "1.16.1")
134 (source (origin
135 (method url-fetch)
136 (uri (string-append "http://pub.mate-desktop.org/releases/"
137 (version-major+minor version) "/"
138 name "-" version ".tar.xz"))
139 (sha256
140 (base32
141 "0w1b8b1ckmkbvwnqi9yh2lwbskzhz99s5yxdkar5xiqylnjrwmm3"))))
142 (build-system gnu-build-system)
143 (arguments
144 `(#:configure-flags
145 `("--with-gtk=3.0"
146 ,(string-append "--with-zoneinfo-dir="
147 (assoc-ref %build-inputs "tzdata")
148 "/share/zoneinfo"))
149 #:phases
150 (modify-phases %standard-phases
151 (add-before
152 'check 'pre-check
153 (lambda* (#:key inputs #:allow-other-keys)
154 (substitute* "data/check-timezones.sh"
155 (("/usr/share/zoneinfo/zone.tab")
156 (string-append (assoc-ref inputs "tzdata")
157 "/share/zoneinfo/zone.tab")))
158 #t)))))
159 (native-inputs
160 `(("pkg-config" ,pkg-config)
161 ("intltool" ,intltool)
162 ("glib:bin" ,glib "bin")))
163 (inputs
164 `(("dconf" ,dconf)
165 ("gdk-pixbuf" ,gdk-pixbuf)
166 ("gtk+" ,gtk+)
167 ("tzdata" ,tzdata)))
168 (propagated-inputs
169 ;; both of these are requires.private in mateweather.pc
170 `(("libsoup" ,libsoup)
171 ("libxml2" ,libxml2)))
172 (home-page "http://mate-desktop.org/")
173 (synopsis "MATE library for weather information from the Internet")
174 (description
175 "This library provides access to weather information from the internet for
176 the MATE desktop environment.")
177 (license license:lgpl2.1+)))
178
179 (define-public mate-menus
180 (package
181 (name "mate-menus")
182 (version "1.16.0")
183 (source (origin
184 (method url-fetch)
185 (uri (string-append "http://pub.mate-desktop.org/releases/"
186 (version-major+minor version) "/"
187 name "-" version ".tar.xz"))
188 (sha256
189 (base32
190 "0crw07iszwsqk54y8znfqdgfz76rjdz8992v4q9kpwwlrl11xmc5"))))
191 (build-system gnu-build-system)
192 (arguments
193 `(#:phases
194 (modify-phases %standard-phases
195 (add-after
196 'unpack 'fix-introspection-install-dir
197 (lambda* (#:key outputs #:allow-other-keys)
198 (let ((out (assoc-ref outputs "out")))
199 (substitute* '("configure")
200 (("`\\$PKG_CONFIG --variable=girdir gobject-introspection-1.0`")
201 (string-append "\"" out "/share/gir-1.0/\""))
202 (("\\$\\(\\$PKG_CONFIG --variable=typelibdir gobject-introspection-1.0\\)")
203 (string-append out "/lib/girepository-1.0/")))
204 #t))))))
205 (native-inputs
206 `(("pkg-config" ,pkg-config)
207 ("intltool" ,intltool)
208 ("gobject-introspection" ,gobject-introspection)))
209 (inputs
210 `(("glib" ,glib)
211 ("python" ,python-2)))
212 (home-page "http://mate-desktop.org/")
213 (synopsis "Freedesktop menu specification implementation for MATE")
214 (description
215 "The package contains an implementation of the freedesktop menu
216 specification, the MATE menu layout configuration files, .directory files and
217 assorted menu related utility programs.")
218 (license (list license:gpl2+ license:lgpl2.0+))))