gnu: python-llvmlite: Remove obsolete patch.
[jackhill/guix/guix.git] / gnu / packages / icu4c.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
6 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages icu4c)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages perl)
26 #:use-module (guix licenses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system ant)
30 #:use-module (guix build-system gnu))
31
32 (define-public icu4c
33 (package
34 (name "icu4c")
35 (version "61.1")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append
39 "http://download.icu-project.org/files/icu4c/"
40 version
41 "/icu4c-"
42 (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
43 "-src.tgz"))
44 (sha256
45 (base32 "1vxgkx0cyvdy00a9yd5khkx14r5kcndkax2wa99klm52x2dgh1yh"))))
46 (build-system gnu-build-system)
47 (inputs
48 `(("perl" ,perl)))
49 (arguments
50 `(#:configure-flags
51 '("--enable-rpath"
52 ,@(if (let ((s (or (%current-target-system)
53 (%current-system))))
54 (or (string-prefix? "arm" s)
55 (string-prefix? "mips" s)))
56 '("--with-data-packaging=archive")
57 '()))
58 #:phases
59 (modify-phases %standard-phases
60 (add-after 'unpack 'chdir-to-source
61 (lambda _ (chdir "source") #t)))))
62 (synopsis "International Components for Unicode")
63 (description
64 "ICU is a set of C/C++ and Java libraries providing Unicode and
65 globalisation support for software applications. This package contains the
66 C/C++ part.")
67 (license x11)
68 (home-page "http://site.icu-project.org/")))
69
70 (define-public java-icu4j
71 (package
72 (name "java-icu4j")
73 (version "59.1")
74 (source (origin
75 (method url-fetch)
76 (uri (string-append "http://download.icu-project.org/files/icu4j/"
77 version "/icu4j-"
78 (string-map (lambda (x)
79 (if (char=? x #\.) #\_ x))
80 version)
81 "-src.jar"))
82 (sha256
83 (base32
84 "0bgxsvgi0qcwj60pvcxrf7a3fbk7aksyxnfwpbzavyfrfzixqh0c"))))
85 (build-system ant-build-system)
86 (arguments
87 `(#:tests? #f ; no tests included
88 #:jar-name "icu4j.jar"))
89 (home-page "http://site.icu-project.org/")
90 (synopsis "International Components for Unicode")
91 (description
92 "ICU is a set of C/C++ and Java libraries providing Unicode and
93 globalisation support for software applications. This package contains the
94 Java part.")
95 (license x11)))