gnu: Synchronize descriptions with 'gnumaint'.
[jackhill/guix/guix.git] / gnu / packages / zile.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages zile)
20 #:use-module (guix licenses)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages bdw-gc)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages help2man)
27 #:use-module (gnu packages ncurses)
28 #:use-module (gnu packages bash))
29
30 (define-public zile
31 (package
32 (name "zile")
33 (version "2.4.9")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/zile/zile-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "0j801c28ypm924rw3lqyb6khxyslg6ycrv16wmmwcam0mk3mj6f7"))))
41 (build-system gnu-build-system)
42 (arguments
43 '(#:phases (alist-cons-before
44 'configure 'patch-/bin/sh
45 (lambda* (#:key inputs #:allow-other-keys)
46 (let ((bash (assoc-ref inputs "bash")))
47 ;; Refer to the actual shell.
48 (substitute* '("lib/spawni.c" "src/funcs.c")
49 (("/bin/sh")
50 (string-append bash "/bin/sh")))))
51 %standard-phases)))
52 (inputs
53 `(("boehm-gc" ,libgc)
54 ("ncurses" ,ncurses)
55 ("bash" ,bash)))
56 (native-inputs
57 `(("perl" ,perl)
58 ("help2man" ,help2man)))
59 (home-page "http://www.gnu.org/software/zile/")
60 (synopsis "Zile is lossy Emacs, a lightweight Emacs clone")
61 (description
62 "GNU Zile is a lightweight Emacs clone. It usage is similar to the
63 default Emacs configuration, but it carries a much lighter feature set.")
64 (license gpl3+)))