gnu: Synchronize descriptions with 'gnumaint'.
[jackhill/guix/guix.git] / gnu / packages / gnutls.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gnutls)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module ((gnu packages compression)
25 #:renamer (symbol-prefix-proc 'guix:))
26 #:use-module (gnu packages)
27 #:use-module (gnu packages nettle)
28 #:use-module (gnu packages guile)
29 #:use-module (gnu packages perl)
30 #:use-module (gnu packages which)
31 #:use-module (gnu packages pkg-config))
32
33 (define-public libtasn1
34 (package
35 (name "libtasn1")
36 (version "3.3")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "mirror://gnu/libtasn1/libtasn1-"
41 version ".tar.gz"))
42 (sha256
43 (base32
44 "1h1sz5py8zlg4yczybr6wa925pyadvjcxrdmhilwaqqgs4n2lrcj"))))
45 (build-system gnu-build-system)
46 (home-page "http://www.gnu.org/software/libtasn1/")
47 (synopsis "ASN.1 library")
48 (description
49 "GNU libtasn1 is a library implementing the ASN.1 notation. It is used
50 for transmitting machine-neutral encodings of data objects in computer
51 networking, allowing for formal validation of data according to some
52 specifications.")
53 (license lgpl2.0+)))
54
55 (define-public gnutls
56 (package
57 (name "gnutls")
58 (version "3.2.4")
59 (source (origin
60 (method url-fetch)
61 (uri
62 ;; Note: Releases are no longer on ftp.gnu.org since the
63 ;; schism (after version 3.1.5).
64 (string-append "mirror://gnupg/gnutls/v3.2/gnutls-"
65 version ".tar.xz"))
66 (sha256
67 (base32
68 "0zvhzy87v9dfxfvmg1pl951kw55rp647cqdza8942fxq7spp158i"))))
69 (build-system gnu-build-system)
70 (native-inputs
71 `(("pkg-config" ,pkg-config)))
72 (inputs
73 `(("guile" ,guile-2.0)
74 ("zlib" ,guix:zlib)
75 ("perl" ,perl)))
76 (propagated-inputs
77 `(("libtasn1" ,libtasn1)
78 ("nettle" ,nettle)
79 ("which" ,which)))
80 (home-page "http://www.gnu.org/software/gnutls/")
81 (synopsis "Transport layer security library")
82 (description
83 "GnuTLS is a secure communications library implementing the SSL, TLS
84 and DTLS protocols. It is provided in the form of a C library to support the
85 protocols, as well as to parse and write X.5009, PKCS 12, OpenPGP and other
86 required structures.")
87 (license lgpl2.1+)))