gnu: Do not #:select from (gnu packages …) modules.
[jackhill/guix/guix.git] / gnu / packages / texinfo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
4 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages texinfo)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages linux)
30 #:use-module (gnu packages ncurses))
31
32 (define-public texinfo
33 (package
34 (name "texinfo")
35 (version "6.0")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/texinfo/texinfo-"
39 version ".tar.xz"))
40 (sha256
41 (base32
42 "1r3i6jyynn6ab45fxw5bms8mflk9ry4qpj6gqyry72vfd5c47fhi"))))
43 (build-system gnu-build-system)
44 (native-inputs `(("procps" ,procps))) ;one of the tests needs pgrep
45 (inputs `(("ncurses" ,ncurses)
46 ("xz" ,xz)
47 ("perl" ,perl)))
48
49 (native-search-paths
50 ;; This is the variable used by the standalone Info reader.
51 (list (search-path-specification
52 (variable "INFOPATH")
53 (files '("share/info")))))
54
55 (home-page "http://www.gnu.org/software/texinfo/")
56 (synopsis "The GNU documentation format")
57 (description
58 "Texinfo is the official documentation format of the GNU project. It
59 uses a single source file using explicit commands to produce a final document
60 in any of several supported output formats, such as HTML or PDF. This
61 package includes both the tools necessary to produce Info documents from
62 their source and the command-line Info reader. The emphasis of the language
63 is on expressing the content semantically, avoiding physical markup commands.")
64 (license gpl3+)))
65
66 (define-public texinfo-5
67 (package (inherit texinfo)
68 (version "5.2")
69 (source (origin
70 (method url-fetch)
71 (uri (string-append "mirror://gnu/texinfo/texinfo-"
72 version ".tar.xz"))
73 (sha256
74 (base32
75 "1njfwh2z34r2c4r0iqa7v24wmjzvsfyz4vplzry8ln3479lfywal"))))
76 (native-inputs '())))
77
78 (define-public texinfo-4
79 (package (inherit texinfo)
80 (version "4.13a")
81 (source (origin
82 (method url-fetch)
83 (uri (string-append
84 "mirror://gnu/texinfo/texinfo-"
85 version
86 ".tar.lzma"))
87 (sha256
88 (base32
89 "1rf9ckpqwixj65bw469i634897xwlgkm5i9g2hv3avl6mv7b0a3d"))))
90 (native-inputs '())
91 (inputs `(("ncurses" ,ncurses) ("xz" ,xz)))))
92
93 (define-public texi2html
94 (package
95 (name "texi2html")
96 (version "5.0")
97 (source (origin
98 (method url-fetch)
99 (uri (string-append "mirror://savannah/" name "/" name "-"
100 version ".tar.bz2"))
101 (sha256
102 (base32
103 "1yprv64vrlcbksqv25asplnjg07mbq38lfclp1m5lj8cw878pag8"))
104 (patches
105 (list (search-patch "texi2html-document-encoding.patch")
106 (search-patch "texi2html-i18n.patch")))
107 (snippet
108 ;; This file is modified by the patch above, but reset its
109 ;; timestamp so we don't trigger the rule to update PO files,
110 ;; which would require Gettext.
111 ;; See <http://bugs.gnu.org/18247>.
112 '(utime "texi2html.pl" 0 0 0 0))))
113 (build-system gnu-build-system)
114 (inputs `(("perl" ,perl)))
115 (home-page "http://www.nongnu.org/texi2html/")
116 (synopsis "Convert Texinfo to HTML")
117 (description
118 "Texi2HTML is a Perl script which converts Texinfo source files to HTML
119 output. It now supports many advanced features, such as internationalization
120 and extremely configurable output formats.
121
122 Development of Texi2HTML moved to the GNU Texinfo repository in 2010, since it
123 was meant to replace the makeinfo implementation in GNU Texinfo. The route
124 forward for authors is, in most cases, to alter manuals and build processes as
125 necessary to use the new features of the makeinfo/texi2any implementation of
126 GNU Texinfo. The Texi2HTML maintainers (one of whom is the principal author
127 of the GNU Texinfo implementation) do not intend to make further releases of
128 Texi2HTML.")
129 ;; Files in /lib under lgpl2.1+ and x11
130 (license gpl2+)))