Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / pth.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages pth)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public pth
27 (package
28 (name "pth")
29 (version "2.0.7")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/pth/pth-" version
34 ".tar.gz"))
35 (sha256
36 (base32
37 "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
38 (build-system gnu-build-system)
39 (arguments
40 '(#:parallel-build? #f))
41 (home-page "http://www.gnu.org/software/pth")
42 (synopsis "Portable thread library")
43 (description
44 "GNU Pth is a portable library providing non-preemptive, priority-based
45 scheduling for multiple execution threads. Each thread has its own
46 program-counter, run-time stack, signal mask and errno variable. Threads are
47 scheduled in a cooperative way, rather than in the standard preemptive way,
48 such that they are managed according to priority and events. However, Pth
49 also features emulation of POSIX.1c threads (\"pthreads\") for backwards
50 compatibility.")
51 (license lgpl2.1+)))