Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / m4.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages m4)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public m4
27 (package
28 (name "m4")
29 (version "1.4.17")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/m4/m4-"
33 version ".tar.bz2"))
34 (sha256
35 (base32
36 "0w0da1chh12mczxa5lnwzjk9czi3dq6gnnndbpa6w4rj76b1yklf"))))
37 (build-system gnu-build-system)
38 (arguments
39 ;; XXX: Disable tests on those platforms with know issues.
40 `(#:tests? ,(not (member (%current-system)
41 '("x86_64-darwin"
42 "i686-cygwin"
43 "i686-sunos")))
44 #:phases (alist-cons-before
45 'check 'pre-check
46 (lambda* (#:key inputs #:allow-other-keys)
47 ;; Fix references to /bin/sh.
48 (let ((bash (assoc-ref inputs "bash")))
49 (for-each patch-shebang
50 (find-files "tests" "\\.sh$"))
51 (substitute* (find-files "tests"
52 "posix_spawn")
53 (("/bin/sh")
54 (format #f "~a/bin/bash" bash)))))
55 %standard-phases)))
56 (synopsis "Macro processor")
57 (description
58 "GNU M4 is an implementation of the M4 macro language, which features
59 some extensions over other implementations, some of which are required by GNU
60 Autoconf. It is used as a macro processor, which means it processes text,
61 expanding macros as it encounters them. It also has some built-in functions,
62 for example to run shell commands or to do arithmetic.")
63 (license gpl3+)
64 (home-page "http://www.gnu.org/software/m4/")))