Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libcanberra.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libcanberra)
21 #:use-module ((guix licenses) #:select (lgpl2.1+))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages autotools)
26 #:use-module (gnu packages gstreamer)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages linux)
30 #:use-module (gnu packages pulseaudio)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages xiph))
33
34 (define-public libcanberra
35 (package
36 (name "libcanberra")
37 (version "0.30")
38 (source
39 (origin
40 (method url-fetch)
41
42 ;; This used to be at 0pointer.de but it vanished.
43 (uri (string-append
44 "http://pkgs.fedoraproject.org/repo/pkgs/libcanberra/libcanberra-"
45 version ".tar.xz/34cb7e4430afaf6f447c4ebdb9b42072/libcanberra-"
46 version ".tar.xz"))
47 (sha256
48 (base32
49 "0wps39h8rx2b00vyvkia5j40fkak3dpipp1kzilqla0cgvk73dn2"))))
50 (build-system gnu-build-system)
51 (inputs
52 `(("alsa-lib" ,alsa-lib)
53 ("gstreamer" ,gstreamer)
54 ("gtk+" ,gtk+)
55 ("libltdl" ,libltdl)
56 ("libvorbis" ,libvorbis)
57 ("pulseaudio" ,pulseaudio)
58 ("udev" ,eudev)))
59 (native-inputs
60 `(("pkg-config" ,pkg-config)))
61 (home-page "http://0pointer.de/lennart/projects/libcanberra/")
62 (synopsis
63 "Implementation of the XDG Sound Theme and Name Specifications")
64 (description
65 "Libcanberra is an implementation of the XDG Sound Theme and Name
66 Specifications, for generating event sounds on free desktops, such as
67 GNOME. It comes with several backends (ALSA, PulseAudio, OSS, GStreamer,
68 null) and is designed to be portable.")
69 (license lgpl2.1+)))
70
71 (define-public sound-theme-freedesktop
72 (package
73 (name "sound-theme-freedesktop")
74 (version "0.8")
75 (source (origin
76 (method url-fetch)
77 (uri (string-append "http://people.freedesktop.org/~mccann/dist/"
78 name "-" version ".tar.bz2"))
79 (sha256
80 (base32
81 "054abv4gmfk9maw93fis0bf605rc56dah7ys5plc4pphxqh8nlfb"))))
82 (build-system gnu-build-system)
83 (native-inputs `(("intltool" ,intltool)))
84 (synopsis "Audio samples for use as a desktop sound theme")
85 (description
86 "This package provides audio samples that can be used by libcanberra as
87 sounds for various system events.")
88 (license #f)
89 (home-page "http://www.freedesktop.org/wiki/Specifications/sound-theme-spec/")))