Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / wm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
3 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
4 ;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2015 xd1le <elisp.vim@gmail.com>
6 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
7 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
8 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
9 ;;; Copyright © 2016 Al McElrath <hello@yrns.org>
10 ;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
11 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
12 ;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
13 ;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
14 ;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
15 ;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
16 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
17 ;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages wm)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (guix packages)
37 #:use-module (gnu packages)
38 #:use-module (gnu packages linux)
39 #:use-module (guix build-system cmake)
40 #:use-module (guix build-system gnu)
41 #:use-module (guix build-system haskell)
42 #:use-module (guix build-system perl)
43 #:use-module (guix build-system python)
44 #:use-module (gnu packages haskell)
45 #:use-module (gnu packages base)
46 #:use-module (gnu packages pkg-config)
47 #:use-module (gnu packages perl)
48 #:use-module (gnu packages pulseaudio)
49 #:use-module (gnu packages xorg)
50 #:use-module (gnu packages xdisorg)
51 #:use-module (gnu packages documentation)
52 #:use-module (gnu packages xml)
53 #:use-module (gnu packages m4)
54 #:use-module (gnu packages docbook)
55 #:use-module (gnu packages image)
56 #:use-module (gnu packages pcre)
57 #:use-module (gnu packages python)
58 #:use-module (gnu packages gtk)
59 #:use-module (gnu packages libevent)
60 #:use-module (gnu packages fribidi)
61 #:use-module (gnu packages maths)
62 #:use-module (gnu packages web)
63 #:use-module (gnu packages fontutils)
64 #:use-module (gnu packages freedesktop)
65 #:use-module (gnu packages glib)
66 #:use-module (gnu packages gperf)
67 #:use-module (gnu packages imagemagick)
68 #:use-module (gnu packages lua)
69 #:use-module (gnu packages suckless)
70 #:use-module (guix download)
71 #:use-module (guix git-download))
72
73 (define-public libconfuse
74 (package
75 (name "libconfuse")
76 (version "3.2.1")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "https://github.com/martinh/libconfuse/"
80 "releases/download/v" version
81 "/confuse-" version ".tar.xz"))
82 (sha256
83 (base32
84 "0pnjmlj9i0alp407qd7c0vq83sz7gpsjrbdgpcn4xvzjp9r35ii3"))))
85 (build-system gnu-build-system)
86 (home-page "https://github.com/martinh/libconfuse")
87 (synopsis "Configuration file parser library")
88 (description "libconfuse is a configuration file parser library. It
89 supports sections and (lists of) values (strings, integers, floats, booleans
90 or other sections), as well as some other features (such as
91 single/double-quoted strings, environment variable expansion, functions and
92 nested include statements).")
93 (license license:isc)))
94
95 (define-public bspwm
96 (package
97 (name "bspwm")
98 (version "0.9.3")
99 (source
100 (origin
101 (file-name (string-append name "-" version ".tar.gz"))
102 (method url-fetch)
103 (uri (string-append
104 "https://github.com/baskerville/bspwm/archive/"
105 version ".tar.gz"))
106 (sha256
107 (base32
108 "17dwj7w16cdj7g4s2y2f96lgj5msq1s4543dnfa3rijlazzy6mmk"))))
109 (build-system gnu-build-system)
110 (inputs
111 `(("libxcb" ,libxcb)
112 ("libxinerama" ,libxinerama)
113 ("sxhkd" ,sxhkd)
114 ("xcb-util" ,xcb-util)
115 ("xcb-util-keysyms" ,xcb-util-keysyms)
116 ("xcb-util-wm" ,xcb-util-wm)))
117 (arguments
118 '(#:phases (modify-phases %standard-phases (delete 'configure))
119 #:tests? #f ; no check target
120 #:make-flags (list "CC=gcc"
121 (string-append "PREFIX=" %output))))
122 (home-page "https://github.com/baskerville/bspwm")
123 (synopsis "Tiling window manager based on binary space partitioning")
124 (description "bspwm is a tiling window manager that represents windows as
125 the leaves of a full binary tree.")
126 (license license:bsd-2)))
127
128 (define-public i3status
129 (package
130 (name "i3status")
131 (version "2.11")
132 (source (origin
133 (method url-fetch)
134 (uri (string-append "https://i3wm.org/i3status/i3status-"
135 version ".tar.bz2"))
136 (sha256
137 (base32
138 "0pwcy599fw8by1a1sf91crkqba7679qhvhbacpmhis8c1xrpxnwq"))))
139 (build-system gnu-build-system)
140 (arguments
141 `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
142 #:phases
143 (modify-phases %standard-phases
144 (delete 'configure))
145 #:tests? #f)) ; no test suite
146 (inputs
147 `(("openlibm" ,openlibm)
148 ("libconfuse" ,libconfuse)
149 ("libyajl" ,libyajl)
150 ("alsa-lib" ,alsa-lib)
151 ("pulseaudio" ,pulseaudio)
152 ("libnl" ,libnl)
153 ("libcap" ,libcap)
154 ("asciidoc" ,asciidoc)))
155 (native-inputs
156 `(("pkg-config" ,pkg-config)))
157 (home-page "https://i3wm.org/i3status/")
158 (synopsis "Status bar for i3bar, dzen2, xmobar or similar programs")
159 (description "i3status is a small program for generating a status bar for
160 i3bar, dzen2, xmobar or similar programs. It is designed to be very efficient
161 by issuing a very small number of system calls, as one generally wants to
162 update such a status line every second. This ensures that even under high
163 load, your status bar is updated correctly. Also, it saves a bit of energy by
164 not hogging your CPU as much as spawning the corresponding amount of shell
165 commands would.")
166 (license license:bsd-3)))
167
168 (define-public i3-wm
169 (package
170 (name "i3-wm")
171 (version "4.14.1")
172 (source (origin
173 (method url-fetch)
174 (uri (string-append "https://i3wm.org/downloads/i3-"
175 version ".tar.bz2"))
176 (sha256
177 (base32
178 "1cazmfbbx6n8c81h6x6pdayq3mxs2ml3adz165z8vapkc72kl1nh"))))
179 (build-system gnu-build-system)
180 (arguments
181 `(#:make-flags
182 (list "CC=gcc"
183 (string-append "PREFIX=" %output)
184 ;; This works around the following error:
185 ;; 'error: ‘for’ loop initial declarations are only allowed in C99
186 ;; or C11 mode'
187 "CFLAGS=-std=c11")
188 ;; The build system tries to build in a separate directory, but that
189 ;; seems to be unnecessary.
190 #:configure-flags '("--disable-builddir")
191 ;; The test suite appears to require the unpackaged Perl module AnyEvent.
192 #:tests? #f))
193 (inputs
194 `(("libxcb" ,libxcb)
195 ("xcb-util" ,xcb-util)
196 ("xcb-util-cursor" ,xcb-util-cursor)
197 ("xcb-util-keysyms" ,xcb-util-keysyms)
198 ("xcb-util-wm" ,xcb-util-wm)
199 ("xcb-util-xrm" ,xcb-util-xrm)
200 ("libxkbcommon" ,libxkbcommon)
201 ("libev" ,libev)
202 ("libyajl" ,libyajl)
203 ("asciidoc" ,asciidoc)
204 ("xmlto" ,xmlto)
205 ("perl-pod-simple" ,perl-pod-simple)
206 ("libx11" ,libx11)
207 ("pcre" ,pcre)
208 ("startup-notification" ,startup-notification)
209 ("pango" ,pango)
210 ("cairo" ,cairo)))
211 (native-inputs
212 `(("which" ,which)
213 ("perl" ,perl)
214 ("pkg-config" ,pkg-config)
215 ;; For building the documentation.
216 ("libxml2" ,libxml2)
217 ("docbook-xsl" ,docbook-xsl)))
218 (home-page "https://i3wm.org/")
219 (synopsis "Improved tiling window manager")
220 (description "A tiling window manager, completely written
221 from scratch. i3 is primarily targeted at advanced users and
222 developers.")
223 (license license:bsd-3)))
224
225 (define-public perl-anyevent-i3
226 (package
227 (name "perl-anyevent-i3")
228 (version "0.17")
229 (source (origin
230 (method url-fetch)
231 (uri (string-append "mirror://cpan/authors/id/M/MS/MSTPLBG/"
232 "AnyEvent-I3-" version ".tar.gz"))
233 (sha256
234 (base32
235 "0qvd9bq16jyy7v3ma82qcnvz9j503bw0mh7h55gkjf7ir62ck0jk"))))
236 (build-system perl-build-system)
237 (propagated-inputs
238 `(("perl-anyevent" ,perl-anyevent)
239 ("perl-json-xs" ,perl-json-xs)))
240 (home-page "http://search.cpan.org/dist/AnyEvent-I3")
241 (synopsis
242 "Communicate with the i3 window manager through perl")
243 (description
244 "This module connects to the i3 window manager using the UNIX socket
245 based IPC interface it provides (if enabled in the configuration file).
246 You can then subscribe to events or send messages and receive their replies.")
247 ;; Can be used with either license.
248 (license (list license:gpl3+ license:perl-license))))
249
250 (define-public python-i3-py
251 (package
252 (name "python-i3-py")
253 (version "0.6.5")
254 (source
255 (origin
256 ;; The latest release is not tagged in Git nor has an entry in PyPi,
257 ;; but there is still a clear commit for it, and it's been the last one
258 ;; for years.
259 (method git-fetch)
260 (uri (git-reference
261 (url "https://github.com/ziberna/i3-py.git")
262 (commit "27f88a616e9ecc340e7d041d3d00782f8a1964c1")))
263 (sha256
264 (base32
265 "1nm719dc2xqlll7vj4c4m7mpjb27lpn3bg3c66gajvnrz2x1nmxs"))
266 (file-name (string-append name "-" version "-checkout"))))
267 (build-system python-build-system)
268 (arguments
269 `(#:tests? #f ; no tests yet
270 #:phases (modify-phases %standard-phases
271 (add-after 'install 'install-doc
272 ;; Copy readme file to documentation directory.
273 (lambda* (#:key outputs #:allow-other-keys)
274 (let ((doc (string-append (assoc-ref outputs "out")
275 "/share/doc/" ,name)))
276 (install-file "README.md" doc)
277 ;; Avoid unspecified return value.
278 #t))))))
279 (propagated-inputs
280 `(("i3-wm" ,i3-wm)))
281 (home-page "https://github.com/ziberna/i3-py")
282 (synopsis "Python interface to the i3 window manager")
283 (description "This package allows you to interact from a Python program
284 with the i3 window manager via its IPC socket. It can send commands and other
285 kinds of messages to i3, select the affected containers, filter results and
286 subscribe to events.")
287 (license license:gpl3+)))
288
289 (define-public python2-i3-py
290 (package-with-python2 python-i3-py))
291
292 (define-public quickswitch-i3
293 (let ((commit "ed692b1e8f43b95bd907ced26238ce8ccb2ed28f")
294 (revision "1")) ; Guix package revision
295 (package
296 (name "quickswitch-i3")
297 (version (string-append "2.2-" revision "."
298 (string-take commit 7)))
299 (source
300 (origin
301 ;; The latest commit is a few years old and just a couple commits
302 ;; after the last tagged release, so we use that latest commit
303 ;; instead of the release.
304 (method git-fetch)
305 (uri (git-reference
306 (url "https://github.com/proxypoke/quickswitch-for-i3.git")
307 (commit commit)))
308 (sha256
309 (base32
310 "0447077sama80jcdg5p64zjsvafmz5rbdrirhm1adcdjhkh6iqc5"))
311 (patches (search-patches "quickswitch-fix-dmenu-check.patch"))
312 (file-name (string-append name "-" version "-checkout"))))
313 (build-system python-build-system)
314 (arguments
315 `(#:tests? #f ; no tests yet
316 #:phases (modify-phases %standard-phases
317 (add-after 'install 'install-doc
318 ;; Copy readme file to documentation directory.
319 (lambda* (#:key outputs #:allow-other-keys)
320 (let ((doc (string-append (assoc-ref outputs "out")
321 "/share/doc/" ,name)))
322 (install-file "README.rst" doc)
323 ;; Avoid unspecified return value.
324 #t))))))
325 (inputs
326 `(("python-i3-py" ,python-i3-py)
327 ("dmenu" ,dmenu)))
328 (home-page "https://github.com/proxypoke/quickswitch-for-i3")
329 (synopsis "Quickly change to and locate windows in the i3 window manager")
330 (description
331 "This utility for the i3 window manager allows you to quickly switch to
332 and locate windows on all your workspaces, using an interactive dmenu
333 prompt.")
334 (license (license:non-copyleft "http://www.wtfpl.net/txt/copying/")))))
335
336 (define-public xmonad
337 (package
338 (name "xmonad")
339 (version "0.13")
340 (synopsis "Tiling window manager")
341 (source (origin
342 (method url-fetch)
343 (uri (string-append "mirror://hackage/package/xmonad/"
344 name "-" version ".tar.gz"))
345 (sha256
346 (base32
347 "1jh3lcs20qpna36fa5a0r174xqrsxhj10x1rm5vwf64zariipy7r"))))
348 (build-system haskell-build-system)
349 (inputs
350 `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
351 ("ghc-mtl" ,ghc-mtl)
352 ("ghc-quickcheck" ,ghc-quickcheck)
353 ("ghc-setlocale" ,ghc-setlocale)
354 ("ghc-utf8-string" ,ghc-utf8-string)
355 ("ghc-directory" ,ghc-directory)
356 ("ghc-x11" ,ghc-x11)))
357 (arguments
358 `(#:phases
359 (modify-phases %standard-phases
360 (add-after
361 'install 'install-xsession
362 (lambda _
363 (let* ((xsessions (string-append %output "/share/xsessions")))
364 (mkdir-p xsessions)
365 (call-with-output-file
366 (string-append xsessions "/xmonad.desktop")
367 (lambda (port)
368 (format port "~
369 [Desktop Entry]~@
370 Name=~a~@
371 Comment=~a~@
372 Exec=~a/bin/xmonad~@
373 Type=Application~%" ,name ,synopsis %output)))))))))
374 (home-page "http://xmonad.org")
375 (description
376 "Xmonad is a tiling window manager for X. Windows are arranged
377 automatically to tile the screen without gaps or overlap, maximising screen
378 use. All features of the window manager are accessible from the keyboard: a
379 mouse is strictly optional. Xmonad is written and extensible in Haskell.
380 Custom layout algorithms, and other extensions, may be written by the user in
381 config files. Layouts are applied dynamically, and different layouts may be
382 used on each workspace. Xinerama is fully supported, allowing windows to be
383 tiled on several screens.")
384 (license license:bsd-3)))
385
386 (define-public xmobar
387 (package
388 (name "xmobar")
389 (version "0.24.5")
390 (source (origin
391 (method url-fetch)
392 (uri (string-append "mirror://hackage/package/xmobar/"
393 name "-" version ".tar.gz"))
394 (sha256
395 (base32
396 "0sdzfj2wa4wpig1i2i5n9qpwm90jp88qifsmaa7j37yhhs6snfir"))))
397 (build-system haskell-build-system)
398 (inputs
399 `(("ghc-http" ,ghc-http)
400 ("ghc-parsec" ,ghc-parsec)
401 ("ghc-regex-compat" ,ghc-regex-compat)
402 ("ghc-stm" ,ghc-stm)
403 ("ghc-x11-xft" ,ghc-x11-xft)
404 ("ghc-hinotify" ,ghc-hinotify)
405 ("libxpm" ,libxpm)
406 ("wireless-tools" ,wireless-tools)))
407 (arguments
408 `(#:configure-flags
409 '("--flags=with_utf8 with_xft with_xpm with_inotify with_iwlib")))
410 (home-page "http://xmobar.org")
411 (synopsis "Minimalistic text based status bar")
412 (description
413 "@code{xmobar} is a lightweight, text-based, status bar written in
414 Haskell. It was originally designed to be used together with Xmonad, but it
415 is also usable with any other window manager. While xmobar is written in
416 Haskell, no knowledge of the language is required to install and use it.")
417 (license license:bsd-3)))
418
419 (define-public ghc-xmonad-contrib
420 (package
421 (name "ghc-xmonad-contrib")
422 (version "0.13")
423 (source
424 (origin
425 (method url-fetch)
426 (uri (string-append "mirror://hackage/package/xmonad-contrib/"
427 "xmonad-contrib-" version ".tar.gz"))
428 (sha256
429 (base32
430 "0vj72jhfng6y7hv5frx2v99jvl3jn9rbpk2j7xw9vydiwmzq4q57"))))
431 (build-system haskell-build-system)
432 (propagated-inputs
433 `(("ghc-mtl" ,ghc-mtl)
434 ("ghc-old-time" ,ghc-old-time)
435 ("ghc-random" ,ghc-random)
436 ("ghc-utf8-string" ,ghc-utf8-string)
437 ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
438 ("ghc-x11" ,ghc-x11)
439 ("ghc-x11-xft" ,ghc-x11-xft)
440 ("xmonad" ,xmonad)))
441 (home-page "http://xmonad.org")
442 (synopsis "Third party extensions for xmonad")
443 (description
444 "Third party tiling algorithms, configurations, and scripts to Xmonad, a
445 tiling window manager for X.")
446 (license license:bsd-3)))
447
448 (define-public evilwm
449 (package
450 (name "evilwm")
451 (version "1.1.1")
452 (source
453 (origin
454 (method url-fetch)
455 (uri (string-append "http://www.6809.org.uk/evilwm/evilwm-"
456 version ".tar.gz"))
457 (sha256
458 (base32
459 "0ak0yajzk3v4dg5wmaghv6acf7v02a4iw8qxmq5yw5ard8lrqn3r"))
460 (patches (search-patches "evilwm-lost-focus-bug.patch"))))
461 (build-system gnu-build-system)
462 (inputs
463 `(("libx11" ,libx11)
464 ("libxext" ,libxext)
465 ("libxrandr" ,libxrandr)))
466 (arguments
467 `(#:modules ((srfi srfi-26)
468 (guix build utils)
469 (guix build gnu-build-system))
470 #:make-flags (let ((inputs (map (cut assoc-ref %build-inputs <>)
471 '("libx11" "libxext" "libxrandr")))
472 (join (lambda (proc strs)
473 (string-join (map proc strs) " ")))
474 (dash-I (cut string-append "-I" <> "/include"))
475 (dash-L (cut string-append "-L" <> "/lib")))
476 `("desktopfilesdir=$(prefix)/share/xsessions"
477 ,(string-append "prefix=" (assoc-ref %outputs "out"))
478 ,(string-append "CPPFLAGS=" (join dash-I inputs))
479 ,(string-append "LDFLAGS=" (join dash-L inputs))))
480 #:tests? #f ;no tests
481 #:phases (modify-phases %standard-phases
482 (delete 'configure)))) ;no configure script
483 (home-page "http://www.6809.org.uk/evilwm/")
484 (synopsis "Minimalist window manager for the X Window System")
485 (description
486 "evilwm is a minimalist window manager based on aewm, extended to feature
487 many keyboard controls with repositioning and maximize toggles, solid window
488 drags, snap-to-border support, and virtual desktops.")
489 (license (license:x11-style "file:///README"))))
490
491 (define-public fluxbox
492 (package
493 (name "fluxbox")
494 (version "1.3.7")
495 (synopsis "Small and fast window manager")
496 (source (origin
497 (method url-fetch)
498 (uri (string-append "mirror://sourceforge/fluxbox/fluxbox/"
499 version "/fluxbox-" version ".tar.xz"))
500 (sha256
501 (base32
502 "1h1f70y40qd225dqx937vzb4k2cz219agm1zvnjxakn5jkz7b37w"))))
503 (build-system gnu-build-system)
504 (arguments
505 `(#:make-flags '("CPPFLAGS=-U__TIME__") ;ugly, but for reproducibility
506 #:phases
507 (modify-phases %standard-phases
508 (add-after
509 'install 'install-xsession
510 (lambda _
511 (let ((xsessions (string-append %output "/share/xsessions")))
512 (mkdir-p xsessions)
513 (call-with-output-file
514 (string-append xsessions "/fluxbox.desktop")
515 (lambda (port)
516 (format port "~
517 [Desktop Entry]~@
518 Name=~a~@
519 Comment=~a~@
520 Exec=~a/bin/startfluxbox~@
521 Type=Application~%" ,name ,synopsis %output)))))))))
522 (native-inputs
523 `(("pkg-config" ,pkg-config)))
524 (inputs
525 `(("freetype" ,freetype)
526 ("fribidi" ,fribidi)
527 ("imlib2" ,imlib2)
528 ("libx11" ,libx11)
529 ("libxext" ,libxext)
530 ("libxft" ,libxft)
531 ("libxinerama" ,libxinerama)
532 ("libxpm" ,libxpm)
533 ("libxrandr" ,libxrandr)
534 ("libxrender" ,libxrender)))
535 (description "Fluxbox is a window manager. It is light on resources
536 and easy to handle yet full of features to make an easy and fast desktop
537 experience.")
538 (home-page "http://fluxbox.org/")
539 (license license:expat)))
540
541 (define-public awesome
542 (package
543 (name "awesome")
544 (version "4.0")
545 (source
546 (origin (method url-fetch)
547 (uri (string-append
548 "https://github.com/awesomeWM/awesome-releases/raw/"
549 "master/awesome-" version ".tar.xz"))
550 (sha256
551 (base32
552 "0czkcz67sab63gf5m2p2pgg05yinjx60hfb9rfyzdkkg28q9f02w"))
553 (modules '((guix build utils)
554 (srfi srfi-19)))
555 (snippet
556 ;; Remove non-reproducible timestamp and use the date of the
557 ;; source file instead.
558 '(substitute* "common/version.c"
559 (("__DATE__ \" \" __TIME__")
560 (date->string
561 (time-utc->date
562 (make-time time-utc 0
563 (stat:mtime (stat "awesome.c"))))
564 "\"~c\""))))
565 (patches (search-patches "awesome-reproducible-png.patch"))))
566 (build-system cmake-build-system)
567 (native-inputs `(("asciidoc" ,asciidoc)
568 ("docbook-xsl" ,docbook-xsl)
569 ("doxygen" ,doxygen)
570 ("gperf" ,gperf)
571 ("imagemagick" ,imagemagick)
572 ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
573 ("pkg-config" ,pkg-config)
574 ("xmlto" ,xmlto)))
575 (inputs `(("cairo" ,cairo)
576 ("dbus" ,dbus)
577 ("gdk-pixbuf" ,gdk-pixbuf)
578 ("glib" ,glib)
579 ("gobject-introspection" ,gobject-introspection)
580 ("imlib2" ,imlib2)
581 ("libev" ,libev)
582 ("libxcb" ,libxcb)
583 ("libxcursor" ,libxcursor)
584 ("libxdg-basedir" ,libxdg-basedir)
585 ("libxkbcommon" ,libxkbcommon)
586 ("lua" ,lua)
587 ("lua-lgi",lua-lgi)
588 ("pango" ,pango)
589 ("startup-notification" ,startup-notification)
590 ("xcb-util" ,xcb-util)
591 ("xcb-util-cursor" ,xcb-util-cursor)
592 ("xcb-util-image" ,xcb-util-image)
593 ("xcb-util-keysyms" ,xcb-util-keysyms)
594 ("xcb-util-renderutil" ,xcb-util-renderutil)
595 ("xcb-util-xrm" ,xcb-util-xrm)
596 ("xcb-util-wm" ,xcb-util-wm)))
597 (arguments
598 `(;; Let compression happen in our 'compress-documentation' phase so that
599 ;; '--no-name' is used, which removes timestamps from gzip output.
600 #:configure-flags '("-DCOMPRESS_MANPAGES=off")
601
602 #:phases
603 (modify-phases %standard-phases
604 (add-before 'build 'xmlto-skip-validation
605 (lambda _
606 ;; We can't download the necessary schema, so so skip
607 ;; validation and assume they're valid.
608 (substitute* "../build/CMakeFiles/man.dir/build.make"
609 (("/xmlto")
610 (string-append "/xmlto --skip-validation")))
611 #t))
612 (add-before 'configure 'set-lua-paths
613 (lambda* (#:key inputs #:allow-other-keys)
614 ;; The build process needs to load cairo dynamically.
615 (let* ((cairo (string-append
616 (assoc-ref inputs "cairo") "/lib" ))
617 (lua-lgi (assoc-ref inputs "lua-lgi") ))
618 (setenv "LD_LIBRARY_PATH" cairo )
619 (setenv "LUA_PATH" (string-append lua-lgi
620 "/share/lua/5.2/?.lua"))
621 (setenv "LUA_CPATH" (string-append lua-lgi
622 "/lib/lua/5.2/?.so"))
623 #t)))
624 (replace 'check
625 (lambda _
626 ;; There aren't any tests, so just make sure the binary
627 ;; gets built and can be run successfully.
628 (zero? (system* "../build/awesome" "-v"))))
629 (add-after 'install 'wrap
630 (lambda* (#:key inputs outputs #:allow-other-keys)
631 (let* ((awesome (assoc-ref outputs "out"))
632 (cairo (string-append
633 (assoc-ref inputs "cairo") "/lib" ))
634 (lua-lgi (assoc-ref inputs "lua-lgi") ))
635 (wrap-program (string-append awesome "/bin/awesome")
636 `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))
637 `("LD_LIBRARY_PATH" suffix (, cairo))
638 `("LUA_PATH" suffix (,(string-append lua-lgi
639 "/share/lua/5.2/?.lua")))
640 `("LUA_CPATH" suffix (,(string-append
641 lua-lgi "/lib/lua/5.2/?.so"))))))))))
642 (synopsis "Highly configurable window manager")
643 (description
644 "Awesome has been designed as a framework window manager. It is fast, small,
645 dynamic and extensible using the Lua programming language.")
646 (license license:gpl2+)
647 (home-page "https://awesome.naquadah.org/")))
648
649 (define-public menumaker
650 (package
651 (name "menumaker")
652 (version "0.99.10")
653 (source
654 (origin
655 (method url-fetch)
656 (uri (string-append "mirror://sourceforge/menumaker/"
657 "menumaker-" version ".tar.gz"))
658 (sha256
659 (base32
660 "1mm4cvg3kphkkd8nwrhcg6d9nm5ar7mgc0wf6fxk6zck1l7xn8ky"))))
661 (build-system gnu-build-system)
662 (inputs
663 `(("python" ,python)))
664 (synopsis "Heuristics-driven menu generator")
665 (description
666 "MenuMaker is a menu generation utility for a number of X window
667 managers and desktop environments. It is capable of finding lots of
668 installed programs and generating a root menu consistent across all
669 supported window managers, so one will get (almost) the same menu in
670 all of them. Currently supported window managers include:
671
672 @enumerate
673 @item BlackBox
674 @item Deskmenu
675 @item FluxBox
676 @item IceWM
677 @item OpenBox
678 @item PekWM
679 @item WindowMaker
680 @item XFCE
681 @end enumerate\n")
682 (home-page "http://menumaker.sourceforge.net/")
683 (license license:bsd-2)))
684
685 (define-public keybinder
686 (package
687 (name "keybinder")
688 (version "0.3.1")
689 (source
690 (origin
691 (method url-fetch)
692 (uri (string-append "https://github.com/engla/keybinder/releases/"
693 "download/v" version "/keybinder-"
694 version ".tar.gz"))
695 (file-name (string-append name "-" version ".tar.gz"))
696 (sha256
697 (base32
698 "0h52hj3ay8mfhwvmfxbxlfyq74hifdk8wxgxp7fr4iy6189hg7w7"))))
699 (build-system gnu-build-system)
700 (inputs
701 `(("python-2" ,python-2)
702 ("gtk+-2" ,gtk+-2)))
703 (native-inputs
704 `(("python2-pygtk" ,python2-pygtk)
705 ("gtk-doc" ,gtk-doc)
706 ("pkg-config" ,pkg-config)))
707 (synopsis "Library for registering global keyboard shortcuts")
708 (description
709 "Keybinder is a library for registering global keyboard shortcuts.
710 Keybinder works with GTK-based applications using the X Window System.")
711 (home-page "https://github.com/engla/keybinder")
712 (license license:gpl2+)))
713
714 (define-public spectrwm
715 (package
716 (name "spectrwm")
717 (version "3.0.2")
718 (source
719 (origin
720 (method url-fetch)
721 (uri (let ((version-with-underscores
722 (string-join (string-split version #\.) "_")))
723 (string-append "https://github.com/conformal/spectrwm/archive/"
724 "SPECTRWM_" version-with-underscores ".tar.gz")))
725 (file-name (string-append name "-" version ".tar.gz"))
726 (sha256
727 (base32
728 "065b7j8s0lxw3p58fyf3c1mr5203pdm0kww42v245rlx0f005kl2"))))
729 (build-system gnu-build-system)
730 (arguments
731 `(#:make-flags (let ((pkg-config (lambda (flag)
732 (string-append
733 "$(shell pkg-config " flag " "
734 "xft fontconfig x11 libpng)"))))
735 (list
736 "CC=gcc"
737 (string-append "PREFIX=" %output)
738 (string-append "INCS=-I. " (pkg-config "--cflags"))
739 (string-append "LIBS=" (pkg-config "--libs") " -lm")))
740 #:tests? #f ;No test suite
741 #:phases
742 (modify-phases %standard-phases
743 (add-before 'build 'change-dir
744 (lambda _
745 (chdir "linux") #t))
746 (add-after 'change-dir 'patch-makefile
747 (lambda _
748 (substitute* "Makefile"
749 (("-g") ""))))
750 (add-after 'change-dir 'fix-freetype-include
751 (lambda _
752 (substitute* "Makefile"
753 (("/usr/include/freetype2")
754 (string-append (assoc-ref %build-inputs "freetype")
755 "/include/freetype2")))))
756 (delete 'configure)))) ;no 'configure' exists
757 (inputs
758 `(("freetype" ,freetype)
759 ("fontconfig" ,fontconfig)
760 ("libx11" ,libx11)
761 ("libxcursor" ,libxcursor)
762 ("libxrandr" ,libxrandr)
763 ("libxtst" ,libxtst)
764 ("libxft" ,libxft)
765 ("xcb-util" ,xcb-util)
766 ("xcb-util-wm" ,xcb-util-wm)
767 ("xcb-util-keysyms" ,xcb-util-keysyms)))
768 (native-inputs
769 `(("libxt" ,libxt)
770 ("pkg-config" ,pkg-config)))
771 (synopsis "Minimalistic automatic tiling window manager")
772 (description
773 "Spectrwm is a small dynamic tiling and reparenting window manager for X11.
774 It is inspired by Xmonad and dwm. Its major features include:
775
776 @itemize
777 @item Navigation anywhere on all screens with either the keyboard or mouse
778 @item Customizable status bar
779 @item Restartable without losing state
780 @item Quick launch menu
781 @item Many screen layouts possible with a few simple key strokes
782 @item Move/resize floating windows
783 @item Extended Window Manager Hints (EWMH) support
784 @item Configureable tiling
785 @item Adjustable tile gap allows for a true one pixel border
786 @item Customizable colors and border width
787 @end itemize\n")
788 (home-page "https://github.com/conformal/spectrwm")
789 (license license:isc)))