gnu: libfilezilla: Update to 0.16.0.
[jackhill/guix/guix.git] / gnu / packages / pretty-print.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
5 ;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
6 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages pretty-print)
25 #:use-module (guix packages)
26 #:use-module (guix licenses)
27 #:use-module (guix download)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix utils)
31 #:use-module (gnu packages)
32 #:use-module (gnu packages ghostscript)
33 #:use-module (gnu packages groff)
34 #:use-module (gnu packages imagemagick)
35 #:use-module (gnu packages gv)
36 #:use-module (gnu packages boost)
37 #:use-module (gnu packages bison)
38 #:use-module (gnu packages flex)
39 #:use-module (gnu packages gperf)
40 #:use-module (gnu packages lua)
41 #:use-module (gnu packages perl)
42 #:use-module (gnu packages pkg-config)
43 #:use-module (gnu packages compression))
44
45 (define-public a2ps
46 (package
47 (name "a2ps")
48 (version "4.14")
49 (source (origin
50 (method url-fetch)
51 (uri (string-append "mirror://gnu/a2ps/a2ps-"
52 version ".tar.gz"))
53 (sha256
54 (base32
55 "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))
56 (modules '((guix build utils)))
57 (snippet
58 ;; Remove timestamp from the installed 'README' file.
59 '(begin
60 (substitute* "etc/README.in"
61 (("@date@")
62 "1st of some month, sometime after 1970"))
63 #t))
64 (patches (search-patches
65 "a2ps-CVE-2001-1593.patch"
66 "a2ps-CVE-2014-0466.patch"))))
67 (build-system gnu-build-system)
68 (inputs
69 `(("psutils" ,psutils)
70 ("groff" ,groff)
71 ("gv" ,gv)
72 ("imagemagick" ,imagemagick)))
73 (native-inputs
74 `(("gperf" ,gperf)
75 ("perl" ,perl)))
76 (arguments
77 '(#:phases
78 (modify-phases %standard-phases
79 (add-before 'build 'patch-scripts
80 (lambda _
81 (substitute*
82 '("afm/make_fonts_map.sh"
83 "tests/defs"
84 "tests/backup.tst"
85 "tests/styles.tst")
86 (("/bin/rm") (which "rm")))))
87 (add-before 'check 'patch-test-files
88 ;; Alternatively, we could unpatch the shebangs in tstfiles
89 (lambda* (#:key inputs #:allow-other-keys)
90 (let ((perl (assoc-ref inputs "perl")))
91 (substitute* '("tests/ps-ref/includeres.ps"
92 "tests/gps-ref/includeres.ps")
93 (("/usr/local/bin/perl")
94 (string-append perl "/bin/perl"))))
95 ;; Some of the reference postscript contain a 'version 3'
96 ;; string that in inconsistent with the source text in the
97 ;; tstfiles directory. Erroneous search-and-replace?
98 (substitute* '("tests/ps-ref/InsertBlock.ps"
99 "tests/gps-ref/InsertBlock.ps"
100 "tests/ps-ref/bookie.ps"
101 "tests/gps-ref/bookie.ps")
102 (("version 3") "version 2"))
103 (substitute* '("tests/ps-ref/psmandup.ps"
104 "tests/gps-ref/psmandup.ps")
105 (("#! */bin/sh") (string-append
106 "#!" (which "sh")))))))))
107 (home-page "https://www.gnu.org/software/a2ps/")
108 (synopsis "Any file to PostScript, including pretty-printing")
109 (description
110 "GNU a2ps converts almost anything to a PostScript file, ready for
111 printing. It accomplishes this by being able to delegate files to external
112 handlers, such as Groff and Gzip. It handles as many steps as is necessary to
113 produce a pretty-printed file. It also includes some extra abilities for
114 special cases, such as pretty-printing \"--help\" output.")
115 (license gpl3+)))
116
117 (define-public trueprint
118 (package
119 (name "trueprint")
120 (version "5.4")
121 (source
122 (origin
123 (method url-fetch)
124 (uri (string-append "mirror://gnu/trueprint/trueprint-"
125 version ".tar.gz"))
126 (sha256
127 (base32
128 "13rkc0fga10xyf56yy9dnq95zndnfadkhxflnp24skszj21y8jqh"))))
129 (build-system gnu-build-system)
130 (arguments
131 ;; Must define DIFF_CMD for tests to pass
132 '(#:configure-flags '("CPPFLAGS=-DDIFF_CMD=\\\"diff\\\"")))
133 (home-page "https://www.gnu.org/software/trueprint/")
134 (synopsis "Pretty-print C sources and other plain text to PostScript")
135 (description
136 "GNU Trueprint translates C source code files as PostScript files.
137 In addition to the basic source code output, it can also perform diff-marking,
138 indentation counting, function and file indices and more.")
139 (license gpl2)))
140
141 (define-public enscript
142 (package
143 (name "enscript")
144 (version "1.6.6")
145 (source
146 (origin
147 (method url-fetch)
148 (uri (string-append "mirror://gnu/enscript/enscript-"
149 version ".tar.gz"))
150 (sha256
151 (base32
152 "1fy0ymvzrrvs889zanxcaxjfcxarm2d3k43c9frmbl1ld7dblmkd"))))
153 (build-system gnu-build-system)
154 (home-page "https://www.gnu.org/software/enscript/")
155 (synopsis "Generating PostScript, including pretty-printing")
156 (description
157 "GNU Enscript is a program to convert ASCII text files to PostScript,
158 HTML or RTF formats, to be stored in files or sent immediately to a printer.
159 It also includes the capability to perform syntax highlighting for several
160 different programming languages.")
161 (license gpl3+)))
162
163 (define-public fmt
164 (package
165 (name "fmt")
166 (version "5.3.0")
167 (source (origin
168 (method url-fetch)
169 (uri (string-append
170 "https://github.com/fmtlib/fmt/releases/download/"
171 version "/fmt-" version ".zip"))
172 (sha256
173 (base32
174 "0p51nhmvjniqlffmmb9djhprnclvm448f2vkdxymvxw307hl21sc"))))
175 (build-system cmake-build-system)
176 (native-inputs
177 `(("unzip" ,unzip)))
178 (home-page "http://fmtlib.net/")
179 (synopsis "Small and fast C++ formatting library")
180 (description
181 "@code{fmt} (formerly @code{cppformat}) is a formatting library for C++.
182 It can be used as a safe alternative to @code{printf} or as a fast alternative
183 to @code{IOStreams}.")
184 ;; The library is bsd-2, but documentation and tests include other licenses.
185 (license (list bsd-2 bsd-3 psfl))))
186
187 (define-public source-highlight
188 (package
189 (name "source-highlight")
190 (version "3.1.8")
191 (source
192 (origin
193 (method url-fetch)
194 (uri (string-append "mirror://gnu/src-highlite/source-highlight-"
195 version ".tar.gz"))
196 (sha256
197 (base32
198 "18xdalxg7yzrxc1njzgw7aryq2jdm7zq2yqz41sc7k6il5z6lcq1"))))
199 (build-system gnu-build-system)
200 ;; The ctags that comes with emacs does not support the --excmd options,
201 ;; so can't be used
202 (inputs
203 `(("boost" ,boost)))
204 (native-inputs
205 `(("bison" ,bison)
206 ("flex" ,flex)))
207 (arguments
208 `(#:configure-flags
209 (list (string-append "--with-boost="
210 (assoc-ref %build-inputs "boost")))
211 #:parallel-tests? #f ;There appear to be race conditions
212 #:phases
213 (modify-phases %standard-phases
214 (add-before 'check 'patch-test-files
215 (lambda _
216 ;; Unpatch shebangs in test input so that source-highlight
217 ;; is still able to infer input language
218 (substitute* '("tests/test.sh"
219 "tests/test2.sh"
220 "tests/test.tcl")
221 (((string-append "#! *" (which "sh"))) "#!/bin/sh"))
222 ;; Initial patching unrecoverably removes whitespace, so
223 ;; remove it also in the comparison output.
224 (substitute* '("tests/test.sh.html"
225 "tests/test2.sh.html"
226 "tests/test.tcl.html")
227 (("#! */bin/sh") "#!/bin/sh"))
228 #t)))))
229 (home-page "https://www.gnu.org/software/src-highlite/")
230 (synopsis "Produce a document with syntax highlighting from a source file")
231 (description
232 "GNU source-highlight reads in a source code file and produces an output
233 file in which the keywords are highlighted in different colors to designate
234 their syntactic role. It supports over 150 different languages and it can
235 output to 8 different formats, including HTML, LaTeX and ODF. It can also
236 output to ANSI color escape sequences, so that highlighted source code can be
237 seen in a terminal.")
238 (license gpl3+)
239 (properties '((ftp-directory . "/gnu/src-highlite")))))
240
241 (define-public highlight
242 (package
243 (name "highlight")
244 (version "3.50")
245 (source
246 (origin
247 (method url-fetch)
248 (uri (string-append "http://www.andre-simon.de/zip/highlight-"
249 version ".tar.bz2"))
250 (sha256
251 (base32 "0frcq12zy3dqfhwwzylm10ydp7zp51w9jlijm23zvx09daslg1bl"))))
252 (build-system gnu-build-system)
253 (arguments
254 `(#:tests? #f ; no tests
255 #:make-flags
256 (let ((confdir (string-append %output "/share/highlight/config/")))
257 (list (string-append "PREFIX=" %output)
258 (string-append "HL_CONFIG_DIR=" confdir)
259 (string-append "conf_dir=" confdir)))
260 #:phases
261 (modify-phases %standard-phases
262 (delete 'configure) ; no configure script
263 (add-after 'unpack 'fix-search-for-lua
264 (lambda _
265 (substitute* "src/makefile"
266 (("(LUA_PKG_NAME=).*" _ assignment)
267 (string-append assignment "lua-" ,(version-major+minor
268 (package-version lua))
269 "\n")))
270 #t)))))
271 (inputs
272 `(("lua" ,lua)
273 ("boost" ,boost)))
274 (native-inputs
275 `(("pkg-config" ,pkg-config)))
276 (home-page "http://www.andre-simon.de/doku/highlight/en/highlight.php")
277 (synopsis "Convert code to documents with syntax highlighting")
278 (description "Highlight converts source code to HTML, XHTML, RTF, LaTeX,
279 TeX, SVG, BBCode and terminal escape sequences with colored syntax
280 highlighting. Language definitions and color themes are customizable.")
281 (license gpl3+)))