Merge branch 'staging'
[jackhill/guix/guix.git] / gnu / packages / openstack.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016, 2017, 2019 Clément Lassieur <clement@lassieur.org>
5 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
8 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages openstack)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages gnupg)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages python-check)
31 #:use-module (gnu packages python-crypto)
32 #:use-module (gnu packages python-web)
33 #:use-module (gnu packages python-xyz)
34 #:use-module (gnu packages sphinx)
35 #:use-module (gnu packages ssh)
36 #:use-module (gnu packages time)
37 #:use-module (gnu packages tls)
38 #:use-module (gnu packages version-control)
39 #:use-module (gnu packages xml)
40 #:use-module (guix build-system python)
41 #:use-module (guix download)
42 #:use-module ((guix licenses)
43 #:select (asl2.0))
44 #:use-module (guix packages)
45 #:use-module (srfi srfi-1))
46
47 (define-public python-bandit
48 (package
49 (name "python-bandit")
50 (version "1.6.2")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (pypi-uri "bandit" version))
55 (sha256
56 (base32
57 "0rb034c99pyhb4a60z7f2kz40cjydhm8m9v2blaal1rmhlam7rs1"))))
58 (build-system python-build-system)
59 (arguments
60 ;; The tests are disabled to avoid a circular dependency with
61 ;; python-stestr.
62 `(#:tests? #f))
63 (propagated-inputs
64 `(("python-gitpython" ,python-gitpython)
65 ("python-pyyaml" ,python-pyyaml)
66 ("python-six" ,python-six)
67 ("python-stevedore" ,python-stevedore)))
68 (native-inputs
69 `(("python-pbr" ,python-pbr)))
70 (home-page "https://github.com/PyCQA/bandit")
71 (synopsis "Security oriented static analyser for python code")
72 (description "Bandit is a tool designed to find common security issues in
73 Python code. To do this Bandit processes each file, builds an AST from it,
74 and runs appropriate plugins against the AST nodes. Once Bandit has finished
75 scanning all the files it generates a report.")
76 (license asl2.0)))
77
78 (define-public python-cliff
79 (package
80 (name "python-cliff")
81 (version "3.5.0")
82 (source
83 (origin
84 (method url-fetch)
85 (uri (pypi-uri "cliff" version))
86 (sha256
87 (base32
88 "0n8pzr0mnn9lq2mykds69ij2xrn0fsirh4ndmkx0mzydbx5niysv"))))
89 (build-system python-build-system)
90 (arguments
91 `(#:tests? #f))
92 (native-inputs
93 `(("python-pbr" ,python-pbr)))
94 (propagated-inputs
95 `(("python-cmd2" ,python-cmd2)
96 ("python-prettytable" ,python-prettytable)
97 ("python-pyparsing" ,python-pyparsing)
98 ("python-pyyaml" ,python-pyyaml)
99 ("python-bandit" ,python-bandit)
100 ("python-stevedore" ,python-stevedore)))
101 (home-page "https://opendev.org/openstack/cliff")
102 (synopsis "Framework for building command line programs")
103 (description "The @code{cliff} framework allows creating multi-level
104 commands such as those of @command{subversion} and @command{git}, where the
105 main program handles some basic argument parsing and then invokes a
106 sub-command to do the work. It uses plugins to define sub-commands, output
107 formatters, and other extensions.")
108 (license asl2.0)))
109
110 (define-public python-debtcollector
111 (package
112 (name "python-debtcollector")
113 (version "1.19.0")
114 (source
115 (origin
116 (method url-fetch)
117 (uri (pypi-uri "debtcollector" version))
118 (sha256
119 (base32
120 "06c7vyn184y9f0lsrwaz13aq63hdz5fjrd191b8nifx6acsni42f"))))
121 (build-system python-build-system)
122 (propagated-inputs
123 `(("python-pbr" ,python-pbr)
124 ("python-six" ,python-six)
125 ("python-wrapt" ,python-wrapt)))
126 (native-inputs
127 `(;; Tests.
128 ("python-subunit" ,python-subunit)
129 ("python-testrepository" ,python-testrepository)
130 ("python-testtools" ,python-testtools)))
131 (home-page "https://www.openstack.org/")
132 (synopsis
133 "Find deprecated patterns and strategies in Python code")
134 (description
135 "This package provides a collection of Python deprecation patterns and
136 strategies that help you collect your technical debt in a non-destructive
137 manner.")
138 (license asl2.0)))
139
140 (define-public python-hacking
141 (package
142 (name "python-hacking")
143 (version "4.0.0")
144 (source
145 (origin
146 (method url-fetch)
147 (uri (pypi-uri "hacking" version))
148 (sha256
149 (base32
150 "062rvbkvbavqqz55f7q00ikwipkn5j0rdls1rrajdbfwgckjcrsm"))))
151 (build-system python-build-system)
152 (propagated-inputs
153 `(("python-flake8" ,python-flake8)))
154 (native-inputs
155 `( ;; Tests
156 ("python-coverage" ,python-coverage)
157 ("python-ddt" ,python-ddt)
158 ("python-dnspython" ,python-dnspython)
159 ("python-fixtures" ,python-fixtures)
160 ("python-eventlet" ,python-eventlet)
161 ("python-mock" ,python-mock)
162 ("python-monotonic" ,python-monotonic)
163 ("python-subunit" ,python-subunit)
164 ("python-stestr" ,python-stestr)
165 ("python-testscenarios" ,python-testscenarios)
166 ("python-testtools" ,python-testtools)))
167 (home-page "https://github.com/openstack-dev/hacking")
168 (synopsis "OpenStack hacking guideline enforcement")
169 (description
170 "Python-hacking is a set of flake8 plugins that test and enforce the
171 @uref{http://docs.openstack.org/developer/hacking/, OpenStack style
172 guidelines}.")
173 (license asl2.0)))
174
175 (define-public python-mox3
176 (package
177 (name "python-mox3")
178 (version "0.24.0")
179 (source
180 (origin
181 (method url-fetch)
182 (uri (pypi-uri "mox3" version))
183 (patches (search-patches "python-mox3-python3.6-compat.patch"))
184 (sha256
185 (base32
186 "0w58adwv7q9wzvmq9mlrk2asfk73myq9fpwy7mjkzsz3baa95zf5"))))
187 (build-system python-build-system)
188 (propagated-inputs
189 `(("python-fixtures" ,python-fixtures)
190 ("python-pbr" ,python-pbr)))
191 (native-inputs
192 `(("python-openstackdocstheme" ,python-openstackdocstheme)
193 ("python-sphinx" ,python-sphinx)
194 ("python-subunit" ,python-subunit)
195 ("python-testrepository" ,python-testrepository)
196 ("python-testtools" ,python-testtools)))
197 (home-page "https://www.openstack.org/")
198 (synopsis "Mock object framework for Python")
199 (description
200 "Mox3 is an unofficial port of the @uref{https://code.google.com/p/pymox/,
201 Google mox framework} to Python 3. It was meant to be as compatible
202 with mox as possible, but small enhancements have been made.")
203 (license asl2.0)))
204
205 (define-public python-openstackdocstheme
206 (package
207 (name "python-openstackdocstheme")
208 (version "1.18.1")
209 (source (origin
210 (method url-fetch)
211 (uri (pypi-uri "openstackdocstheme" version))
212 (sha256
213 (base32
214 "1ki5204rjdqjvr8xr9w2qc1z6b6d2i5jas0i70xzkf9njlzjzv2r"))))
215 (build-system python-build-system)
216 (arguments
217 ;; FIXME: Tests require an old version of python-hacking, which in
218 ;; turn depends on mox3 which depends on this package.
219 `(#:tests? #f))
220 (propagated-inputs
221 `(("python-dulwich" ,python-dulwich)
222 ("python-pbr" ,python-pbr)))
223 (native-inputs
224 `(("python-sphinx" ,python-sphinx)))
225 (home-page "https://docs.openstack.org/openstackdocstheme/latest/")
226 (synopsis "OpenStack Docs Theme")
227 (description
228 "This package provides themes and extensions for Sphinx for publishing
229 to docs.openstack.org and developer.openstack.org.")
230 (license asl2.0)))
231
232 (define-public python-os-client-config
233 (package
234 (name "python-os-client-config")
235 (version "1.12.0")
236 (source
237 (origin
238 (method url-fetch)
239 (uri (pypi-uri "os-client-config" version))
240 (sha256
241 (base32
242 "1vjn7667pswnmpqv6ngwyqm2xn46w90hi5b4pv2grwfz751cn1lf"))))
243 (build-system python-build-system)
244 (arguments
245 `(#:tests? #f)) ;; Circular dependency with python-oslotest
246 (propagated-inputs
247 `(("python-appdirs" ,python-appdirs)
248 ("python-pyyaml" ,python-pyyaml)))
249 (native-inputs
250 `(("python-pbr" ,python-pbr)
251 ("python-fixtures" ,python-fixtures)
252 ("python-mimeparse" ,python-mimeparse)
253 ("python-testrepository" ,python-testrepository)
254 ("python-testscenarios" ,python-testscenarios)
255 ("python-testtools" ,python-testtools)))
256 (home-page "https://www.openstack.org/")
257 (synopsis
258 "OpenStack Client Configuration Library")
259 (description
260 "The OpenStack Client Configuration Library is a library for collecting
261 client configuration for using an OpenStack cloud in a consistent and
262 comprehensive manner.")
263 (license asl2.0)))
264
265 (define-public python-os-testr
266 (package
267 (name "python-os-testr")
268 (version "0.8.0")
269 (source
270 (origin
271 (method url-fetch)
272 (uri (pypi-uri "os-testr" version))
273 (sha256
274 (base32
275 "0mknd9hlmxmihr755gjkxyjp180380jajq5i3zm34q7y7bi62lss"))))
276 (build-system python-build-system)
277 (arguments
278 ;; os-testr uses itself to run the tests. It seems like pbr writes the
279 ;; exectuable in the virtualenv when using tox. Not sure how to do this
280 ;; when building the package. Skip the tests for now.
281 `(#:tests? #f))
282 (propagated-inputs
283 `(("python-subunit" ,python-subunit)))
284 (native-inputs
285 `(("python-pbr" ,python-pbr)
286 ("python-testtools" ,python-testtools)
287 ("python-babel" ,python-babel)))
288 (home-page "https://www.openstack.org/")
289 (synopsis "Testr wrapper to provide functionality for OpenStack projects")
290 (description
291 "Os-testr provides developers with a testr wrapper and an output filter
292 for subunit.")
293 (license asl2.0)))
294
295 (define-public python-stevedore
296 (package
297 (name "python-stevedore")
298 (version "3.2.2")
299 (source
300 (origin
301 (method url-fetch)
302 (uri (pypi-uri "stevedore" version))
303 (sha256
304 (base32
305 "1w11lm293afzb73iq0ba9wnmr2rjwymnhr92km4a4xrs7a5qcigq"))))
306 (build-system python-build-system)
307 (arguments
308 ;; The tests are disabled to avoid a circular dependency with
309 ;; python-stestr.
310 `(#:tests? #f))
311 (native-inputs
312 `(("python-pbr" ,python-pbr)))
313 (home-page "https://github.com/dreamhost/stevedore")
314 (synopsis "Manage dynamic plugins for Python applications")
315 (description
316 "Python makes loading code dynamically easy, allowing you to configure
317 and extend your application by discovering and loading extensions (\"plugins\")
318 at runtime. Many applications implement their own library for doing this,
319 using __import__ or importlib. Stevedore avoids creating yet another extension
320 mechanism by building on top of setuptools entry points. The code for managing
321 entry points tends to be repetitive, though, so stevedore provides manager
322 classes for implementing common patterns for using dynamically loaded
323 extensions.")
324 (license asl2.0)))
325
326 (define-public python-tempest-lib
327 (package
328 (name "python-tempest-lib")
329 (version "1.0.0")
330 (source
331 (origin
332 (method url-fetch)
333 (uri (pypi-uri "tempest-lib" version))
334 (sha256
335 (base32
336 "1cpp2vwmawpd29hjsklsps181lq2ah91cl412qvpnz228nf9sqn5"))))
337 (build-system python-build-system)
338 (arguments
339 `(#:tests? #f ; FIXME: Requires oslo.log >= 1.14.0.
340 #:phases
341 (modify-phases %standard-phases
342 (add-before
343 'check 'pre-check
344 (lambda _
345 (substitute* "tempest_lib/tests/cli/test_execute.py"
346 (("/bin/ls") (which "ls"))))))))
347 (propagated-inputs
348 `(("python-fixtures" ,python-fixtures)
349 ("python-httplib2" ,python-httplib2)
350 ("python-iso8601" ,python-iso8601)
351 ("python-jsonschema" ,python-jsonschema)
352 ("python-oslo.log" ,python-oslo.log)
353 ("python-paramiko" ,python-paramiko)
354 ("python-pbr" ,python-pbr)
355 ("python-six" ,python-six)))
356 (native-inputs
357 `(("python-babel" ,python-babel)
358 ("python-mock" ,python-mock)
359 ("python-os-testr" ,python-os-testr)
360 ("python-oslotest" ,python-oslotest)))
361 (home-page "https://www.openstack.org/")
362 (synopsis "OpenStack functional testing library")
363 (description
364 "Tempest-lib is a functional testing library for OpenStack. It provides
365 common features used in Tempest.")
366 (license asl2.0)))
367
368 \f
369 ;;;
370 ;;; Packages from the Oslo library
371 ;;;
372
373 (define-public python-oslo.config
374 (package
375 (name "python-oslo.config")
376 (version "5.2.0")
377 (source
378 (origin
379 (method url-fetch)
380 (uri (pypi-uri "oslo.config" version))
381 (sha256
382 (base32
383 "0ymf7jxbq29fifyvkwhfiys1qvljqfxdw8ajwzwaf3yiqidgpxqd"))))
384 (build-system python-build-system)
385 (propagated-inputs
386 `(("python-debtcollector" ,python-debtcollector)
387 ("python-netaddr" ,python-netaddr)
388 ("python-oslo.i18n" ,python-oslo.i18n)
389 ("python-pbr" ,python-pbr)
390 ("python-rfc3986" ,python-rfc3986)
391 ("python-six" ,python-six)
392 ("python-stevedore" ,python-stevedore)
393 ("python-pyyaml" ,python-pyyaml)))
394 (native-inputs
395 `(("python-bandit" ,python-bandit)
396 ("python-coverage" ,python-coverage)
397 ("python-mock" ,python-mock)
398 ("python-openstackdocstheme" ,python-openstackdocstheme)
399 ("python-oslotest" ,python-oslotest)
400 ("python-reno" ,python-reno)
401 ("python-sphinx" ,python-sphinx)
402 ("python-testrepository" ,python-testrepository)
403 ("python-testscenarios" ,python-testscenarios)
404 ("python-testtools" ,python-testtools)))
405 (home-page "https://launchpad.net/oslo")
406 (synopsis "Oslo Configuration API")
407 (description
408 "The Oslo configuration API supports parsing command line arguments and
409 .ini style configuration files.")
410 (license asl2.0)))
411
412 (define-public python-oslo.context
413 (package
414 (name "python-oslo.context")
415 (version "3.1.1")
416 (source
417 (origin
418 (method url-fetch)
419 (uri (pypi-uri "oslo.context" version))
420 (sha256
421 (base32
422 "1l2z186rkd9acrb2ygf53yrdc1lgf7cy1akbhm21kgkzind4p2r6"))))
423 (build-system python-build-system)
424 (arguments
425 `(#:phases (modify-phases %standard-phases
426 (add-after 'unpack 'relax-requirements
427 (lambda _
428 (substitute* "test-requirements.txt"
429 (("hacking>=3.0.1,<3.1.0")
430 "hacking>=3.0.1"))
431 #t)))))
432 (propagated-inputs
433 `(("python-debtcollector" ,python-debtcollector)))
434 (native-inputs
435 `(("python-bandit" ,python-bandit)
436 ("python-coverage" ,python-coverage)
437 ("python-fixtures" ,python-fixtures)
438 ("python-hacking" ,python-hacking)
439 ("python-oslotest" ,python-oslotest)
440 ("python-pbr" ,python-pbr)
441 ("python-stestr" ,python-stestr)))
442 (home-page "https://launchpad.net/oslo")
443 (synopsis "Oslo context library")
444 (description
445 "The Oslo context library has helpers to maintain useful information
446 about a request context. The request context is usually populated in the WSGI
447 pipeline and used by various modules such as logging.")
448 (license asl2.0)))
449
450 (define-public python-oslo.i18n
451 (package
452 (name "python-oslo.i18n")
453 (version "3.20.0")
454 (source
455 (origin
456 (method url-fetch)
457 (uri (pypi-uri "oslo.i18n" version))
458 (sha256
459 (base32
460 "0kjcdw4bk3mi4vqmqwhhq053kxbbbj05si6nwxd1pzx33z067ky3"))))
461 (build-system python-build-system)
462 (propagated-inputs
463 `(("python-babel" ,python-babel)
464 ("python-six" ,python-six)))
465 (native-inputs
466 `(("python-pbr" ,python-pbr)
467 ;; Tests
468 ("python-mock" ,python-mock)
469 ("python-mox3" ,python-mox3)
470 ("python-oslotest" ,python-oslotest)
471 ("python-testscenarios" ,python-testscenarios)))
472 (home-page "https://launchpad.net/oslo")
473 (synopsis "Oslo internationalization (i18n) library")
474 (description
475 "The oslo.i18n library contain utilities for working with
476 internationalization (i18n) features, especially translation for text strings
477 in an application or library.")
478 (license asl2.0)))
479
480 (define-public python-oslo.log
481 (package
482 (name "python-oslo.log")
483 (version "3.36.0")
484 (source
485 (origin
486 (method url-fetch)
487 (uri (pypi-uri "oslo.log" version))
488 (sha256
489 (base32
490 "0h7hplf1h8k24v75m3mq1jlrl74x5ynyr4hwgffsg5campxnza4x"))))
491 (build-system python-build-system)
492 (propagated-inputs
493 `(("python-dateutil" ,python-dateutil)
494 ("python-debtcollector" ,python-debtcollector)
495 ("python-monotonic" ,python-monotonic)
496 ("python-oslo.config" ,python-oslo.config)
497 ("python-oslo.context" ,python-oslo.context)
498 ("python-oslo.i18n" ,python-oslo.i18n)
499 ("python-oslo.utils" ,python-oslo.utils)
500 ("python-oslo.serialization" ,python-oslo.serialization)
501 ("python-pbr" ,python-pbr)
502 ("python-pyinotify" ,python-pyinotify)
503 ("python-six" ,python-six)))
504 (native-inputs
505 `(("python-mock" ,python-mock)
506 ("python-oslotest" ,python-oslotest)
507 ("python-subunit" ,python-subunit)
508 ("python-testrepository" ,python-testrepository)
509 ("python-testtools" ,python-testtools)))
510 (home-page "https://launchpad.net/oslo")
511 (synopsis "Python logging library of the Oslo project")
512 (description
513 "The oslo.log (logging) configuration library provides standardized
514 configuration for all OpenStack projects. It also provides custom formatters,
515 handlers and support for context specific logging (like resource id’s etc).")
516 (license asl2.0)))
517
518 (define-public python-oslo.serialization
519 (package
520 (name "python-oslo.serialization")
521 (version "2.24.0")
522 (source
523 (origin
524 (method url-fetch)
525 (uri (pypi-uri "oslo.serialization" version))
526 (sha256
527 (base32
528 "08bxkp98c617y58x630xq44iiffm7f0f3cwh6zbnlkgq0zgh7jk1"))))
529 (build-system python-build-system)
530 (propagated-inputs
531 `(("python-msgpack" ,python-msgpack)
532 ("python-netaddr" ,python-netaddr)
533 ("python-oslo.utils" ,python-oslo.utils)
534 ("python-six" ,python-six)
535 ("python-pytz" ,python-pytz)))
536 (native-inputs
537 `(("python-pbr" ,python-pbr)
538 ;; Tests.
539 ("python-mock" ,python-mock)
540 ("python-oslo.i18n" ,python-oslo.i18n)
541 ("python-oslotest" ,python-oslotest)))
542 (home-page "https://launchpad.net/oslo")
543 (synopsis "Oslo serialization library")
544 (description
545 "The oslo.serialization library provides support for representing objects
546 in transmittable and storable formats, such as JSON and MessagePack.")
547 (license asl2.0)))
548
549 (define-public python-reno
550 (package
551 (name "python-reno")
552 (version "2.7.0")
553 (source
554 (origin
555 (method url-fetch)
556 (uri (pypi-uri "reno" version))
557 (sha256
558 (base32 "0gwzi5dvacqx43smxl3rd1z33npn7gfhm50bvgmq90fib2q431wc"))))
559 (build-system python-build-system)
560 (arguments
561 `(#:phases
562 (modify-phases %standard-phases
563 (add-before 'check 'init-git
564 (lambda _
565 ;; reno expects a git repo
566 (invoke "git" "init"))))))
567 (propagated-inputs
568 `(("python-dulwich" ,python-dulwich)
569 ("python-pbr" ,python-pbr)
570 ("python-pyyaml" ,python-pyyaml)
571 ("python-six" ,python-six)))
572 (native-inputs
573 `(("python-testtools" ,python-testtools)
574 ("python-testscenarios" ,python-testscenarios)
575 ("python-testrepository" ,python-testrepository)
576 ("python-mock" ,python-mock)
577 ("python-docutils" ,python-docutils)
578 ("python-sphinx" ,python-sphinx)
579 ("gnupg" ,gnupg)
580 ("git" ,git-minimal)))
581 (home-page "https://docs.openstack.org/reno/latest/")
582 (synopsis "Release notes manager")
583 (description "Reno is a tool for storing release notes in a git repository
584 and building documentation from them.")
585 (license asl2.0)))
586
587 (define-public python-oslosphinx
588 (package
589 (name "python-oslosphinx")
590 (version "4.18.0")
591 (source
592 (origin
593 (method url-fetch)
594 (uri (pypi-uri "oslosphinx" version))
595 (sha256
596 (base32
597 "1xm41857vzrzjmnyi6bqirg4i5qa61v7wxcsdc4q1nzgr3ndgz5k"))))
598 (build-system python-build-system)
599 (arguments
600 `(#:phases
601 (modify-phases %standard-phases
602 (add-after 'unpack 'relax-requirements
603 (lambda _
604 (substitute* "test-requirements.txt"
605 (("hacking!=0.13.0,<0.14,>=0.12.0")
606 "hacking!=0.13.0,>=0.12.0"))
607 #t)))))
608 (propagated-inputs
609 `(("python-requests" ,python-requests)))
610 (native-inputs
611 `(("python-hacking" ,python-hacking)
612 ("python-openstackdocstheme" ,python-openstackdocstheme)
613 ("python-pbr" ,python-pbr)
614 ("python-reno" ,python-reno)
615 ("python-sphinx" ,python-sphinx)))
616 (home-page "https://www.openstack.org/")
617 (synopsis "OpenStack sphinx extensions and theme")
618 (description "This package provides themes and extensions for Sphinx
619 documentation from the OpenStack project.")
620 (license asl2.0)))
621
622 (define-public python-oslotest
623 (package
624 (name "python-oslotest")
625 (version "4.4.1")
626 (source
627 (origin
628 (method url-fetch)
629 (uri (pypi-uri "oslotest" version))
630 (sha256
631 (base32
632 "0r50sz55m8ljv2vk1k7sp88iz1iqq4p9w6kb8hn8g8c50r9zdi5i"))))
633 (build-system python-build-system)
634 (arguments
635 ;; The tests are disabled to avoid a circular dependency with oslo.config.
636 `(#:tests? #f))
637 (propagated-inputs
638 `(("python-fixtures" ,python-fixtures)
639 ("python-six" ,python-six)
640 ("python-subunit" ,python-subunit)
641 ("python-testtools" ,python-testtools)))
642 (home-page "https://launchpad.net/oslo")
643 (synopsis "Oslo test framework")
644 (description "The Oslo Test framework provides common fixtures, support
645 for debugging, and better support for mocking results.")
646 (license asl2.0)))
647
648 (define-public python-oslo.utils
649 (package
650 (name "python-oslo.utils")
651 (version "3.36.2")
652 (source
653 (origin
654 (method url-fetch)
655 (uri (pypi-uri "oslo.utils" version))
656 (sha256
657 (base32
658 "1ipjcgg9z697wmibhcbg5lqpk5gafakdx4qkff3w255zr0mvw04r"))))
659 (build-system python-build-system)
660 (propagated-inputs
661 `(("python-debtcollector" ,python-debtcollector)
662 ("python-oslo.i18n" ,python-oslo.i18n)
663 ("python-iso8601" ,python-iso8601)
664 ("python-monotonic" ,python-monotonic)
665 ("python-netaddr" ,python-netaddr)
666 ("python-netifaces" ,python-netifaces)
667 ("python-pyparsing" ,python-pyparsing)
668 ("python-pytz" ,python-pytz)
669 ("python-six" ,python-six)))
670 (native-inputs
671 `(("python-pbr" ,python-pbr)
672 ;; Tests.
673 ("python-bandit" ,python-bandit)
674 ("python-ddt" ,python-ddt)
675 ("python-fixtures" ,python-fixtures)
676 ("python-oslo.config" ,python-oslo.config)
677 ("python-oslotest" ,python-oslotest)
678 ("python-mock" ,python-mock)
679 ("python-testrepository" ,python-testrepository)
680 ("python-testscenarios" ,python-testscenarios)
681 ("python-testtools" ,python-testtools)))
682 (home-page "https://launchpad.net/oslo")
683 (synopsis "Oslo utility library")
684 (description
685 "The @code{oslo.utils} library provides support for common utility type
686 functions, such as encoding, exception handling, string manipulation, and time
687 handling.")
688 (license asl2.0)))
689
690 (define-public python-keystoneclient
691 (package
692 (name "python-keystoneclient")
693 (version "1.8.1")
694 (source
695 (origin
696 (method url-fetch)
697 (uri (pypi-uri "python-keystoneclient" version))
698 (sha256
699 (base32
700 "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
701 (build-system python-build-system)
702 (arguments
703 '(#:tests? #f)) ; FIXME: Many tests are failing.
704 (native-inputs
705 `(("python-sphinx" ,python-sphinx)
706 ;; and some packages for the tests
707 ("openssl" ,openssl)
708 ("python-coverage" ,python-coverage)
709 ("python-discover" ,python-discover)
710 ("python-fixtures" ,python-fixtures)
711 ("python-hacking" ,python-hacking)
712 ("python-keyring" ,python-keyring)
713 ("python-lxml" ,python-lxml)
714 ("python-mock" ,python-mock)
715 ("python-mox3" ,python-mox3)
716 ("python-oauthlib" ,python-oauthlib)
717 ("python-oslosphinx" ,python-oslosphinx)
718 ("python-oslotest" ,python-oslotest)
719 ("python-pycrypto" ,python-pycrypto)
720 ("python-requests-mock" ,python-requests-mock)
721 ("python-temptest-lib" ,python-tempest-lib)
722 ("python-testrepository" ,python-testrepository)
723 ("python-testresources" ,python-testresources)
724 ("python-testtools" ,python-testtools)
725 ("python-webob" ,python-webob)))
726 (propagated-inputs
727 `(("python-babel" ,python-babel)
728 ("python-debtcollector" ,python-debtcollector)
729 ("python-iso8601" ,python-iso8601)
730 ("python-netaddr" ,python-netaddr)
731 ("python-oslo.config" ,python-oslo.config)
732 ("python-oslo.i18n" ,python-oslo.i18n)
733 ("python-oslo.serialization" ,python-oslo.serialization)
734 ("python-oslo.utils" ,python-oslo.utils)
735 ("python-pbr" ,python-pbr)
736 ("python-prettytable" ,python-prettytable)
737 ("python-requests" ,python-requests)
738 ("python-six" ,python-six)
739 ("python-stevedore" ,python-stevedore)))
740 (home-page "https://www.openstack.org/")
741 (synopsis "Client Library for OpenStack Identity")
742 (description
743 "Python-keystoneclient is the identity service used by OpenStack for
744 authentication (authN) and high-level authorization (authZ). It currently
745 supports token-based authN with user/service authZ, and is scalable to support
746 OAuth, SAML, and OpenID in future versions. Out of the box, Keystone uses
747 SQLite for its identity store database, with the option to connect to external
748 LDAP.")
749 (license asl2.0)))
750
751 (define-public python-swiftclient
752 (package
753 (name "python-swiftclient")
754 (version "2.6.0")
755 (source
756 (origin
757 (method url-fetch)
758 (uri (pypi-uri "python-swiftclient" version))
759 (sha256
760 (base32
761 "1j33l4z9vqh0scfncl4fxg01zr1hgqxhhai6gvcih1gccqm4nd7p"))))
762 (build-system python-build-system)
763 (native-inputs
764 `(("python-pbr" ,python-pbr)
765 ("python-sphinx" ,python-sphinx)
766 ;; The folloing packages are needed for the tests.
767 ("python-coverage" ,python-coverage)
768 ("python-discover" ,python-discover)
769 ("python-hacking" ,python-hacking)
770 ("python-mock" ,python-mock)
771 ("python-oslosphinx" ,python-oslosphinx)
772 ("python-keystoneclient" ,python-keystoneclient)
773 ("python-testrepository" ,python-testrepository)
774 ("python-testtools" ,python-testtools)))
775 (propagated-inputs
776 `(("python-requests" ,python-requests)
777 ("python-six" ,python-six)))
778 (home-page "https://www.openstack.org/")
779 (synopsis "OpenStack Object Storage API Client Library")
780 (description
781 "OpenStack Object Storage (code-named Swift) creates redundant, scalable
782 object storage using clusters of standardized servers to store petabytes of
783 accessible data. It is not a file system or real-time data storage system, but
784 rather a long-term storage system for a more permanent type of static data that
785 can be retrieved, leveraged, and then updated if necessary. Primary examples of
786 data that best fit this type of storage model are virtual machine images, photo
787 storage, email storage and backup archiving. Having no central \"brain\" or
788 master point of control provides greater scalability, redundancy and
789 permanence.")
790 (license asl2.0)))
791
792 (define-public python-git-review
793 (package
794 (name "python-git-review")
795 (version "1.28.0")
796 (source
797 (origin
798 (method url-fetch)
799 (uri (pypi-uri "git-review" version))
800 (sha256
801 (base32 "0nn17mfqvsa3ryjz53qjslmf60clc0vx2115kkj66h28p6vsnflf"))))
802 (build-system python-build-system)
803 (arguments
804 '(#:tests? #f ; tests require a running Gerrit server
805 #:phases
806 (modify-phases %standard-phases
807 (add-after 'install 'wrap-program
808 (lambda* (#:key inputs outputs #:allow-other-keys)
809 (let* ((out (assoc-ref outputs "out"))
810 (git (assoc-ref inputs "git"))
811 (openssh (assoc-ref inputs "openssh")))
812 (wrap-program (string-append out "/bin/git-review")
813 `("PATH" ":" prefix
814 ,(map (lambda (dir)
815 (string-append dir "/bin"))
816 (list git openssh)))))
817 #t)))))
818 (native-inputs
819 `(("python-pbr" ,python-pbr)))
820 (propagated-inputs
821 `(("python-requests" ,python-requests)))
822 (inputs
823 `(("git" ,git)
824 ("openssh" ,openssh)))
825 (home-page "https://docs.openstack.org/infra/git-review/")
826 (synopsis "Command-line tool for Gerrit")
827 (description
828 "Git-review is a command-line tool that helps submitting Git branches to
829 Gerrit for review, or fetching existing ones.")
830 (license asl2.0)))