gnu: Add ganeti.
[jackhill/guix/guix.git] / gnu / packages / patches / ganeti-shepherd-master-failover.patch
1 By default, master-failover will call "herd start ganeti-wconfd" with
2 extra arguments such as --force-node. That does not work with the
3 Shepherd, so the Guix service has a "force-start" action for this purpose.
4
5 diff --git a/lib/bootstrap.py b/lib/bootstrap.py
6 --- a/lib/bootstrap.py
7 +++ b/lib/bootstrap.py
8 @@ -1011,9 +1011,7 @@ def MasterFailover(no_voting=False):
9
10 try:
11 # Forcefully start WConfd so that we can access the configuration
12 - result = utils.RunCmd([pathutils.DAEMON_UTIL,
13 - "start", constants.WCONFD, "--force-node",
14 - "--no-voting", "--yes-do-it"])
15 + result = utils.RunCmd(["herd", "force-start", constants.WCONFD])
16 if result.failed:
17 raise errors.OpPrereqError("Could not start the configuration daemon,"
18 " command %s had exitcode %s and error %s" %